Advertisement:

Author Topic: Anti-spam  (Read 1211 times)

Offline Bigguy

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 12,974
  • Gender: Male
  • Be nice, or else....
    • smfbigguy on GitHub
    • What's Ur Beef
Anti-spam
« on: April 07, 2018, 09:13:16 PM »
I have been playin with registration on my site with different questions and such. My questions are not showing up and neither is the image verification. I get an error in the log:

GenericControls.template.php (Line 240)

I have not checked that line yet so i have no idea what it does. I had image verification on and questions and recaptcha I will try to get a screen shot if I can.

Offline Bigguy

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 12,974
  • Gender: Male
  • Be nice, or else....
    • smfbigguy on GitHub
    • What's Ur Beef
Re: Anti-spam
« Reply #1 on: April 07, 2018, 09:17:17 PM »
Screenshot

Offline Steve

  • Freak
  • SMF Friend
  • SMF Hero
  • *
  • Posts: 4,500
  • Gender: Male
  • I have not yet begun to procrastinate.
Re: Anti-spam
« Reply #2 on: April 08, 2018, 09:58:16 AM »
Does this happen in more than one browser?
Online Manual

Please do not PM me for support.

Offline Bigguy

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 12,974
  • Gender: Male
  • Be nice, or else....
    • smfbigguy on GitHub
    • What's Ur Beef
Re: Anti-spam
« Reply #3 on: April 08, 2018, 10:19:02 AM »
I just tried it in Sea Monkey browser and it's the same thing.

Offline Bigguy

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 12,974
  • Gender: Male
  • Be nice, or else....
    • smfbigguy on GitHub
    • What's Ur Beef
Re: Anti-spam
« Reply #4 on: April 08, 2018, 10:21:20 AM »
Line 235 to 252 is this:

Code: [Select]
            // Where in the question array is this question?
            $qIndex = $verify_context['show_visual'] ? $i - 1 : $i;

            echo '
                <div class="smalltext">
                    ', $verify_context['questions'][$qIndex]['q'], ':<br>
                    <input type="text" name="', $verify_id, '_vv[q][', $verify_context['questions'][$qIndex]['id'], ']" size="30" value="', $verify_context['questions'][$qIndex]['a'], '" ', $verify_context['questions'][$qIndex]['is_error'] ? 'style="border: 1px red solid;"' : '', ' tabindex="', $context['tabindex']++, '" required>
                </div>';
        }

        if ($display_type != 'single')
            echo '
            </div><!-- #verification_control_[i] -->';

        // If we were displaying just one and we did it, break.
        if ($display_type == 'single' && $verify_context['tracking'] == $i)
            break;
    }

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 51,286
Re: Anti-spam
« Reply #5 on: April 08, 2018, 01:57:16 PM »
what is the full error? just telling us there is an error on line xyz does not tell us what the system says the error actually is.

Offline Bigguy

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 12,974
  • Gender: Male
  • Be nice, or else....
    • smfbigguy on GitHub
    • What's Ur Beef
Re: Anti-spam
« Reply #6 on: April 08, 2018, 02:05:39 PM »
I understand that. I thought that posting the code someone may have been able to spot the error. That's all. I will get the error next time I turn it on and try to register and post here.

Offline Bigguy

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 12,974
  • Gender: Male
  • Be nice, or else....
    • smfbigguy on GitHub
    • What's Ur Beef
Re: Anti-spam
« Reply #7 on: April 08, 2018, 02:10:52 PM »
Hmm, seems there isn't one in the error log. I'll check in cpanel. Nothing there either.

Offline Bigguy

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 12,974
  • Gender: Male
  • Be nice, or else....
    • smfbigguy on GitHub
    • What's Ur Beef
Re: Anti-spam
« Reply #8 on: April 08, 2018, 02:16:56 PM »
When I try to add a question the box is there for the answer but no question.

Offline Bigguy

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 12,974
  • Gender: Male
  • Be nice, or else....
    • smfbigguy on GitHub
    • What's Ur Beef
Re: Anti-spam
« Reply #9 on: April 08, 2018, 02:19:26 PM »
OK, now there is an error when I turn on questions. It is:

Type of error: Undefined
  8: Undefined offset: 1  https://www.whatsurbeef.net/index.php?action=signup
file=L2hvbWUvd2hhdHN1cmJlZWYvcHVibGljX2h0bWwvVGhlbWVzL2RlZmF1bHQvR2VuZXJpY0NvbnRyb2xzLnRlbXBsYXRlLnBocA==;line=241]/home/public_html/Themes/default/GenericControls.template.php (Line 241)

Offline Bigguy

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 12,974
  • Gender: Male
  • Be nice, or else....
    • smfbigguy on GitHub
    • What's Ur Beef
Re: Anti-spam
« Reply #10 on: April 08, 2018, 03:00:21 PM »
I figured it out. Don't worry about this one. Completely my fault. Sorry to waste your time.