Advertisement:

Author Topic: 1.1.x upgrade to 2.0.x  (Read 849 times)

Offline Declan303

  • Newbie
  • *
  • Posts: 3
1.1.x upgrade to 2.0.x
« on: June 18, 2018, 04:43:30 AM »
I am going to upgrade an old forum to 2.0.15. I now have it patched up to 1.1.21 so wondering do I now have to upgrade to 2.0 and then apply the patches up to 2.0.15 or can I upgrade directly to 2.0.15?

TIA
Declan

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 68,759
    • Arantor on GitHub
Re: 1.1.x upgrade to 2.0.x
« Reply #1 on: June 18, 2018, 05:03:14 AM »
Upgrading SMF - go direct to 2.0.15, though you will need new mods and a new theme as these are not compatible between 1.1 and 2.0.
To assume is to hope that those who came before had the presence of mind and capacity to implement the dreams of those who would come after.

Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

Offline GigaWatt

  • Support Specialist
  • Sr. Member
  • *
  • Posts: 869
  • Gender: Male
    • Macedonian electronics forum
Re: 1.1.x upgrade to 2.0.x
« Reply #2 on: June 18, 2018, 11:28:00 AM »
I would also advise to uninstall any installed mods on the 1.1.x version of the forum and leave it in it's "virgin" state, then do the upgrade.
"This is really a generic concept about human thinking - when faced with large tasks we're naturally inclined to try to break them down into a bunch of smaller tasks that together make up the whole."

"A 500 error loosely translates to the webserver saying, "WTF?"..."

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 7,935
  • 'Tis the gift to be simple (duh)
Re: 1.1.x upgrade to 2.0.x
« Reply #3 on: June 18, 2018, 12:30:45 PM »
Check your php version, you must be at 5.4 minimum, should be at least 5.6.
« Last Edit: June 18, 2018, 12:58:37 PM by Sir Osis of Liver »

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 56,473
  • Gender: Male
    • Kindred-999 on GitHub
Re: 1.1.x upgrade to 2.0.x
« Reply #4 on: June 18, 2018, 12:31:32 PM »
I would also advise to uninstall any installed mods on the 1.1.x version of the forum and leave it in it's "virgin" state, then do the upgrade.


Well, that should not be necessary, since replacing all the files will effectively remove all 1.1.x mods.
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 68,759
    • Arantor on GitHub
Re: 1.1.x upgrade to 2.0.x
« Reply #5 on: June 18, 2018, 01:35:23 PM »
True, as unlike 2.0, I don’t know of any mods using hooks in 1.1. Though it’s possible to do ;)
To assume is to hope that those who came before had the presence of mind and capacity to implement the dreams of those who would come after.

Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

Offline GigaWatt

  • Support Specialist
  • Sr. Member
  • *
  • Posts: 869
  • Gender: Male
    • Macedonian electronics forum
Re: 1.1.x upgrade to 2.0.x
« Reply #6 on: June 18, 2018, 11:58:44 PM »
You're both probably right, but since I'm still having nightmares from my first 1.1.x to 2.0.x conversion on a heavily manually modded 1.1.x forum... I suggested it as a precaution.
"This is really a generic concept about human thinking - when faced with large tasks we're naturally inclined to try to break them down into a bunch of smaller tasks that together make up the whole."

"A 500 error loosely translates to the webserver saying, "WTF?"..."

Offline Declan303

  • Newbie
  • *
  • Posts: 3
Re: 1.1.x upgrade to 2.0.x
« Reply #7 on: June 28, 2018, 06:57:37 PM »
Now have 2.0.15 working . Thanks for the help everyone. Have one question at the moment. Anyone know where the path to the Smileys directory is set?

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 68,759
    • Arantor on GitHub
Re: 1.1.x upgrade to 2.0.x
« Reply #8 on: June 28, 2018, 06:59:07 PM »
Admin > Forum > Smileys and Message Icons > Settings
To assume is to hope that those who came before had the presence of mind and capacity to implement the dreams of those who would come after.

Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

Offline Declan303

  • Newbie
  • *
  • Posts: 3
Re: 1.1.x upgrade to 2.0.x
« Reply #9 on: June 29, 2018, 04:32:52 AM »
Thanks Arantor, looked everywhere for that and couldn't see it.  ;D ;D ;D ;D

Offline GigaWatt

  • Support Specialist
  • Sr. Member
  • *
  • Posts: 869
  • Gender: Male
    • Macedonian electronics forum
Re: 1.1.x upgrade to 2.0.x
« Reply #10 on: June 29, 2018, 05:27:54 AM »
Can the thread be marked as solved?
"This is really a generic concept about human thinking - when faced with large tasks we're naturally inclined to try to break them down into a bunch of smaller tasks that together make up the whole."

"A 500 error loosely translates to the webserver saying, "WTF?"..."