• Welcome to Simple Machines Community Forum. Please login or sign up.
December 04, 2021, 11:29:49 PM

News:

Bored?  Looking to kill some time?  Want to chat with other SMF users?  Join us in IRC chat or Discord


Converting PHPfusion 7.02.07 to SMF 2.0.15

Started by CarstenP, November 10, 2018, 09:46:35 AM

Previous topic - Next topic

CarstenP

I'm trying hard to convert my site from PHPfusion 7.02.07 to SMF 2.0.15 to getter better support and updates.

When executing convert.php i get "Unknown system variable 'SQL_MAX_JOIN_SIZE'"

I have then removed the routine "// Attempt to allow big selects, only for mysql so far though." as described several in several tropics. but then ends up with the following messaged. (also shown in attachment)

Parse error: syntax error, unexpected 'elseif' (T_ELSEIF) in xxxxxx/nytforum/convert.php on line 2524

I'm not that strong in this coding and I may not have removed the correct string for the "// Attempt to allow big selects, only for mysql so far though." fix.

All suggestions would be appreciated

Regards
Carsten


vbgamer45

Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

CarstenP

The convert.php that I have tried to modify is attached.

It may be that I'm just a clown to do this. Haven't worked with any coding since Turbo Pascal back in the early 1990's

vbgamer45

Is that the modified version? I am not seeing errors in that file
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

CarstenP

Hi

It has been changed as described in attachment incl. the last error messaged I get

Regards
Carsten

vbgamer45

Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

CarstenP

Hi

Tried it and got the attached error messaged

vbgamer45

Use SMF 2.0.13 I find that works the best when upgrading. seems like there are bugs in the upgrade process.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

CarstenP


CarstenP

All most there, I got an error with the attachments see attached file.

And then I cannot log on to the page but I believe that I have seen that I have to run some kind of file to help on that, but now I cannot find it ?

And thee are no post visible in any of the foar's ?

Regards
Carsten

CarstenP

November 14, 2018, 12:09:12 PM #10 Last Edit: November 14, 2018, 12:45:29 PM by CarstenP
Ok today's status.

I have installed SMF 2.0.13

Looked around in different threads found some hints and now it has finished converting with out errors, even Log-on works  8)

Not all updates from the old forum is there but that is acceptable (compared to the loss of the full site)

Issues left: There are no pictures visible in the posts and if I go to modify there are no attachment shown either, but if I create a new post with an attachment it is visible ?? Any suggestions to solve that  ? I have checked and all the files are present in the attachments folder.

Regards
Carsten

Looking

This may be of help to you: repair settings. Understanding where it goes and what it does: What is repair_settings.php? Unless its something more that happened during conversion.

CarstenP

Hi Looking

Had a look at the suggested file and what is had of setting, it think that something went wrong during the converting.

I'll do a new clean install and then use the files I have modified once more and hope to reach the goal (I have only until the Nov 30 as my hosting provider is cancelling the support all PHP rev below 7.2 and my existing PHPFusion site do not support PHPH 7.2)

Looking

When done, look at the database to see if the data is there and not just how it looks from the forum side.

Illori

you do know that SMF 2.0 does not support php 7.2 at this point either?

CarstenP

Quote from: Illori on November 15, 2018, 11:45:36 AM
you do know that SMF 2.0 does not support php 7.2 at this point either?

Sorry my bad, they still support 7.1 and I have tested with SMF 2.0.15 and it seems to work

CarstenP

Hmm I'm close to throw in towel  :-\

I have done a clean install of SMF2.0.13 works as it should.

Used the convet.php i got from vbgamer45 (thanks for that)

I modified the LogInOut.php like this: added this $other_passwords[] = hash_hmac('sha256', $_POST['passwrd'], $user_settings['password_salt']); in front of this // Whichever encryption it was using, let's make it use SMF's now ;).

I used the modified phpfusion7_to_smf.php that is attached (I got it from this thread http://www.simplemachines.org/community/index.php?topic=294705.msg3405891#msg3405891 page 6 by ThorstenE)

It converts without any errors, but there are no avatars and no attachments in any posts, the folder attachments contain all the pics as the old sites attachments do.

I do suspect that the above mentioned modified phpfusion7_to_smf.php is the cause but I'm not sure. All 3 files is attached.

Regards
Carsten

Looking

In the database does it have data in the columns for attachments / avatars?

CarstenP

Quote from: Looking on November 15, 2018, 12:36:10 PM
In the database does it have data in the columns for attachments / avatars?

Aha for attachments there are only 9 entries in the DB, where there are about 3k in the attachment files, that explains why there are no pics. in the posts. Another thing is how to solve that ?

For avatar the problem is properly that the PHPFusion avatar is do not define it as SMF do and hey I can live with the fact that the users have to upload a new avatar

CarstenP

My site is set-up to run on SSH- og SFTP-administration could that be a part of the problems I have ?

Looking

Something is wrong with the conversion process. What does it say when its converting attachments? Errors?

Avatars aren't a big deal, make them put up new ones ;)

SSH should not matter.

CarstenP

That is the strange thing it do not come up with any errors during converting, I have tried several times, once it came up with a warning that it had to wait to not overload server and a countdown for continue. that's that

Agree on avatars

And check for SSH

Looking


CarstenP

Good ? I don't have a clue on how to check that I'm using one.com [nofollow] as hosting service

Looking

I have fully tested those conversion scripts and the fault is with the script itself. Besides not being able to work on 2.0.15 it does not populate the attachment table even though it does convert attachments with hashes.

A var_dump returns a null value for attachment IDs.

CarstenP

Ok Forum is running now, but without any attachments  :'(

Better than nothing and I can add the most important pics when I have some spare time

Thank for input and help.

Regards
Carsten

Advertisement: