Advertisement:

Author Topic: Error after upgrade to 2.0.14  (Read 627 times)

Offline Cloudmaster

  • Semi-Newbie
  • *
  • Posts: 25
Error after upgrade to 2.0.14
« on: May 01, 2019, 06:00:22 PM »
Hi all,

After fixing an earlier problem of not being able to upgrade through the package manager, I now have another problem after upgrading to 2.0.14.  Here's the error -

Fatal error: Function name must be a string in C:\FileStore\Website\forum\Sources\Load.php on line 133

That's all that shows on the screen so I can't roll back the update, any suggestions?

Thanks for looking

Edit:  Is it normal to have lots of .php~ files in the Sources folder?

Offline SpacePhoenix

  • Semi-Newbie
  • *
  • Posts: 95
Re: Error after upgrade to 2.0.14
« Reply #1 on: May 01, 2019, 06:06:19 PM »
What is line 133 of Load.php?

Any mods installed?

Don't you have a backup made from just before the upgrade attempt that you could roll back to?

Offline Cloudmaster

  • Semi-Newbie
  • *
  • Posts: 25
Re: Error after upgrade to 2.0.14
« Reply #2 on: May 01, 2019, 06:12:37 PM »
What is line 133 of Load.php?

This is the block that includes line 133

   // Most database systems have not set UTF-8 as their default input charset.
   if (!empty($db_character_set))
      $smcFunc['db_query']('set_character_set', '
         SET NAMES ' . $db_character_set,
         array(
         )
      );

Don't you have a backup made from just before the upgrade attempt that you could roll back to?

I can roll back to a copy made before any of todays updates were made

Offline Portugal

  • Jr. Member
  • **
  • Posts: 214
Re: Error after upgrade to 2.0.14
« Reply #3 on: May 01, 2019, 06:47:52 PM »
Hi,

PHP~ are like a bakcup files made by the system before changes made.

Offline Cloudmaster

  • Semi-Newbie
  • *
  • Posts: 25
Re: Error after upgrade to 2.0.14
« Reply #4 on: May 06, 2019, 03:11:10 PM »
Anyone have any insight into this problem?  I've managed to get my forum up to 2.0.13 but I'm still getting this error when upgrading to 2.0.14.  The upgrade claims to run on PHP 5.3 (I'm currently running 5.3.6)

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 71,643
    • StoryBB/StoryBB on GitHub
Re: Error after upgrade to 2.0.14
« Reply #5 on: May 06, 2019, 03:18:42 PM »
2.0.14 needs PHP 5.4 and it won't work on 5.3 as you have.

You also have an insecure version of PHP since you're not even on the most recent version of PHP 5.3 which itself is long since end of life.
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.

Offline lurkalot

  • Support Specialist
  • SMF Hero
  • *
  • Posts: 1,446
  • Gender: Male
  • Tinyportal Support
    • guitaristguild on Facebook
    • Tinyportal on GitHub
    • @GuitaristGuild on Twitter
    • Guitarist Guild
Re: Error after upgrade to 2.0.14
« Reply #6 on: May 06, 2019, 03:21:07 PM »
Beat me to it as usual.  ;)

"Versions of SMF from 2.0.14 onwards require a version of PHP between 5.4 and 7.1. If you use PHP 5.3 or lower, it is necessary to use SMF 2.0.13 or lower. PHP 7.2 is not supported by SMF at this time."

Taken from here, https://wiki.simplemachines.org/smf/SMF2.0:Requirements_and_recommendations

Offline Cloudmaster

  • Semi-Newbie
  • *
  • Posts: 25
Re: Error after upgrade to 2.0.14
« Reply #7 on: May 06, 2019, 03:24:36 PM »
2.0.14 needs PHP 5.4 and it won't work on 5.3 as you have.

You also have an insecure version of PHP since you're not even on the most recent version of PHP 5.3 which itself is long since end of life.

It clearly states that it needs PHP5.3 (see link).  I'm aware my PHP version is way out of date but I 'inherited' the site from a webmaster who has long disappeared and I don't have the skills to modify the site for later versions.

https://custom.simplemachines.org/upgrades/index.php?action=upgrade;file=smf_patch_2.0.14.tar.gz;smf_version=2.0.13

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 71,643
    • StoryBB/StoryBB on GitHub
Re: Error after upgrade to 2.0.14
« Reply #8 on: May 06, 2019, 04:03:50 PM »
The installer readme is wrong, and it has been since it was published.

The error you get is because the language changed in 5.4 to support it. So you either need to upgrade PHP, or never upgrade beyond 2.0.13.
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.

Offline Oldiesmann

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 24,868
  • Gender: Male
  • Ask me about the function DB :)
    • oldiesmann on Facebook
    • Oldiesmann on GitHub
    • https://www.linkedin.com/in/michaeleshom on LinkedIn
    • @oldiesmann on Twitter
    • Archie Comics Fan Forum
Re: Error after upgrade to 2.0.14
« Reply #9 on: May 13, 2019, 10:32:31 PM »
It should be noted that PHP dropped support for 5.3 back in August of 2014 so the better option would be to upgrade (or ask your host to if you can't).
Michael Eshom
Cincy Space - now open!