Advertisement:

Author Topic: Unable to install "Alen1-Multicolor-v2" theme  (Read 315 times)

Offline Nojus2001

  • Newbie
  • *
  • Posts: 1
Unable to install "Alen1-Multicolor-v2" theme
« on: May 24, 2019, 11:10:00 AM »
I'm getting "Your Theme does not show it has compatibility with SMF 2.1 RC2. Contact the Theme author" Is there any workaround for this? The only reason i want to use it 'cause it looks 9x style and my forum is dedicated on Windows 9x :)

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 51,139
Re: Unable to install "Alen1-Multicolor-v2" theme
« Reply #1 on: May 24, 2019, 11:13:34 AM »
a theme that is made for any version other then SMF 2.1 will not work on SMF 2.1. it would have to be rewritten.

Offline Antes

  • Evil Black Cat
  • SMF Friend
  • SMF Hero
  • *
  • Posts: 8,943
  • Gender: Male
  • Black cat rulz!
    • Antes on GitHub
    • merta on LinkedIn
    • @XinYenFon on Twitter
    • WoWSnips
Re: Unable to install "Alen1-Multicolor-v2" theme
« Reply #2 on: May 24, 2019, 12:10:27 PM »
Please do not use any theme which is not made for SMF 2.1, you will literally break tons of things which you cant work around.
You can support me directly via Patreon

In Catnip We Trust.
The solution is Catnip!
Vote for Catnip!

Current Project(s): [ WoWSnips ]
Past Project(s): [ ezPortal ] # [ Lunarfall ] # [ RDD (HTML5) ]

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 71,400
    • StoryBB/StoryBB on GitHub
Re: Unable to install "Alen1-Multicolor-v2" theme
« Reply #3 on: May 24, 2019, 01:31:58 PM »
Please do not use any theme which is not made for SMF 2.1, you will literally break tons of things which you cant work around.

It won't even let you - 2.1 mandates the theme specify what version it is designed for in the theme-info.xml file, and no 2.0 theme would.
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.

Offline Antes

  • Evil Black Cat
  • SMF Friend
  • SMF Hero
  • *
  • Posts: 8,943
  • Gender: Male
  • Black cat rulz!
    • Antes on GitHub
    • merta on LinkedIn
    • @XinYenFon on Twitter
    • WoWSnips
Re: Unable to install "Alen1-Multicolor-v2" theme
« Reply #4 on: May 24, 2019, 01:46:26 PM »
Please do not use any theme which is not made for SMF 2.1, you will literally break tons of things which you cant work around.

It won't even let you - 2.1 mandates the theme specify what version it is designed for in the theme-info.xml file, and no 2.0 theme would.

Ofc, but you can work-around that with install file but after that hell breaks loose :D
You can support me directly via Patreon

In Catnip We Trust.
The solution is Catnip!
Vote for Catnip!

Current Project(s): [ WoWSnips ]
Past Project(s): [ ezPortal ] # [ Lunarfall ] # [ RDD (HTML5) ]

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 71,400
    • StoryBB/StoryBB on GitHub
Re: Unable to install "Alen1-Multicolor-v2" theme
« Reply #5 on: May 24, 2019, 01:59:06 PM »
If someone doesn't know this is a requirement, it limits their ability to work around it ;)
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.