Advertisement:

Author Topic: HTTP ERROR 500  (Read 347 times)

Offline lupaz77

  • Semi-Newbie
  • *
  • Posts: 15
HTTP ERROR 500
« on: October 09, 2019, 03:42:58 PM »
While trying to post a reply with an attachment I get this error.

This page isn’t working
aircraftnoise.info is currently unable to handle this request.
HTTP ERROR 500

Today I tried to install (and uninstalled) a mod. Not sure if that has to do with it.

Any ideas?

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 73,098
Re: HTTP ERROR 500
« Reply #1 on: October 09, 2019, 03:44:52 PM »
Well... what version of SMF? What mod? Did you get any warnings about it during installation?
No good deed goes unpunished
All helpful urges should be circumvented

Offline lupaz77

  • Semi-Newbie
  • *
  • Posts: 15
Re: HTTP ERROR 500
« Reply #2 on: October 09, 2019, 04:13:35 PM »
SMF 2.0.15
I manually installed this: https://custom.simplemachines.org/mods/index.php?mod=40

Then I restored the original files after I noticed the mod wasn't working.

No warnings or error messages due to that mod.
Everything is working fine except for the attachment issue.

Thanks Arantor




Offline lupaz77

  • Semi-Newbie
  • *
  • Posts: 15
Re: HTTP ERROR 500
« Reply #3 on: October 09, 2019, 04:22:49 PM »
Figured it out.
I created a new folder for the attachments and it works.


Offline lupaz77

  • Semi-Newbie
  • *
  • Posts: 15
Re: HTTP ERROR 500
« Reply #4 on: October 09, 2019, 04:26:50 PM »
And now the problem is back  >:(

I believe it starts when I change the maximum capacity for the folder

Offline lupaz77

  • Semi-Newbie
  • *
  • Posts: 15
Re: HTTP ERROR 500
« Reply #5 on: October 09, 2019, 04:33:09 PM »
OMG! The problem is with one JPG and I get the same error message on this forum LOL

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 73,098
Re: HTTP ERROR 500
« Reply #6 on: October 09, 2019, 05:00:06 PM »
How big is the JPEG? Both in terms of file size and pixel size.
No good deed goes unpunished
All helpful urges should be circumvented

Offline lupaz77

  • Semi-Newbie
  • *
  • Posts: 15
Re: HTTP ERROR 500
« Reply #7 on: October 10, 2019, 10:30:14 AM »
It's a 2.45 MB file, 3340px x 3340px.

I reduced the size by 10% and it worked.

I was able to attach even bigger images though... Maybe SMF doesn't like the size 3340px  :o

Thanks for you help.

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 52,600
Re: HTTP ERROR 500
« Reply #8 on: October 10, 2019, 10:35:21 AM »
most likely https://custom.simplemachines.org/mods/index.php?mod=4111 would help with that issue.

Offline lupaz77

  • Semi-Newbie
  • *
  • Posts: 15
Re: HTTP ERROR 500
« Reply #9 on: October 10, 2019, 10:49:08 AM »
most likely https://custom.simplemachines.org/mods/index.php?mod=4111 would help with that issue.

Cool.

May be it does help.
But it still doesn't make sense to me.

In that link they ask to use this formula to check memory consumption:

Height * Width * 4 / 1000000

The image that keeps giving me errors gives a result of 44.62
Another bigger image that I can attach without a problem gives this result: 82.67


Offline lupaz77

  • Semi-Newbie
  • *
  • Posts: 15
Re: HTTP ERROR 500
« Reply #10 on: October 10, 2019, 10:57:20 AM »
Indeed, it's the memory consumption I believe.
A bigger image returned the same error.

Thanks.