Advertisement:

Author Topic: 2.0.16 error when installing/uninstalling mods  (Read 681 times)

Offline SychO

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 1,992
  • Gender: Male
    • SychO9 on GitHub
    • SychO
2.0.16 error when installing/uninstalling mods
« on: December 28, 2019, 04:46:02 PM »
Getting this when installing or uninstalling a mod

PHP 7.3.9
SMF 2.0.16

8192: The each() function is deprecated. This message will be suppressed on further callsApply Filter: Only show the errors from this fileFile: .../Sources/Subs-Package.php
Line: 2749
Checkout My Themes:
-

Potato  •  Ackerman  •  SunRise  •  NightBreeze


Offline shawnb61

  • Dev. Team Mentor
  • Developer
  • SMF Hero
  • *
  • Posts: 3,116
    • sbulen on GitHub
Re: 2.0.16 error when installing/uninstalling mods
« Reply #1 on: December 28, 2019, 04:54:56 PM »
What about 7.2?
Address the process rather than the outcome.  Then, the outcome becomes more likely.   - Fripp

Offline Sesquipedalian

  • The Mad Doctor
  • On Hiatus
  • Sophist Member
  • *
  • Posts: 1,153
  • Gender: Male
  • It works! ... in theory.
    • Sesquipedalian on GitHub
Re: 2.0.16 error when installing/uninstalling mods
« Reply #2 on: December 28, 2019, 05:23:11 PM »
Fix is ready in our internal repo, #61

[Edit (m4z)]: removed repo URL; this board is public, no?
« Last Edit: December 28, 2019, 07:52:33 PM by m4z »
I promise you nothing.

Sesqu... Sesqui... what?
Sesquipedalian, the best word in the English language.

Offline m4z

  • 98.8% chimp
  • Localizer
  • Sophist Member
  • *
  • Posts: 1,373
  • /mɛs/
Re: 2.0.16 error when installing/uninstalling mods
« Reply #3 on: December 28, 2019, 07:55:01 PM »
@Sesq: I edited your post a couple of minutes after you posted (hope that was ok and the right thing to do), and just now I edited again to make my comment more useful.
"Faith is what you have in things that don't exist."
--Homer Simpson

Es gibt hier im Forum ein deutsches Support-Board!
<werbung>Meine Freundin hat ihr erstes Buch veröffentlicht!</werbung>

Offline GL700Wing

  • Full Member
  • ***
  • Posts: 666
  • Gender: Female
Re: 2.0.16 error when installing/uninstalling mods
« Reply #4 on: December 28, 2019, 11:47:59 PM »
Getting this when installing or uninstalling a mod

PHP 7.3.9
SMF 2.0.16

8192: The each() function is deprecated. This message will be suppressed on further callsApply Filter: Only show the errors from this fileFile: .../Sources/Subs-Package.php
Line: 2749
Had the same issue with PHP 7.2 and fixed it - see The each() function is deprecated
Life doesn't have to be perfect to be wonderful ...

Offline shawnb61

  • Dev. Team Mentor
  • Developer
  • SMF Hero
  • *
  • Posts: 3,116
    • sbulen on GitHub
Re: 2.0.16 error when installing/uninstalling mods
« Reply #5 on: December 30, 2019, 10:31:26 PM »
Fixed in 2.0.17
Address the process rather than the outcome.  Then, the outcome becomes more likely.   - Fripp