• Welcome to Simple Machines Community Forum. Please login or sign up.
December 07, 2021, 05:28:28 PM

News:

Want to get involved in developing SMF, then why not lend a hand on our github!


Search Produces Different Results Based on User's Device and Browser?

Started by sah62, March 03, 2020, 09:12:32 AM

Previous topic - Next topic

sah62

I'm running SMF 2.0.17 with PHP 7.2 (7.2.24-0ubuntu0.18.04.3) and Ubuntu 18.04.4 LTS.

When I search my forum's topics for a phrase like "transmission fluid" (in quotes) from a Windows 10 PC using Firefox 68.5.0esr, I get results as expected. Topics are found, and the phrase is highlighted in the found topics. When I do the same search on an iPhone XR running iOS 13.3.1 and Safari 13, I get no results at all. I also get no results using Edge 44.13.3 on the same iPhone. Can someone help me figure out why I'm getting no search results when searching from an iPhone?

Kindred

bet you it's the quotes....

are you using UTF8 on your site or still on ISO?
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.<br /><br />"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

sah62

My smf_topics table uses the InnoDB engine type with utf8_general_ci collation.

Kindred

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.<br /><br />"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

shawnb61

Address the process rather than the outcome.  Then, the outcome becomes more likely.   - Fripp

sah62

Quote from: Kindred on March 03, 2020, 03:18:54 PM
but is your SMF ALSO UTF8?

The current language setting is English, ISO-8859-1. Should it be English UTF-8?

sah62

Quote from: shawnb61 on March 03, 2020, 04:07:08 PM
Do you see the same behavior on this site?

I get results when I search from the iPhone, but they're not the same results as found when searching from a PC. I just tried a search for "language setting". On the phone, I get a list of topic titles without highlighted hits. On the PC, I get a different list of topics and hits are highlighted.

sah62

Since I'm seeing the same basic behavior here, should I assume that this is a feature and not a bug?

Kindred

regarding the different result -- I don't know.

Regarding the highlighting...   yes, I expect that is browser specific -- so, using a mobile browser will ahve different effects from using a desktop browser
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.<br /><br />"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Advertisement: