News:

Bored?  Looking to kill some time?  Want to chat with other SMF users?  Join us in IRC chat or Discord

Main Menu

Light Portal

Started by Bugo, March 25, 2020, 07:36:36 AM

Previous topic - Next topic

Seyit

WHAT YOU SAY IS ALREADY IN EFFECTIVE POSITION
USER INFORMATION IS NOT CREATED

it throws an error in the error log

I'm throwing information from the demo site special for you

this is what i work for : https://www.simplemachines.org/community/index.php?action=dlattach;topic=572393.0;attach=278995

Bugo

If you choose English, there is no problem with UserInfo addon, it's related to Turkish translation.

Are you sure you are using the latest version of the translation?

Seyit

Quote from: Bugo on March 03, 2022, 04:40:18 AMIf you choose English, there is no problem with UserInfo addon, it's related to Turkish translation.

Are you sure you are using the latest version of the translation?


language files are up to date sir

Bugo

Here is a screenshot from my test forum with a similar configuration. As you see, the UserInfo addon works.

Try to remove /Sources/LightPortal/Addons/BoardIndex dir

Seyit

Quote from: Bugo on March 03, 2022, 05:34:58 AMHere is a screenshot from my test forum with a similar configuration. As you see, the UserInfo addon works.

Try to remove /Sources/LightPortal/Addons/BoardIndex dir

I reset the site, I reinstalled it, there is a problem on your portal


Seyit

pages : manage pages

when i delete it gets a white page
Error log gives an error when I try to manage plugins




Bugo


Seyit

Quote from: Bugo on March 03, 2022, 09:28:16 AMCan you test a fix?

public function getSnakeName(string $value): string
{
return strtolower(preg_replace('/(?<!^)[A-Z]/', '_$0', $value));
}

public function getCamelName(string $value): string

degiştir

public function getSnakeName(string $value): string
{
return strtolower(preg_replace('/(?<!^)[A-Z]/', '_$0', $value));
return $this->smcFunc['strtolower'](preg_replace('/(?<!^)[A-Z]/', '_$0', $value));
}

public function getCamelName(string $value): string

i will give you ftp you solve the problem

I'm throwing private



Max22

Did you try to delete or comment out return strtolower(preg_replace('/(?<!^)[A-Z]/', '_$0', $value)); from the second code?

Seyit

Turkish problem solved

public function getSnakeName(string $value): string
{
return $this->smcFunc['strtolower'](preg_replace('/(?<!^)[A-Z]/', '_$0', $value));
}

public function getCamelName(string $value): string




Seyit

http://erdoganmobilyam.com/index.php?action=admin;area=lp_pages;d3a1608feba=809981d7af8a4c66ed2f61766ac60569


There is no such page, but it seems to exist.

You cannot view this attachment.You cannot view this attachment. 


we need to get this portal from the troubled hand eh it can't replace the portal

Mick.

@Bugo can we have abbreviated month on the front page?

Full month breaks the line on small devices due to long category name.

Mick.

Heads up:
Padding, twice.
.article_alt3_view .card .details {
  padding: 0;
  list-style: none;
  position: absolute;
  top: 0;
  bottom: 0;
  left: -100%;
  margin: auto;
  transition: left 0.2s;
  background: rgba(0, 0, 0, 0.6);
  color: #fff;
  padding: 10px;
  width: 100%;
  font-size: 0.9rem;
}

Bugo

Quote from: Mick. on March 03, 2022, 12:56:28 PM@Bugo can we have abbreviated month on the front page?

Full month breaks the line on small devices due to long category name.
Any screenshot?

Mick.

I think rez is 480px

You cannot view this attachment.


I thought LP used abbreviated months on earlier versions?

Bugo


Mick.

Quote from: Bugo on March 03, 2022, 11:18:38 PMEntities\FrontPage.php

ViewFrontPage.template.php

if (! empty($article['datetime'])) {
echo '
<time class="floatright" datetime="', $article['datetime'], '">', $context['lp_icon_set']['date'], date('M j', $article['raw_date']), '</time>';
}

I added the Year to it. All's good.

if (! empty($article['datetime'])) {
echo '
<time class="floatright" datetime="', $article['datetime'], '">', $context['lp_icon_set']['date'], date('M j Y', $article['raw_date']), '</time>';
}

Diego Andrés

I think I found a bug?
When I add a Board News block, the content won't display if the board doesn't have a single group added with permissions to view/access the board? I suppose if I'm admin I could see the content regardless of the board permissions?


https://i.imgur.com/86qRlFd.png

SMF Tricks - Free & Premium Responsive Themes for SMF.

Bugo

This block uses the SSI function ssi_boardNews to retrieve results. Is it a bug or is it an expected result? Check through ssi_examples.php


FrizzleFried

I've read through this support topic and I can't seem to find a definitive answer.  I did find where someone else asked the question (well,  insinuated that the mod (at the time) needed one).

Shoutbox.  Does this portal have a shoutbox plugin?

Thanks!

Advertisement: