• Welcome to Simple Machines Community Forum. Please login or sign up.
January 22, 2022, 06:09:09 PM

News:

Join the Facebook Fan Page.


PM Attachments

Started by SoLoGHoST, August 20, 2009, 09:08:18 AM

Previous topic - Next topic

DarkAngel612

SMF: 2.0.17Link: http://thefantasiesattic.net/attic/
Modification Packages — Installed
   
1.     Global Headers Footers     2.1a
2.     Separate the sticky topics     1.0.1
3.     Stupid bouncy BBC     1.0
4.     BK Modding Disable Decrease Post Count Option     3.0
5.     Advanced Contact Form     1.1
6.     Sorted Package Manager Listing     1.2
7.     Stop Spammer     2.3.9
8.     Float BBCODE     1.0.2
9.     Most Popular Topic Today     2.3
10.     TinyPortal     1.2
11.     httpBL     2.5.1
12.     Simple Audio Video Embedder     5.0.3
13.     Join Reason     1.5
14.     Change All Subjects     1.3
15.     PM Attachments     2.12
16.     SMF Staff Page     1.8
17.     Enhanced Dropdown     1.3

I have version 2.12 installed of this mod, since the last version it has stopped letting pm's attach .zip files. It claims to send but it doesn't send the attachment, just the text and non-zip files.
The forum has all fresh updated files, I have run repair_settings -- just in case -- to no avail. There were no errors when the mod installed.
Can someone give me an inkling of what to do? There is nothing on server errors, forum error log nor an error log in the server folders.
Fantasy Attic ::  Fantasies Realm Market :: SMF 2.0+ with various mods and TinyPortal

rcane

HI there,

Been using the mod for a while now (few months).  I've got around 900 users now, and I started seeing this today from one particular user:

Unable to load the 'PMAttachments.english' language file.


Any guidance or ideas?

GL700Wing

Quote from: rcane on November 17, 2021, 10:32:53 PMBeen using the mod for a while now (few months).  I've got around 900 users now, and I started seeing this today from one particular user:

Unable to load the 'PMAttachments.english' language file.
I can't think of any reason why SMF would only throw an error like this for one user - might be worth getting that user to try another browser and/or device to see if the error still occurs ...
Life doesn't have to be perfect to be wonderful ...

DarkAngel612

forum: 2.0.18
https://www.thefantasiesattic.net/


Now that we are on a new host...yay this mod is working again, however, I found this error message on the server for our forum:

[13-Dec-2021 22:59:45 America/Chicago] PHP Fatal error:  Call to undefined function removePMAttachments() in /home/txxx/public_html/xxx/Sources/PersonalMessage.php on line 3120

line 3120 says: 3119 to 3129
require_once($sourcedir . '/ManageAttachments.php');
removePMAttachments(array('id_attach' => $remove_attachments), '', false, true, false);
}

I'm confused since it is asking for one file but the file a different one, I then did a search in the ManageAttachments file for removePMAttachments  which was not found.


Aside from this error things seem to be working wonderfully again. Should I be worried?
Fantasy Attic ::  Fantasies Realm Market :: SMF 2.0+ with various mods and TinyPortal

GL700Wing

Looks like the removePMAttchhments function was moved to Subs-PMAttachments.php some years ago: https://www.simplemachines.org/community/index.php?topic=331969.msg3915054;topicseen#msg3915054

Changing 'require_once($sourcedir . '/ManageAttachments.php');' to 'require_once($sourcedir . '/Subs-PMAttachments.php');' should fix the problem ...
Life doesn't have to be perfect to be wonderful ...

Advertisement: