UTF-8 convert broke connection to mysql database

Started by Jarppi, June 10, 2020, 02:31:27 PM

Previous topic - Next topic

Jarppi

 >:(
F...king SMF!
I tried to convert the whole forum to UTF-8 because some scandinavian letter was shown that stupid question mark.
Page just turned empty white page and that's all after UTF-8 conversion that was done through admin page.

So what the hell I can now do to recover this problem? repair_settings.php did not help.
Should I try to change collation in database? I guess it went some how bad during that convert?
Here is the link to that pile of crap:
http://finnbikers.fi/foorumi/index.php
SMF 2.0.17 with php 7.2

Kindred

a white screen of death means that there was a server-level failure, usually in php itself.

Go to your server. find the SERVER error log...   see what is listed there.
We can make other suggestions once we know what's actually causing php to fail.
Слова
Украина

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Jarppi

Ok, do you mean some thing from SERVER like errors there through cpanel.
If this is the one you mean:
[Wed Jun 10 22:33:33.354687 2020] [:error] [pid 29899] [client 157.55.39.193:9643] client denied by server configuration: /home/finnbike/public_html/foorumi/index.php
[Wed Jun 10 22:33:33.182127 2020] [:error] [pid 29899] [client 157.55.39.193:9643] client denied by server configuration: /home/finnbike/public_html/foorumi/index.php
[Wed Jun 10 22:33:33.009587 2020] [:error] [pid 29899] [client 157.55.39.193:9643] client denied by server configuration: /home/finnbike/public_html/foorumi/index.php
[Wed Jun 10 22:33:32.836736 2020] [:error] [pid 29899] [client 157.55.39.193:9643] client denied by server configuration: /home/finnbike/public_html/foorumi/index.php

That SMF error log does not show much either. I attached it.

Illori

So you need to change permissions on the index.php file and you will gain access again.

Jarppi


Arantor

Check with your hosting company what they suggest.

644 on files, and 755 on folders is normal though.

Jarppi

But why this suddenly is an issue that forum was working fine and now after utf8 conversion it needs different file permissions.
I just checked form old backup and file permissions are same way, so I guess this is not solved by just changing those.

Kindred

well -- the error certainly seems pretty clear - regardless of WHY it started happening.

I suggest that you check with your host at this point, since the SERVER is having a problem, not SMF.
Слова
Украина

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Jarppi

#8
And server suddenly will have problem when I do that conversion, very hard to believe that there is such coincident.
So I installed new another SMF to same host server to see what file permissions for that is done by default and it is 644 files and 755 folder and that same settings IS NOT working on that broken SMF.
So something else is broken here!

Kindred

sure. maybe so...

But you have to get your server to pass the DISPLAYED error before we can move on to the nest problem.

As I said -- talk to your host. They should be able to determine the actual server issue in under 5 mins.
Слова
Украина

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Jarppi

I used old backup to recover SMF part and then patched that to current level. So there was nothing wrong on SERVER side.
Something corrupted current SMF files and that's it.
So problem recovered but not solved. Also utf8 conversion worked now and i got rid of original issue.

Arantor

Did you restore Settings.php? This should have been updated during the conversion.

Sir Osis of Liver

IIRC, I saw a couple of forums where language installer changed forum root directory to 777 (not index.php), which isn't allowed on some servers, and it killed the forum.  Changing directory permissions back to 755 fixed it.  Sounds like something similar may have happened here.
"The best laid schemes o' mice an' men / Gang aft a-gley." - Robert Burns

Advertisement: