• Welcome to Simple Machines Community Forum. Please login or sign up.
October 20, 2021, 08:18:11 PM

News:

Want to get involved in developing SMF, then why not lend a hand on our github!


Used Pkg Mgr to upgrade from .17 to .18 Now blank screen when accessing forum

Started by Mareid, February 10, 2021, 01:37:14 PM

Previous topic - Next topic

Mareid

The subject says it all.  I used the package manager to upload the new version.  Now all I see on index.php is a blank screen.  I am not knowledgeable enough to fix this myself. 

edited to add:  I contacted the host and had them upgrade php to 7.4....same result

Mareid

I have a backup in .tar.gz format.  Could you point me to where I can learn how to restore from the backup please.

Kindred

if you have a backup of the files, just restore it, overwriting the existing files with the backup contents

If you have a backup of the database, you would do the same thing at the db level...   but the database is not a problem here...

Alternatively, get the upgrade archive (not the patch) and upload it to your server, overwriting the existing files
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Mareid

I restored the backup and it worked perfectly...thanks. I tried again to use the package manager and I got errors (I didn't notice any the previous time, but it's possible I just missed them.  Here's a screenshot.  I don't know how to fix them.  I deleted (actually I uninstalled) an addon package, but other than that that's all I see that might interfere. 



Kindred

you will have to manually find and apply the patch changes to those locations.

Alternatively, you could use the upgrade archive, overwrite all files and then reinstall mods.
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Mareid

This is what I did and I still get the error.
I found the 0.17 patch and extracted the two files that were causing the error  and uploaded them one at a time to the proper directory shown in the error message.  I then  tried to patch 0.18 again. I got the same error.  I had already removed the two mods I'd installed and I deleted them also.

I will try your suggestion to overwrite all the files from the 0.18 archive

I think it would work to download the .zip archive to my pc and just FTP the files up but there must be a better way using the .gz archive.  I just don't know how to do it that way.  This is quite a learning curve for me.  To give you an idea how big, I graduated from engineering school in 1961 and I've been retired now for 25 years!

Mareid

Before I do it with the zip file, will that work correctly, simply ftp up the files in their directories?  I do have a backup but I am worried I'll screw the whole thing up

Mareid

Before I start doing the upload I'd like someone to validate that I'm doing this correctly: 


  • made a full copy of the entire forum as it exists today to my PC.  All the files appear to be there, and Filezilla agrees that except for the cache they all downloaded.
  • I downloaded a zip copyof the "large upgrade" of the 0.18 patch from simplemachines.org

  • I extracted the files from the 0.18 archive (the .zip) file to my PC
If I simply filezilla the files that I expanded from the 0.18 archive back up to the server, will that work? Or is there more to do with file permissions and so on?



Mareid

I followed the instructions in the link to the letter:

  • backed up everything, including the database (had to figure out how to do that)
  • removed all mods using the package manager
  • went to the download site and downloaded the "large upgrade" package for 2-0-17 which is the version I am currently running (see below)
  • uploaded the .tar.gz file to my hosting site and got this error (see below) while trying to extract to the temporary directory.
  • installed fix_packages.php and ran it, removed every hook that was not one of the versions of smf itself
  • attempted to install the 0.18 patch again and got the exact failure as above

Now I don't know what to do.

Mareid

The picture shows the .zip download (oops) but I did also download the .tar.gz and that's what I uploaded to my host

Mareid

I fixed it.  I uploaded the two files again, and ran the patch.  this time it worked.

Advertisement: