SMF Support > SMF 1.1.x Support

Attachment Not Found

(1/2) > >>

aswuser:
SMF v1.1.21  php 5.6

We moved the forum to a new host; finally got it all working except for this issue. When making a new post and adding an attachment (jpg) the process seems to go as it should but when review the post, the image does not display. Trying to view image gets error 404 - Attachment Not Found.

Attachments on older posts show up fine. I know the path to attachments directory is correct.  You can see what it looks like here:
https://schoolofevolutionaryastrology.com/forum/index.php/topic,1720.0.html [nofollow]

Screen shot is attached. 

Also it appears the attachment is not getting processed. It looks like when you upload an attachment, SMF renames the file to something like "162000_ca280451ea5b" but  the one I uploaded is named "post_tmp_4_0".

Any ideas on what is going on and how to repair?

Kindred:
hint: upgrade to 2.0.18

aswuser:
I already tried updgrading to from 1.1.21 to 2.0.10 - over a year ago. That failed. But thanks for the suggestion. I do plan to try upgrading again but need to keep this version running until that time.

Attachments was working fine before the move.

Grammy:
Whenever I've moved a forum from one host to another, I always upload repair_settings.php to my forum's root and check the URLs.  There's a link for it in my signature.   :)

shawnb61:
Since it appears you have the temp file, the upload itself worked.  What failed is the last step, after a number of edits, it renames the temp file to the real filename.

If the rename itself is failing (which moves it from the temp dir to the attachment dir), that suggests to me there is likely an issue with attachment folder permissions. 

Double-check the folder name in repair_settings.php,  and also double-check the folder's permissions.   

Navigation

[0] Message Index

[#] Next page

Go to full version