Advertisement:

Author Topic: Installing a new clean 2.1 RC3 install have issue  (Read 539 times)

Offline thomcd8

  • Newbie
  • *
  • Posts: 7
Installing a new clean 2.1 RC3 install have issue
« on: June 10, 2021, 12:29:48 PM »
I have installed a clean 2.1 rc3 install and get this error in the installing

Fatal error: Uncaught Error: Call to undefined function display_db_error() in /home/www/politicalawareness.net/Sources/Subs-Db-mysql.php:101 Stack trace: #0 /home/www/politicalawareness.net/install.php(399): smf_db_initiate('localhost', '', 'blahblah', 'blahblah', 'smf_', Array) #1 /home/www/politicalawareness.net/install.php(952): load_database() #2 /home/www/politicalawareness.net/install.php(145): ForumSettings() #3 {main} thrown in /home/www/politicalawareness.net/Sources/Subs-Db-mysql.php on line 101

Any thoughts on the fix?

Thank you in advance
« Last Edit: June 10, 2021, 12:32:42 PM by shawnb61 »

Online shawnb61

  • Developer
  • SMF Hero
  • *
  • Posts: 3,228
    • sbulen on GitHub
Re: Installing a new clean 2.1 RC3 install have issue
« Reply #1 on: June 10, 2021, 12:35:40 PM »
Message above edited to remove DB credentials.  Please be careful not to share sensitive information when posting.


Looks like it is still running the installer code for some reason. 

Did your installation complete OK?  If so, delete install.php & try again.
Address the process rather than the outcome.  Then, the outcome becomes more likely.   - Fripp

Offline thomcd8

  • Newbie
  • *
  • Posts: 7
Re: Installing a new clean 2.1 RC3 install have issue
« Reply #2 on: June 10, 2021, 12:39:54 PM »
No its getting stuck with that error right at forum settings in the install.php at step 4

Offline thomcd8

  • Newbie
  • *
  • Posts: 7
Re: Installing a new clean 2.1 RC3 install have issue
« Reply #3 on: June 10, 2021, 12:54:46 PM »
i deleted it even tried from the one on github and tried installing and get stuck on step 4 after entering all the info, i get that error when i hit continue

Online shawnb61

  • Developer
  • SMF Hero
  • *
  • Posts: 3,228
    • sbulen on GitHub
Re: Installing a new clean 2.1 RC3 install have issue
« Reply #4 on: June 10, 2021, 01:16:30 PM »
OK, so it appears the installation never completed successfully. 

First, some basics:
 - What version of mysql?
 - What php version?
 - Have you double-checked the DB credentials, e.g., by accessing the DB via phpmyadmin?
Address the process rather than the outcome.  Then, the outcome becomes more likely.   - Fripp

Offline thomcd8

  • Newbie
  • *
  • Posts: 7
Re: Installing a new clean 2.1 RC3 install have issue
« Reply #5 on: June 10, 2021, 01:28:17 PM »
Here are those answers :)

- What version of mysql?  MySQL version: 5.7.27
 - What php version?  Version 7.4.20
 - Have you double-checked the DB credentials, e.g., by accessing the DB via phpmyadmin? Yes i have :)

Online shawnb61

  • Developer
  • SMF Hero
  • *
  • Posts: 3,228
    • sbulen on GitHub
Re: Installing a new clean 2.1 RC3 install have issue
« Reply #6 on: June 10, 2021, 02:23:01 PM »
It is failing attempting to connect to the db, so there is something wrong with the credentials or permissions for that db user. 

There were some enhancements made to connection error reporting in the latest code up on GitHub.  I would suggest trying the code there.  It should give us a better error message for the connection problem...

To install from GitHub:
 - Download the files from here: https://github.com/SimpleMachines/SMF2.1 (click on Code and then Download Zip)
 - Overwrite your 2.1 RC3 files with what you just downloaded
 - Copy the 3 install*.* files from the /other folder down to the forum root - overwriting existing files
 - Copy the Settings.php template from the /other folder down to the forum root - overwriting existing files

Attempt the install again & report back with any errors found.
Address the process rather than the outcome.  Then, the outcome becomes more likely.   - Fripp

Offline thomcd8

  • Newbie
  • *
  • Posts: 7
Re: Installing a new clean 2.1 RC3 install have issue
« Reply #7 on: June 10, 2021, 02:50:55 PM »
i did just that and now i get this error at same spot


Fatal error: Uncaught Error: Call to undefined function display_db_error() in /home/www/politicalawareness.net/Sources/Subs-Db-mysql.php:103 Stack trace: #0 /home/www/politicalawareness.net/install.php(399): smf_db_initiate() #1 /home/www/politicalawareness.net/install.php(948): load_database() #2 /home/www/politicalawareness.net/install.php(145): ForumSettings() #3 {main} thrown in /home/www/politicalawareness.net/Sources/Subs-Db-mysql.php on line 103

Online shawnb61

  • Developer
  • SMF Hero
  • *
  • Posts: 3,228
    • sbulen on GitHub
Re: Installing a new clean 2.1 RC3 install have issue
« Reply #8 on: June 10, 2021, 07:19:13 PM »
OK, so let's check the user.  Two items of interest:
 - The authentication plugin field (should say Native MySQL Authentication, like the attached)
 - The privileges (all should be selected)

In phpmyadmin, the screen to use looks like the attached.
Address the process rather than the outcome.  Then, the outcome becomes more likely.   - Fripp

Offline thomcd8

  • Newbie
  • *
  • Posts: 7
Re: Installing a new clean 2.1 RC3 install have issue
« Reply #9 on: June 11, 2021, 10:28:45 AM »
Where is that setting in myphp

I cant find it at all under any the the tabs. Please forgive me for that question :)

Online shawnb61

  • Developer
  • SMF Hero
  • *
  • Posts: 3,228
    • sbulen on GitHub
Re: Installing a new clean 2.1 RC3 install have issue
« Reply #10 on: June 11, 2021, 11:31:00 AM »
Click on the privileges tab, then edit privileges.

If you don't have access, we'll get at it via query...
Address the process rather than the outcome.  Then, the outcome becomes more likely.   - Fripp

Online shawnb61

  • Developer
  • SMF Hero
  • *
  • Posts: 3,228
    • sbulen on GitHub
Re: Installing a new clean 2.1 RC3 install have issue
« Reply #11 on: June 11, 2021, 02:44:09 PM »
Or you could have your host support check it!

My thinking at the moment is that this user either doesn't have all privileges or is using a different authentication module. 
Address the process rather than the outcome.  Then, the outcome becomes more likely.   - Fripp

Offline thomcd8

  • Newbie
  • *
  • Posts: 7
Re: Installing a new clean 2.1 RC3 install have issue
« Reply #12 on: June 11, 2021, 03:01:00 PM »
You're correct no user privileges.

So can anything be done with that or is that a losing battle? Thank you for your time on all this

Online shawnb61

  • Developer
  • SMF Hero
  • *
  • Posts: 3,228
    • sbulen on GitHub
Re: Installing a new clean 2.1 RC3 install have issue
« Reply #13 on: June 11, 2021, 03:03:00 PM »
If you're using an ID provided by your host support, make them fix it...

If it's all you, then we need to grant the appropriate privileges.
Address the process rather than the outcome.  Then, the outcome becomes more likely.   - Fripp

Online shawnb61

  • Developer
  • SMF Hero
  • *
  • Posts: 3,228
    • sbulen on GitHub
Re: Installing a new clean 2.1 RC3 install have issue
« Reply #14 on: June 13, 2021, 02:32:10 PM »
Do you need help granting the privileges?
Address the process rather than the outcome.  Then, the outcome becomes more likely.   - Fripp