• Welcome to Simple Machines Community Forum. Please login or sign up.

Foorumin skandit sekaisin

Started by suomi50, November 30, 2021, 09:36:38 PM

Previous topic - Next topic

suomi50

Päivitin foorumin heinäkuussa versioon 2.0.18
Lokakuussa osallistujat huomasivat ääkkösien sekoamisen, niin vanhoissa viesteissä, aihealueen nimissä, yleensäkin kaikkialla, missä niitä on.

Ehdin korjata etusivun yläkulmassa näkyvät uutiset normaaliksi, kunnes itse huomasin ongelmia olevan muuallakin. Mitään muutoksia en ollut tehnyt foorumille tuon 4.7.2021 jälkeen.

Foorumin nimi on ADHD-aikuisten vertaistukifoorumi

palvelu sijaitsee Nettihotellin serverillä 2. Olen jo laittanut kyselyä sinne, onko jotain muutoksia tehty palvelimelle syksyn kuluessa.

Foorumin kielenä on finnish UTF-8

mikä neuvoksi?

Aleksi "Lex" Kilpinen

Toimiiko skandit siis oikein uusissa viesteissä, ja vain vanhassa sisällössä on näitä ongelmia?
Ihan ensiksi kannattaa ottaa varmuuden vuoksi varmuuskopio tietokannasta jos pystyt, sen jälkeen voisit kokeilla Forum Maintenance -osiosta löytyvää "Convert HTML-entities to UTF-8 characters" valintaa. Jos kyse on siitä että aiemmin on ollut käytössä joku muu merkistökoodaus kuin UTF-8 niin tämä voi auttaa. Jos kyse on jostain muusta, tämä ei välttämättä tee mitään (tai voi ihan pahimmassa tapauksessa sotkea jotain lisää - siksi se varmuuskopio). Viimeiiseksi varmista että kaikilla on käytössä joku UTF-8 kielipaketti, muita ei enää tämän jälkeen tulisi käyttää.
A Finnish Project Manager (Support Specialist)
 Happily running multiple SMF 2.x installations.
  Fooling around with i7-10700 @ 2,90GHz-4.80GHz / 16Gb / RTX-2070 Super / 3840x2160 / Win 10 x64


How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum. Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

suomi50

Juuri näin, että vanhat tekstit ovat seonneet. Uudet näkyvät kunnolla.

Editoin esim. etusivun oikeassa nurkassa olevat uutiset ja korjasin skandit, jolloin ne nyt näkyvät oikein.

Foorumilla on ollut mahdollisuus valita vain finnish UTF-8, joten siksi tuota ihmettelin.

Nettihotelli vastasi, ettei heillä olisi ollut mitään muutoksia, joka tuohon voisi vaikuttaa.

 Forum Maintenance -osiosta löytyvää "Convert HTML-entities to UTF-8 characters" ei mielestäni muuttanut mitään

Onko foorumi nyt pysyvästi sekaisin?




Aleksi "Lex" Kilpinen

Nuo etusivulla näkyvät ongelmat kuten "Pyyntöketju" hieman vihjaisi että palvelinpuolella on ehkä jotain tehty jos mikään muu ei oikeasti ole mitenkään muuttunu niinä aikoina kun ongelma on ilmennyt - Mutta pystytkö katsomaan tietokannasta suoraan, miltä tällaiset virheelliset tekstit näyttää siellä - ja mitä merkistöä tietokanta on asetettu käyttämään?
A Finnish Project Manager (Support Specialist)
 Happily running multiple SMF 2.x installations.
  Fooling around with i7-10700 @ 2,90GHz-4.80GHz / 16Gb / RTX-2070 Super / 3840x2160 / Win 10 x64


How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum. Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

suomi50

Palvelun tarjoajalta saamieni vastausten mukaan heillä ei olisi tehty muutoksia, mutta en ole tuosta aivan varma kuitenkaan. Miten tuollainen muutos olisi tapahtunut itsestään, kun en ole käynyt mitään tekemässä foorumin ylläpidossa heinäkuisen 2.0.18 päivityksen jälkeen?

Pääsen kyllä palvelimelle, mutta en taida osata katsoa, miltä tekstit näyttävät. Tarvitsisin siihen konkreettisia ohjeita.

Mistä sen näkisin, mitä merkistöä tetokanta on laitettu käyttämään.

Foorumin puolelta on asetettu tuo UTF-8, mutta sekö ei ole sama asia. Foorumi on ollut käytössä parikymmentä vuotta ja päivitetty matkan varrella. Aiemmin ei ole merkistöongelmia ollut. Siksi olen nyt ihmeissäni.

Kielipaketin päivitykset on tehty suoraan palvelimelle eli .zip tiedosto on purettu siellä.

Uusimman version suomesta päivitin vasta tuon ongelman ilmestymisen jälkeen.

Toki foorumi siirrettiin toiselle palvelimelle, mutta tuo tapahtui jo 12.3.2019.

Mistähän saisi apuja ongelman ratkaisuun?


Aleksi "Lex" Kilpinen

Pääsetkö katsomaan tietokannan sisälle, esimerkiksi PHPMyAdminilla?
smf_boards sisältää nuo alueiden otsikot, ja koska niitä on vähän vähemmän kuin viestejä tai ketjuja yleensä niin sieltä voisi olla helppo katsastaa mitä tietokanta kertoo.

PHPMyAdminin näkymä pitäisi olla jotain tämän tyylistä
You cannot see attachments on this board.
Tässä kiinnostaisi sarake "Collation", mitä siinä lukee? (Kaikissa pitäisi olla sama.)

Klikkaamalla tuota _boards otsikkoa, pitäisi avautua jotain tämän oloista
You cannot see attachments on this board.
Juuri kuvan ulkopuolella seuraavaksi olisi kentät name ja description, jotka sisältää alueen otsikon ja kuvauksen. Tästä kiinnostaisi tietää miten ääkköset näkyy siellä?

Valitettavasti, nämä on usein hieman hankalia diagnosoitavia - eikä ole minun vahvinta alaani, mutta koitetaan ainakin löytää joku punainen lanka ja mietitään sitten mitä seuraavaksi.
A Finnish Project Manager (Support Specialist)
 Happily running multiple SMF 2.x installations.
  Fooling around with i7-10700 @ 2,90GHz-4.80GHz / 16Gb / RTX-2070 Super / 3840x2160 / Win 10 x64


How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum. Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

suomi50

Selasin viestiketjuja foorumilla

Nyt minulle selvisikin, että ajankohta meneekin heinäkuulle, jonka jälkeen viestit näkyvät oikein.
Foorumille tehty seuraavat päivitykset:
4.7.2021 foorumi päivitetty versioon 2.0.16
4.7.2021 foorumi päivitetty versioon 2.0.17
4.7.2021 foorumi päivitetty versioon 2.0.18

Ilmeisesti jokin näistä päivityksistä muutti 4.7.2021 ja sitä ennen kirjoitetut viestit oudoiksi ääkkösten osalta. Elokuusta alkaen kirjoitetut viestit ovat lukukelpoisia.

Ehkä en vaan heti huomannut, että noin oli käynyt eikä foorumilaisetkaan valittaneet. Joku uusi liittynyt sitten heräsi huomauttamaan ylläpidolle ääkkösongelmasta lukiessaan vanhoja viestiketjuja.


suomi50

Näyttäisi kaikissa sarakkeen riveillä olevan tuo UTF8_general_ci

You cannot see attachments on this board.

Siellä _boards alla esim. tällainen teksti
Tänne kaikki vuosikokouksiin liittyvä aineisto
tei
Täältä löytyvät vuoden 2006 kokoukset

Samalta näytti tekstit foorumin kautta. Ehdin jo muutaman korjatakin foorumin muokkaa toiminnolla.

Muutamat ovat käyttäneet ääkkösiä myös tunnuksissaan. Onko ne tarpeen korjata? Mistä niihin helpoiten pääsisi käsiksi?


Aleksi "Lex" Kilpinen

Älä innostu korjailemaan liikaa vielä, koitetaan ensin löytää syy tähän.
Foorumin juuressa on tiedosto Settings.php, onko siellä riviä
$db_character_set = 'utf8';
Jos ei ole, niin koita lisätä se sinne omana rivinään - tsekkaa uudestaan miltä nuo tekstit näyttää foorumilla.
Jos on, ota hetkeksi pois ja katso miten vaikuttaa.
A Finnish Project Manager (Support Specialist)
 Happily running multiple SMF 2.x installations.
  Fooling around with i7-10700 @ 2,90GHz-4.80GHz / 16Gb / RTX-2070 Super / 3840x2160 / Win 10 x64


How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum. Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Advertisement: