Problems with apostrophes and quotes in the title

Started by riflessioni, December 29, 2021, 08:43:08 PM

Previous topic - Next topic

riflessioni

After upgrading from 2.0.18 to 2.0.19 I encountered the following problem:
all topics with an apostrophe or quotation marks in the title, clicking on them refer to the index of the section and not to the topic.

MOD
1.    ugc external links    1.0.0
2.    Responsive Curve    1.0.0
3.    Optimus    1.9.7
4.    Pretty URLs

Roger2

Nil illigitimis el carborundum

shawnb61

I cannot reproduce this.

Any clues/errors anywhere?  In the browser console?
Address the process rather than the outcome.  Then, the outcome becomes more likely.   - Fripp

Kindred

Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Dave J

Just a thought as this happened to me on an earlier version of SMF.

Try editing the post/link and delete the exisiting apostrophes and replace them with new ones. I found that links that had been copied from the net had some other properties that caused issues.

This might have nothing to do with it at all but anything is worth a try in my opinion.
If you want quizzes to add to the new SMF2.1 quiz mod go here . There are also walkthroughs in the forum to explain how to install them and other tips.

Steve

DO NOT pm me for support!

riflessioni

I solved it by updating the pretty urls MOD.

Doug Heffernan

Quote from: riflessioni on February 27, 2022, 08:38:08 AMI solved it by updating the pretty urls MOD.

Thanks for sharing the solution. :)

It can help other users in the future who might run into the same issue.

Sebastiii

Hello,
I can confirm the same issue and updating to PrettyURLs right now to validating it locally, and it works.
Thanks.

Steve

Btw, the latest Pro version of SMFPacks Auto Media Embedder causes the same problem. I've notified the mod creator.
DO NOT pm me for support!

Advertisement: