News:

Want to get involved in developing SMF, then why not lend a hand on our github!

Main Menu

Re: No Email notifications

Started by Gavin Chatt, May 31, 2022, 10:08:22 PM

Previous topic - Next topic

Gavin Chatt

My domain was blocked at the server

I'm at the same point and was wondering how you unblocked this at the server side?

Appreciate any assistance, thank you.

Edit#
Sorry, just noticed how old this post was, should I start a new post or run with the search reasults?

Please note I had also tested using the testmail option and this provided a good result in sending but no email was recevied.
Regards
Gavin Chatt
Austeam Founder
http://austeamracing.com.au

Kindred

Слова
Украина

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Gavin Chatt

Yes tried that, cheers.

All they mentioned was that we would not  able to use PHP option as this is emailed direct from the host details and would cause issues as such recommended the use of paid SMPT plugin and I already pay out a load for this non profit league for a number of different needs lol.

Right now the administrator needs to register users and set up the needs based on the league requirements as the emails fail to arrive when needing the activation completed.

Regards
Gavin Chatt
Austeam Founder
http://austeamracing.com.au

Chief of Nothing

Your host doesn't sound very good. I don't have a 2.0.x forum running to check but is there an option to use SMTP in 2.0.x SMF? There is in 2.1.x and it works well in my testing.

Gavin Chatt

Hi and thank you for your reply.

Yes but the settings I've been informed to use still has no emails come through.

Removed the settings before saving the image

Regards
Gavin Chatt
Austeam Founder
http://austeamracing.com.au

Chief of Nothing

Ok, so checking 2.0.19's source the smtp_mail code isn't much different to 2.1.x.

Is your SMTP server using SSL? ie, port 465? If so you may need to do this when using SMTP, I found this out the long way around in my testing on my 2.1 development forum when emails failed to send using SMTP without doing this. Prepend tls:// or ssl:// before the SMTP servers name, eg tls://yoursmtpserver.example

If your server is not using SSL (port 25, hopefully not!) then the above isn't required and it's possible that your host doesn't have fsockopen enabled in PHP, which is what the smtp_mail function uses.

Kindred

you do not have to PAY to get SMTP mail...   people have even configured their system to use google's SMTP for gmail.


I don't know why your host would say to not use phpmail however....       it seriously sounds like you need a new host, because I use phpmail on 8 different sites with no issues.
Слова
Украина

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Gavin Chatt

Quote from: Chief of Nothing on June 01, 2022, 09:26:42 AMOk, so checking 2.0.19's source the smtp_mail code isn't much different to 2.1.x.

Is your SMTP server using SSL? ie, port 465? If so you may need to do this when using SMTP, I found this out the long way around in my testing on my 2.1 development forum when emails failed to send using SMTP without doing this. Prepend tls:// or ssl:// before the SMTP servers name, eg tls://yoursmtpserver.example

If your server is not using SSL (port 25, hopefully not!) then the above isn't required and it's possible that your host doesn't have fsockopen enabled in PHP, which is what the smtp_mail function uses.


Thanks once again - tried a number of options including one of my other email accounts but nothing has fixed the issue.

To clarify, I've tried

SMTP server
mail.XXXXXXXXXXXX.com.au | ssl://mail.xxxxxxxxxxxx.com.au | ssl://xxxxxxxxxxxx.com.au

PORTS
25
465

Tried two different mail hosts but the SMF on the same host.

Not sure why this is such an issue. I'm lookin to install another forum option to see if this will sort the issue, I can't keep registered users manually and activating them, its a lot of people lol

Thanks once again @Chief of Nothing appreciate you trying to assist.
Regards
Gavin Chatt
Austeam Founder
http://austeamracing.com.au

Gavin Chatt

I don't like the forum but installed phpBB and can receive emails, I've condensed the email below to keep the post length simple :)

Hello Admin,
The topic "EMAIL TESTING" received a new reply by Gavin Chatt since your last visit to "My Board". No more emails will be sent until you visit the topic.
If you want to view the newest post click the following link:
LINK REMOVED
If you want to view the topic, click the following link:
LINK REMOVED
If you want to view the forum, click the following link:
LINK REMOVED
If you no longer wish to watch this topic click the following link:
LINK REMOVED

Thanks, The Management

Regards
Gavin Chatt
Austeam Founder
http://austeamracing.com.au

Chief of Nothing

Well, we can always try and find out what the server responses are when trying to use SMF's SMTP implementation. I wrote up a script to help another user but that user solved the problem anyway before I finished it. It wouldn't take long to backdate it to 2.0.19's implementation from 2.1.1.

Let me know if you'd like to try it.

Steve

I would be remiss if I didn't post a word of caution.

No offense to @Chief of Nothing because from I know of him, he knows what he's doing, but one should always be cautious about running scripts from members you're unfamiliar with.

Backup, backup, backup.
Please do not PM me for support.

Chief of Nothing

No offense taken @Steve, I'm actually happy you posted the warning; and thanks for the vote of confidence too  :)

Script is probably the wrong word, the script is nothing more than SMF's own smtp_mail function ripped out into it's own stand alone file with a lot of echos added for displaying the SMTP server responses so one can see what's happening as the function progresses; inbuilt debugging and logging in SMF, while good, is still a bit lacking.

Shambles

Just diving in here... @Gavin Chatt does your host give you cPanel access?  If so, there should be a section in there wherein you can see server failures while handling email (and the reasons why they failed).





Worth ruling out.

Gavin Chatt

@Shambles

So so sorry for such a late reply, I do have access and can see this area and after running some tests this morning I don't see any information Successful or Failed.

I see three failed notification from the System showing an email address name is note listed (which is corrected) dated June 13th and the last successful event also June 16th.

Emailed myself from myself and this reported and reported successfully.
Regards
Gavin Chatt
Austeam Founder
http://austeamracing.com.au

Advertisement: