Error when clicking login button

Started by michaelcrook, January 19, 2023, 10:21:34 PM

Previous topic - Next topic

michaelcrook

When people try to sign up to my forums, they get "error" when they click on the log in button.  I've looked all over this site and via Google to see how this can be resolved.

It doesn't appear to be a redirect issue: htxxp://michaelcrook.org/bbs [nonactive]

Any help would be appreciated...I've exhausted all other options at this point...no one can log in so I hope I can fix this.  But they can sign up??? 

Thanks.

Topic title changed to reflect subject of topic. Please try to do this in the future. ~ Steve

Diego Andrés

Because they're likely using https://www.web.com instead of the URL you setup for the forum which is without the www

SMF Tricks - Free & Premium Responsive Themes for SMF.

michaelcrook

Quote from: Diego Andrés on January 19, 2023, 10:34:04 PMBecause they're likely using https://www.web.com instead of the URL you setup for the forum which is without the www

Okay, how do I fix that?  I'm looking for a config page where I can fix the title, url, etc.  I really like SMF and I want to keep it, so hopefully this can be resolved.  Thanks in advance for the help.

Diego Andrés

You can add a redirect in your cPanel.
Or add a rule to your htaccess file:

Quote from: Diego Andrés on October 17, 2022, 11:31:17 PMProbably, but you can add a rule to your htaccess file.

RewriteEngine On
RewriteCond %{HTTPS} !=on
RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

Other option:
Quote from: Shades. on October 18, 2022, 09:28:32 PM# Always use https for secure connections
# Replace 'www.example.com' with your domain name
# (as it appears on your ssl certificate)
RewriteEngine On
RewriteCond %{SERVER_PORT} 80
RewriteRule ^(.*)$ https://www.example.com/$1 [R=301,L]

SMF Tricks - Free & Premium Responsive Themes for SMF.

Oldiesmann

Quote from: michaelcrook on January 19, 2023, 10:39:00 PM
Quote from: Diego Andrés on January 19, 2023, 10:34:04 PMBecause they're likely using https://www.web.com instead of the URL you setup for the forum which is without the www

Okay, how do I fix that?  I'm looking for a config page where I can fix the title, url, etc.  I really like SMF and I want to keep it, so hopefully this can be resolved.  Thanks in advance for the help.

You can change the title of the forum at Admin -> Maintenance -> Server Settings -> General
You will need to use repair_settings.php (available from the Tools section of the downloads page) to fix the URL. See https://wiki.simplemachines.org/smf/Repair_settings.php for more information on that.
Michael Eshom
Christian Metal Fans

Steve

DO NOT pm me for support!

Advertisement: