• Welcome to Simple Machines Community Forum. Please login or sign up.
October 19, 2021, 01:46:02 PM

News:

SMF 2.0.18 has been released! Please update. Read more.


Custom Profile Field Mod

Started by winrules, March 30, 2006, 02:21:25 PM

Previous topic - Next topic

mark7144

Thanks!

I used your mod with the YouTube one to create this:

http://www.murraysworld.com/talk/index.php?action=profile;u=2

Hope you like it ;)

Kalika

Can anyone please tell me what files need to be set writeable in order for this mod to install, so I can set them writeable manually?  I haven't been able to get this installed to save my life.   :-[  thanks!

winrules

Kalika - just chmod all the files that are lsited to be modified to 777.


winrules
SMF Developer
               
My Mods
Please do not PM me for support.


Kalika

That's the thing, I don't know which files need to be modified.. it doesn't tell me when it tries to install, it just asks for my FTP information and when I enter it, it takes me back to the very same page.   :)

vaulot

I got the exact same problem with the supposedly new verions for SM 1.1....  ???

mark7144

I really love this mod but it could just be me but the administration side of it seems very buggy (on my non-default theme).

Adding a new field doesn't happen unless I first click 'Add Field' then uncheck one of the other fields, then click save and then I assume I should have them all checked again.

The same process has to happen if I try and move the position up or down.

Also once getting it to move up or down, all of my profiles used the same description from another one.


0897jhPEFUOIyG90

I have noticed that more than one user has lost functionality of this mod when upgrading to 1.1 final.

You may want to have a look at the code in "upgrade_1-1.sql" in the "smf_1-1_update.zip" package.

Particularly the code commented:

/******************************************************************************/
--- Installing new default theme...
/******************************************************************************/

---# Installing theme settings...
---{
// This is Grudge's secret "I'm not a developer" theme install code - keep this quiet ;)


;) shhhhh! (maybe it wasn't such a good idea...)


I'm not quite sure about it yet, but I suspect that these changes to the default theme in the update will adversely affect the function of the custom profile field mod and its derivatives.

I will advise once I get a look at a site that has had a derivative of this mod borked by updating to 1.1 final.

winrules

Kalika, vaulot - Have you installed any other mods successfully?

mark7144 - Yes, I know that there are many bugs. The problem is really the backend of it - it uses a system that is designed for individual static options. I'm currently rewriting it using a much better system.

0897jhPEFUOIyG90 - You will have to reinstall the mod after upgrading.


winrules
SMF Developer
               
My Mods
Please do not PM me for support.


Kalika

winrules - No, I can't get any mod on any of my versions of SMF to install.  They all do the same thing.  I know it's not a problem with your mod.   :)  I just thought that if I could manually set the files writeable, I could skip the whole 'enter your FTP info' screen and advance to get the mod installed.. that's what I had to do to install SMF to begin with.  It wouldn't install or accept my FTP info, so I set the necessary files writeable and it went on with the install.

mark25

Quote from: mark7144 on December 10, 2006, 09:50:39 PM
I'm on SMF1.1 final and everything seems to be working but if you have someone as a 'buddy', when viewing their profile the 'Remove Buddy' text moves all the way to the top.

My only additional profile field is the 'Bebo' one.

Can someone help please?


same problem.

mark7144

Quote from: mark25 on December 14, 2006, 10:55:04 PM
Quote from: mark7144 on December 10, 2006, 09:50:39 PM
I'm on SMF1.1 final and everything seems to be working but if you have someone as a 'buddy', when viewing their profile the 'Remove Buddy' text moves all the way to the top.

My only additional profile field is the 'Bebo' one.

Can someone help please?


same problem.

And we're both called mark... SPOOKY!  :P

tarsia

Hello,

I'm using the mod in SMF 1.1. It's working fine and i'm using some custom-field on the register-page. But i have a question:

Is it possible that the custom-fields would appear above and not under the "Visual verification" on the register page?

If yes, what do i have to change?

Many thanks
tarsia
SMF 1.1

Kindred

WOW!!!!   I seem to have found a BIG oversight here...

if you add a custom text field, there is no limit to the number of characters that can be added...

in other words, in the display screen, a person can have 300 lines of text added...

I think you need to add a maxlength stat in the field settings... 
(the current "size" of the field is set to 50, but that should probably be the same size as "maxlength", especially if you make it into a settable variable.)

for the moment, I have change the field size and maxlength (in my set up) to 25...
If anyone else is interested in 'fixing" this:

line 31 in CustomProfile.php

<td><b>' . $modSettings['CP' . $i . '_name'] . ': </b>' , !empty($modSettings['CP' . $i . '_desc']) ? '<div class="smalltext">' . $modSettings['CP' . $i . '_desc'] . '</div>' : '' , '</td><td><input type="text" name="default_options[' . $modSettings['CP' . $i . '_id'] . ']" size="25" maxlength="25" value="', @$context['member']['options'][$modSettings['CP' . $i . '_id']], '" /></td>
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

Dem0n

The package you are trying to download or install is either corrupt or not compatible with this version of SMF.

I get the following error when trying to install on 1.1 Final.

mark7144

December 16, 2006, 10:35:13 PM #734 Last Edit: December 16, 2006, 10:41:45 PM by mark7144
Quote from: Kindred on December 16, 2006, 06:49:04 PM
WOW!!!!   I seem to have found a BIG oversight here...

if you add a custom text field, there is no limit to the number of characters that can be added...

in other words, in the display screen, a person can have 300 lines of text added...

I think you need to add a maxlength stat in the field settings... 
(the current "size" of the field is set to 50, but that should probably be the same size as "maxlength", especially if you make it into a settable variable.)

for the moment, I have change the field size and maxlength (in my set up) to 25...
If anyone else is interested in 'fixing" this:

line 31 in CustomProfile.php

<td><b>' . $modSettings['CP' . $i . '_name'] . ': </b>' , !empty($modSettings['CP' . $i . '_desc']) ? '<div class="smalltext">' . $modSettings['CP' . $i . '_desc'] . '</div>' : '' , '</td><td><input type="text" name="default_options[' . $modSettings['CP' . $i . '_id'] . ']" size="25" maxlength="25" value="', @$context['member']['options'][$modSettings['CP' . $i . '_id']], '" /></td>

Thanks, I also was worried over this issue.

maxlength="70" was much more appropriate for my forum btw.

tarsia

Hi,

if you insert the maxlenght and are using a customfield on the register page, i think it makes to change line 88 (function RegistrationFields), too

tarsia
SMF 1.1

mgaidia

Can you please add statistics.
so we can see how many members chose a specific option.

Livethefire

Ok I am setting up a forum and I have Mambo version: 4.6.1

I have downloaded and installed SMF 1.1
I have downloaded and installed (the mod doesnt install successfully) "1.3.2 beta 1 [SMF 1.1]" >  MamboSMFForum_1.3.2b1.zip
which has the component and the mod.

the component works perfect, but the mod brings back a few test failures:

1.     Execute Modification     ./index.php     Test successful
2.    Execute Modification    ./Themes/default/script.js           Test failed
3.    Execute Modification    ./Sources/Post.php                    Test successful
4.    Execute Modification    ./Sources/Subs-Post.php         Test failed
5.    Execute Modification    ./Sources/Profile.php                     Test successful
6.    Execute Modification    ./Sources/Subs.php                    Test failed
7.    Execute Modification    ./Sources/LogInOut.php                   Test successful
8.    Execute Modification    ./Sources/QueryString.php          Test successful


I have tried several other components and mod packages, but this one brigns back less test failed, all other ones bring back more than three.
I have no other mods installed and these results where tested STRAIGHT after i uploaded and installed the SMF 1.1


What will I do to get the mod working?

thanks.

sparky33

Just installed, and it "seems" to be working, I can't tell at the moment as it doesn't show in profiles of already registered members, as a retrospective, but if I go to my forum as a guest and open the registration page, it does ask me to fill in the fields??? I'm using Babylon theme and SMF 1.1.1
www.dublinforums.org

www.renaultforums.co

!Hachi!

i am unable to delete fields after adding new one and fields number getting mix up..any idea guys like 2 fields have same field id....ah
Happy Ramadan

Advertisement: