News:

Bored?  Looking to kill some time?  Want to chat with other SMF users?  Join us in IRC chat or Discord

Main Menu

Paid Subscriptions

Started by Grudge, August 12, 2006, 06:09:49 AM

Previous topic - Next topic

merm

It only seems to cause a problem if you check "make recurring".

If you do it as a regular subscription type it's no problem.

LBizGrl

I am using it on 1.1

It installs Ok...it lets me do the settings and add the options...

But...

It is not showing up in the profile. It says that there are no subscriptions available...

It says "activated...yes" in the back office...

Any thoughts??
Smile! :)

It burns WAY more calories than a frown!

bri

Getting this error...

Unknown transaction type in ipn.php

I imagine something is messed up on the paypal side, do I need to set something up there as well?

Thanks, love the mod!
<*)))><

snork13

Quote from: bri on December 18, 2006, 01:33:49 PM
Getting this error...

Unknown transaction type in ipn.php

I imagine something is messed up on the paypal side, do I need to set something up there as well?

Thanks, love the mod!

Hey Bri...paypal could be return some trans that not in the array? I haven't looked at this mod in depth though
Mods
Please DO NOT PM me with requests for individual support, but post your questions and concerns in the appropriate section of the forum where other users can benefit from them as well. Thank you.
I have been super busy as of late. Working on updates to all my modifications for 2.0.1

bri

lol hey snork :) Yeah, I think it may be something on the paypal side, playing with both atm...
<*)))><

bri

#305
followup.... non-recurring payment work flawlessly, it's the recurring payment that is fowled up a bit. hmmmm... any advice?
<*)))><

JayBachatero

What version of the mod are you using?  Also do you have a donate buttom somewhere in your site?
Follow me on Twitter

"HELP!!! I've fallen and I can't get up"
This moment has been brought to you by LifeAlert

bri

everything is the latest version, no donate buttons or mods, I am pretty sure it's an error in the ipn.php understanding what paypal is coming back with for a recurring subscription. The normal ones work flawlessly..
<*)))><

bri

<*)))><

madfiddler

Have I found the problem???

Going through the error logs on my forum, and ipn.php has come up as a missing file.

The directory mine is in is Subs, however in package-info.xml the directory is subs (no capitals).

Should I change this?

madfiddler

Ha - on top of that I notice that the files in Subs are all old dates... So my guess is that an old version used Subs as a directory name, that got changes to subs and every install since, the files haven't copied into the directory? In which has, why didn't the package manage tell me it wouldn't be able to copy some files across.

JayBachatero

The dir name supposed to be subs.  The files are not supposed to be in the Sources dir.
Follow me on Twitter

"HELP!!! I've fallen and I can't get up"
This moment has been brought to you by LifeAlert

madfiddler

..didn't say it was in the Sources directory.. I have a directory called Subs, not subs.. I'm trying to test this now...

JayBachatero

Well it should be subs.  In linux case matters.
Follow me on Twitter

"HELP!!! I've fallen and I can't get up"
This moment has been brought to you by LifeAlert

madfiddler

Yep, that's my thinking, and hence my problems.. Just guessing that a really old version of the mod had "Subs" as the directory..

madfiddler

Here's another question.. Why is it, that the mod forces people to pay via eCheque with paypal rather than using money in their account. I'm talking about US'ers mainly. I take payment in ££. This never used to be a problem. Perhaps it's a change in the way PayPal do things?

bri

<*)))><

madfiddler

OK - new problem with the paid subs admin. I've just done a clean 1.1.1 install with the language files, and when you click on the paid subs admin, the main SMF forum page loads.

This has happened 3 times.

Any thoughts?

Ta,

m

madfiddler

hmmm - I don't know why - but this isn't getting altered in index.php


<search for>
'post' => array('Post.php', 'Post'),
</search for>

<add before>
'paidsubscribe' => array('ManagePaid.php', 'ManagePaidSubscriptions'),
</add before>

bri

never had that happen, been ok here on all installs... tho I am confused when you say "click on the paid subs admin". What exactly do you mena?
<*)))><

Advertisement: