News:

Wondering if this will always be free?  See why free is better.

Main Menu

TrimUrl

Started by JayBachatero, August 18, 2006, 02:17:04 PM

Previous topic - Next topic

JayBachatero

Link to Mod
Rate this Mod

This mod will trim url a la vB style.

http://www.google.com/search?q=jaybachatero&start=0&ie=utf-8&oe=utf-8&client=firefox&rls=org.mozilla:en-US:unofficial
will become
http://www.google.com/sea....mozilla:en-US:unofficial

Ver 1.0.1
! Fixed bug with img tags.
! Make sure that $urlNew is returned even if $url is not long enough.
! Fixed bug with uninstall
Follow me on Twitter

"HELP!!! I've fallen and I can't get up"
This moment has been brought to you by LifeAlert

Harzem

Nice and useful mod :) That was asked a lot in the boards here I moderate :)

N3lson

#2
Nice Mod....
I´m Portuguese Yeah

ArkServer

After installing this mod, the links in my signature disappeared but when i go to my profile and check my sign its still there..

JayBachatero

Umm will have to look into that one Ark.
Follow me on Twitter

"HELP!!! I've fallen and I can't get up"
This moment has been brought to you by LifeAlert

K_4_kelly

oh... i like this one ;)

L.G.S

Nice mod

question: what's the basis for this mod?

I mean like when does it choose to limit the link?

Is it after the first / or after certain amount of characters?
FREE and LIVE World Cup + Premier League football streams:

www.gamesandgoals.com


Gary

A nice mod and it does come in handy. But I've noticed that when you post a URL (such as one from YouTube) (eg: http://youtube.com/watch?v=niYFEl8mzrU) the link doesnt appear at all.
Gary M. Gadsdon
Do NOT PM me unless I say so
War of the Simpsons
Bongo Comics Fan Forum
Youtube Let's Plays

^ YT is changing monetisation policy, help reach 1000 sub threshold.

K_4_kelly

can we have a TrimQuote as well? ;)

JayBachatero

TrimQuote?  BTW upgrade your mod to the latest one.  Big bug was fixed.
Follow me on Twitter

"HELP!!! I've fallen and I can't get up"
This moment has been brought to you by LifeAlert

K_4_kelly

Jay,

i just installed the 1.0.1 version, but have a look the photo below...
we have two ./Sources/Subs.php




-------
TrimQuote =
When a member insert a very long quote from previous post..
will become
hello blahblahlabl...........blablablah

dont know why some of my members like to quote the entire message from previous post when they reply...
if the mod can be done, probably can set something like "if the quote more than 500 words, it will then automatically become to  hello blahblahlablabalabalabal....blablablah" ....
not sure if this possible..... anyway just a suggestion...


K_4_kelly

#11
Quote from: AwwLilMaggie on August 18, 2006, 08:39:07 PM
A nice mod and it does come in handy. But I've noticed that when you post a URL (such as one from YouTube) (eg: http://youtube.com/watch?v=niYFEl8mzrU) the link doesnt appear at all.


i got the same... how to fix it?
cos all the URL is dissapearred

rockinaway

Quote from: K_4_kelly on August 19, 2006, 03:50:25 AM
TrimQuote =
When a member insert a very long quote from previous post..
will become
hello blahblahlabl...........blablablah

dont know why some of my members like to quote the entire message from previous post when they reply...
if the mod can be done, probably can set something like "if the quote more than 500 words, it will then automatically become to  hello blahblahlablabalabalabal....blablablah" ....
not sure if this possible..... anyway just a suggestion...


That would be a good idea... and to have it so that you can have a link saying click here for more... and it shows the whole quote on same page... just expanded.
Have I helped you? Then please join AdminFuel - The forum for forum administrators.

If you need help managing your forum, or maybe launching it, then visit us and view the quality articles, downloads and posts.

K_4_kelly

Quote from: K_4_kelly on August 19, 2006, 04:57:09 AM
Quote from: AwwLilMaggie on August 18, 2006, 08:39:07 PM
A nice mod and it does come in handy. But I've noticed that when you post a URL (such as one from YouTube) (eg: http://youtube.com/watch?v=niYFEl8mzrU) the link doesnt appear at all.


i got the same... how to fix it?
cos all the URL is dissapearred

though i uninstalled the problem still there..... :'(

K_4_kelly

oh ...
another bug is here:

when i insert photos

for example : [img]http://i13.photobucket.com/albums/a286/fallenangel4/insertlink.jpg[/img]
it become like this after i posted  [img=http://i13.photobucket.com/albums/a286/fallenangel4/insertlink.jpg]http://i13.photobucket.com/albums/a286/fallenangel4/insertlink.jpg[/img]

it couldnt display the photo...... :'(  :(

JayBachatero

K_4_Kelly the problem was with the uninstall of 1.0.  For some reason a var gets dropped by SMF.  Here is the subs.php you sent me.  It should install fine now.
Follow me on Twitter

"HELP!!! I've fallen and I can't get up"
This moment has been brought to you by LifeAlert

K_4_kelly

thanks jay,
but...
problem still there..

]


JayBachatero

Ok let me look into all of the files that you sent me.  Did you uninstall the mod? Or it's installed?
Follow me on Twitter

"HELP!!! I've fallen and I can't get up"
This moment has been brought to you by LifeAlert

JayBachatero

Ok here are the files and everything should be working.  The mod is installed now.
Follow me on Twitter

"HELP!!! I've fallen and I can't get up"
This moment has been brought to you by LifeAlert

GC

Ive installed and uninstalled this mod and I still get the IMG tag problem, why?

Advertisement: