• Welcome to Simple Machines Community Forum. Please login or sign up.
September 22, 2021, 10:05:06 AM

News:

SMF 2.1 RC4 has been released! Try it out and help us test! :) Read more.


CHMOD

Started by Elisa, May 21, 2004, 12:11:31 PM

Previous topic - Next topic

Elisa

Ciao a tutti, vi chiedo un aiuto per l'installazione della versione smf 1.0. beta5.
Io ho fatto l'upload di tutte le cartelle ma non riesco ad attribuire i chmod. Può essere perchè il mio S.O. è windows? Avete un'idea di come posso fare per procedere nell'installazione?
L'errore che mi da, subito aprendo la prima pagina www.../install.php è:

You're on a windows server, and some crucial files are not writable. Please ask your host to give write permissions to the user PHP is running under for the files in your SMF installation.

Click here to try this step again.

Supreme

scusa... ma è il tuo host.. sarai sicuramente su NT

Tony Reid

install as administrator or change NT permissions for your acount

installi windows coordinatore
Tony Reid

Elisa

Il mio sistema operativo è windows xp.
Sull'host è installato mysql.
Via ftp non riesco assolutamente a cambiare i chmod. Ho trovato un sistema per cambiarli tramite dos in windows ma non funziona nemmeno quello. Avete altre idee?
Se potete rispondermi in italiano ve ne sono molto grato perchè l'inglese non lo capisco!
Grazie mille!

jami

c'è un po di confusione: quale sia il tuo sistema operativo di casa e se riesci a cambiare i permessi dei file, non ha assolutamente effetto ( a meno che non sia la tua macchina a funzionare da server ) sull' impostazione dei chmod dei file remoti.

La gestione dei permessi su windows e linux ( o unix ) non funziona alla stessa maniera, comunque esiste una sorta di emulazione per windows, per cui su alcuni servizi di hosting windows ( es. aruba.it ) è possibile tramite un normale client ftp ( es. cuteftp ) effettuare dei chmod su file e directory.

la soluzione ideale rimane contattare il supporto dell' hosting e chiedere un aiuto al riguardo.

FaSan

Quote from: desio on May 21, 2004, 12:11:31 PM
You're on a windows server, and some crucial files are not writable. Please ask your host to give write permissions to the user PHP is running under for the files in your SMF installation.


Devi semplicemente abilitare il scrittura il file Settings.php, inquanto l' installazione prevede di scriverci dentro la configurazione. Come già accennato da Jami un software FTP che preveda il chmod (cuteftp e wsftp ad esempio) e stai apposto :)



FaSan

Elisa

Io utilizzo il flashFXP che permette di settare i permessi, ma quando provo mi dice che l'operazione è impossibile. Da quello che ho capito è aruba che non permette la modifica dei permessi su files o cartelle, sbaglio?

jami

May 23, 2004, 10:22:12 AM #7 Last Edit: May 23, 2004, 10:24:29 AM by jami
se non ricordo male poco tempo fa aruba aveva detto che tutti i nuovi file .php, e cartelle che li contengono, che venivano caricati dovevano essere settati con 755, ma a scanso di equivoci ad ogni upload in ftp di default ( da aruba.it stesso ) vengono impostati i permessi 755.

quindi quando fai l' upload i file dovrebbero avere già da soli un 755.

io utilizzo sia hosting windows only che linux only su aruba, ed in entrambi i casi ( con cuteftp ) non ho problemi di settaggio dei permessi

Elisa

Si mi sono accorta anche io che le cartelle sono già settate su 755, ma i singoli files che andrebbero a 666 sono a 664 e non capisco perchè e soprattutto non li posso modificare!
Su altervista ho uppato tutto e funziona a meraviglia però è molto più lento!
Non so più che pesci pigliare!

edi67

si purtroppo la pecca di aruba e quella di non consentire il cambio dei permessi CHMOD nelle cartelle normali

altervista  un ottimo spazio e dubito meno veloce io ho avuto entrambi gli spazi e devo dire che altervista oltre che essere gratis funziona e supporta bene SMF:

ciao
CrazyZone - My SMF Forum


From the difficult the hardening of the man you can see

Elisa

Sono riuscita ad installare tutto. Aruba mette a disposizione 5 cartelle con permessi diversi, ho cambiato cartella ai file uppati ed ora funziona! Grazie a tutti per l'aiuto!

Advertisement: