• Welcome to Simple Machines Community Forum. Please login or sign up.
October 15, 2021, 06:06:38 PM

News:

Wondering if this will always be free?  See why free is better.


K-Detection: Detect OS & Browser Version

Started by Nikola_, October 07, 2006, 08:15:24 PM

Previous topic - Next topic

Nikola_

October 07, 2006, 08:15:24 PM Last Edit: May 04, 2007, 10:33:01 AM by Nikola_
Link to Mod


K-Detection: Detect OS & Browser Version
Version 2.2

This modification add OS & Browser Version in every post (it will be displayed after user custom text)

No option to turn it on or off - automatically turned on for all posts.

Supported Operating Systems: almost all :)
Supported Browsers: almost all :)

Changes log:

* Version: 2.2
  - Fixed some problems from v2.1

* Version: 2.1
  - Fixed bugs from K-Detection v2.0
  - Fully reversible (uninstalls cleanly)
  - Removed support for older version of SMF

* Version: 2.0
  - Added support for 1.1.2
  - Added Pictures of OS & Browsers
  - Install/uninstall cleanly
  - Added more OS & Browsers

* Version: 1.1
  - Added support for 1.0.6, 1.0.7, 1.0.8, 1.1 RC1, 1.1 RC2 & 1.1 RC3
  - Install/uninstall cleanly
  - Added more OS & Browsers

* Version: 1.0
  - Released for 1.0.8
  - Install/uninstall cleanly

steve in houston


xcrazyxfrogx

I installed but seems its not working i cant see anything !  :-\


Money... my obsession... Wealth... my addiction... Fear... my weapon... Crazy people... don't you understand... from the smokes of fear... who I am?

nightmist

I installed the mod and it added a tag at the end of my posts next to the page number. This is what it adds K-Detection Mod © 2006. So now my posts look like this:

[1] [2] K-Detection Mod © 2006

Throws off my them buttons at the end of posts for reply and so on. Worst thing is I cannot even find this code. Not really happy about the idea of a mod trying to place junk like that were it shouldn't be so I uninstalled it. Cool idea but just went a little to far.

Badboy

October 09, 2006, 05:19:31 AM #4 Last Edit: October 10, 2006, 09:38:14 AM by Badboy
Thx Great Mod. I like it much.

But there is a small problem... :)

8: Undefined index: aol
File: c:\appserv\www\forumrc2\Sources\K_Detection.php
Line: 250


To fix this (it works for me but i am not sure) :-\
Open K_Detection.php and find this

        $bd['version'] = "n";

Add after
        $bd['aol'] = "n";


And u can add this for security
Find this

/*
K-Detection v1.1 by Nikola
www.kupus.org
poslednja izmena: 04.10.2006.
*/


Add after
if (!defined('SMF'))

die('Hacking attempt...');


Thx...
Nothing is true, everything is permitted.

Gobo

hi

this mod dosent work it seems

it displays nothing upon install

Nikola_

Quote from: akulion on October 13, 2006, 05:46:30 PM
hi

this mod dosent work it seems

it displays nothing upon install

that problem is because you do not use default smf theme for that version

you need to edit manually Display.template.php

Nikola_

Quote from: xcrazyxfrogx on October 08, 2006, 08:30:42 PM
I installed but seems its not working i cant see anything !  :-\

same problem as @akulion

you need to edit manually Display.template.php
because you do not use default theme for your version of forum

Elegant John

I liked the idea of this mod until I got to looking at it, and looking at the website it was linked to.

Gentlemen, and gurlz, I have a major problem with anything coming out of Russia. I run a mega site discussion forum (not LONL) powered by IPB and we have been being hit with spammers and hackers from Russia and Educational institutions in China.

I would be extremely leery of anything that exhibits behavior such as this without doing as it advertises. A sad commentary of our times folks.

!Hachi!

Happy Ramadan

Nikola_

Quote from: hassan on October 15, 2006, 11:24:30 AM
what about vista?

currently there is not Vista detection in version 1.1 but you can add it manually
find this code in file Sources/K_Detection.php
        if (eregi("Windows NT 5.1", $agent))
            $bd['platform'] = "Windows XP";

and after it add
        if (eregi("Windows NT 6.0", $agent))
            $bd['platform'] = "Windows Vista";


or you can wait because version 2.0 will be available soon
it will have more OS and Browsers even pictures of them

Gobo

nope it dosent work on default for me

i always test mods on default - this one produced only 1 thing - a copyright link and in the profile template nithing showed up

dunno why

Nikola_

Quote from: akulion on October 16, 2006, 01:33:27 AM
nope it dosent work on default for me

i always test mods on default - this one produced only 1 thing - a copyright link and in the profile template nithing showed up

dunno why

maybe because mod do not display OS and Browser version for posts that are posted before mod has been installed (it will display OS and Browser only for new posts that are posted after mod installation)

Gobo

Quote from: Nikola_ on October 17, 2006, 12:09:09 PM
Quote from: akulion on October 16, 2006, 01:33:27 AM
nope it dosent work on default for me

i always test mods on default - this one produced only 1 thing - a copyright link and in the profile template nithing showed up

dunno why

maybe because mod do not display OS and Browser version for posts that are posted before mod has been installed (it will display OS and Browser only for new posts that are posted after mod installation)


oohhh so that is why
it is cool feature to have
but problem for me is i have already 1000+ members and 30000+ posts so it will look strange for old posts not to have it and new posts to have it

but no way around it either - whats posted is posted lol

thanks anyways - ill put this on any new pages i make :)

xcrazyxfrogx

October 17, 2006, 10:38:13 PM #14 Last Edit: October 17, 2006, 10:40:17 PM by xcrazyxfrogx
U need to edit ur template Display.Template.php file for each theme (if it has)

look for:

Quote// Show their personal text?
                        if (!empty($settings['show_blurb']) && $message['member']['blurb'] != '')
                                echo '
                                                                ', $message['member']['blurb'], '<br />
                                                                <br />';

and Add After :-

Quote//K-Detection
                         if (!empty($message['k_os']))
                      {
                        if ($message['k_os']!="n") echo '<b>OS:</b> ', $message['k_os'], '<br/>';
            
                        if ($message['k_br']!="n") echo '<b>Browser:</b> ', $message['k_br'];
            
                        if ($message['k_ver']!="n") echo ' ', $message['k_ver'], '<br/>';
            echo '<br/>';
         }                  

But strange nikola it showing The version for Old Post too lol i have installed it and it also shown up in old posts is it bad lol m confuzzled???? ! ::) ::)


Money... my obsession... Wealth... my addiction... Fear... my weapon... Crazy people... don't you understand... from the smokes of fear... who I am?

Gobo

xcrazyxfrogx i already did that with no luck

but ill give it another try - maybe i made some error the 1st time round - so ill check - thanks

Gobo

reinstalled - works but only for new posts for me, not the old ones

ill include this on my new page only when i launch it

the old page can do without it - thanks either ways :)

Vinspire

Quote from: akulion on October 18, 2006, 12:59:46 PM
reinstalled - works but only for new posts for me, not the old ones

ill include this on my new page only when i launch it

the old page can do without it - thanks either ways :)

This mods seem to work only with the post after you've just installed the mods.

It is quite an awesome mod and i like the idea but i have to second nightmist regarding the idea of adding [1] [2] K-Detection Mod © 2006 ... It look very annoying to me so i decided to uninstall the mod.

Quote from: nightmist on October 09, 2006, 12:16:15 AM
I installed the mod and it added a tag at the end of my posts next to the page number. This is what it adds K-Detection Mod © 2006. So now my posts look like this:

[1] [2] K-Detection Mod © 2006

Throws off my them buttons at the end of posts for reply and so on. Worst thing is I cannot even find this code. Not really happy about the idea of a mod trying to place junk like that were it shouldn't be so I uninstalled it. Cool idea but just went a little to far.

Bigguy

Thank you I think this has fixed my error. Much appreciated. :)

Quote from: Badboy on October 09, 2006, 05:19:31 AM
Thx Great Mod. I like it much.

But there is a small problem... :)

8: Undefined index: aol
File: c:\appserv\www\forumrc2\Sources\K_Detection.php
Line: 250


To fix this (it works for me but i am not sure) :-\
Open K_Detection.php and find this

        $bd['version'] = "n";

Add after
        $bd['aol'] = "n";


And u can add this for security
Find this

/*
K-Detection v1.1 by Nikola
www.kupus.org
poslednja izmena: 04.10.2006.
*/


Add after
if (!defined('SMF'))

die('Hacking attempt...');


Thx...

Max22

November 24, 2006, 05:44:06 PM #19 Last Edit: November 24, 2006, 05:48:53 PM by Max22
If I try to edit or remove copyright, when I post a message:

Fatal error: Cannot instantiate non-existent class: browser in /web/htdocs/www.eng2ita.net/home/forum/Sources/Post.php on line 1573

Why?

I've default theme, 1.1 RC3.

Advertisement: