• Welcome to Simple Machines Community Forum. Please login or sign up.
October 20, 2021, 08:30:57 PM

News:

Wondering if this will always be free?  See why free is better.


RSS Feed Poster

Started by SMFHacks.com Team, January 11, 2007, 07:46:04 PM

Previous topic - Next topic

imrie

August 19, 2007, 12:02:08 PM #500 Last Edit: August 19, 2007, 12:14:55 PM by imrie
I get a internal sever error when i press Add feed. It is showing up in the RSS Feed Poster manger tho.

Can you just use the url to any feed you want? or are some feeds copyrighted etc.

imrie

My host wont allow the fsockopen to be open, how can do this with curl or the other method mentioned?

Thanks,

imrie

Now im getting internal sever errors when i try to access my forum after enabling "fake cron jobs"!

What should i do?

imrie

Okay just looking at the ftp right now there are only the following files from the download on the server:

/Packages/rss_poster.zip
/Sources/FeedPoster.php
/cronrss.php

Is this correct?

Please help.

vipmoney


There is a problem with Non English Caracthers... does anybody has a solution yet ?
VipMoney

Buster.de

I see no problem when using utf-8.

imrie

Hey, I fixed the problem i had.

How do i use this mod with CURL?

imrie

August 20, 2007, 02:49:02 PM #507 Last Edit: August 20, 2007, 02:51:09 PM by imrie
Quote from: vbgamer45 on January 14, 2007, 08:26:14 PM
Released an Update.
Fixed only downloading 1 feed item now downloads current number feeds.

Added support for FOpen for feeds as well as cURL - cURL is untested though.

Does this mean i can use it without fsockopen? My host cupports CURL and Fopen but not fsockopen, it would be fantastic if it worked.

imrie

It appears to be working but i have to threds that use this mod, 1 thread is working and the other is not, they both use the same user. I get an internal server error when i try to save the changes made to the feed.

It is set to update every half hour.

vipmoney

Quote from: Buster.de on August 20, 2007, 02:22:30 PM
I see no problem when using utf-8.

Yes, but my forum is «ISO-8859-1», so I get a lot of strange characters.... Is there a php script to convert a string into ISO-8859-1 ?
VipMoney

vipmoney

I found a solution for the problem with characters encoding ;)

(in my case I was using ISO-8859-1)

Go to Subs-RSS.php and find:

// Create the Post
$msg_title = $feed['html'] ? $context['feeditems'][$i]['title'] : strip_tags($context['feeditems'][$i]['title']);

$msg_body =  $feed['html'] ? $context['feeditems'][$i]['description'] . "\n\n" . $context['feeditems'][$i]['link']  : strip_tags($context['feeditems'][$i]['description'] .  "\n\n" . $context['feeditems'][$i]['link']);


Replace with this one or change it according to your enconding needs (this one converts to ISO-8859-1):


// Create the Post
$msg_title_ = $func['htmlspecialchars'](($feed['html'] ? $context['feeditems'][$i]['title'] : strip_tags($context['feeditems'][$i]['title'])), ENT_QUOTES);
$msg_title = iconv("UTF-8", "ISO-8859-1", $msg_title_);  //// NEW added Code

$msg_body_ =  $func['htmlspecialchars'](($feed['html'] ? $context['feeditems'][$i]['description'] . "\n\n" . $context['feeditems'][$i]['link']  : strip_tags($context['feeditems'][$i]['description'] .  "\n\n" . $context['feeditems'][$i]['link'])), ENT_QUOTES);
$msg_body = iconv("UTF-8", "ISO-8859-1", $msg_body_);  //// NEW added Code


Its working now ;)

VipMoney

vipmoney

we need to fix the HTML posts....

for example, if you got a feed from a youtube user videos, the post includes a tumbnail of the video, with this bug the image doenst show up, and a lot of html coding ruins the post.
VipMoney

imrie

Can anyone else get this to do 2 feeds? Mine will only do 1 feed, the other does not work.

imrie

This is not working at all.

It wont do 2 feeds and it has now stopped doing the one feed. How so i correct this?

Forum: mysimtractor.com/forum

Details:

fsockopen: disabled
fopen: enabled
CURL: enabled

ketchup

Hey friends :)

OK

How can I run multiple cron jobs thoughout the day?

I don't want the one http://mysite.com/forum/cronrss.php to pull all feeds at once

I would like to pull news feeds at one time sports feeds at another etc

Thanks

imrie

In the config does the poster name have to be like this:

"Member" or Member

Thanks,

imrie

Just noticed that even if it is in the form "Member" it will change to Member,  This is still not working. In the download there are .xml files but they are not on the server, is this a problem?

imrie

August 22, 2007, 06:37:03 AM #517 Last Edit: August 22, 2007, 07:54:20 AM by imrie
A have loads of these errors in the error log.

8: Undefined offset: 23
File: /home/fhlinux164/m/mysimtractor.com/user/htdocs/forum/Sources/Subs-RSS.php
Line: 130

Every time i edit/create a feed i get this ^.

Line 130:

function startElement2($parser, $name, $attrs)
{   
global $depth; 
$depth[$parser]++;
}


line 130: $depth[$parser]++;


This is driving me mad!

imrie

August 22, 2007, 07:47:42 AM #518 Last Edit: August 22, 2007, 07:53:58 AM by imrie
The above error is actually when i edit/create the feed.

I also get this error:

2: fopen(http://digg.com/rss/index.xml) [<a href='function.fopen'>function.fopen</a>]: failed to open stream: HTTP request failed!
File: /home/fhlinux164/m/mysimtractor.com/user/htdocs/forum/Sources/Subs-RSS.php
Line: 25

imrie


Advertisement: