Advertisement:

Author Topic: View Only Boards  (Read 229168 times)

Offline Bob La Londe

  • Semi-Newbie
  • *
  • Posts: 49
Re: View Only Boards
« Reply #640 on: August 18, 2014, 10:42:05 AM »
Is there a variant, version, or alternative that works with 2.0.8? 

Offline ahrasis

  • SMF Hero
  • ******
  • Posts: 4,921
  • Gender: Male
  • Busy mode is on.
    • ahrasis on GitHub
    • ahrasis on LinkedIn
    • ElkArte Malaysia
Re: View Only Boards
« Reply #641 on: August 18, 2014, 11:15:35 PM »
The view_only_boards_1.2c.zip version of the mod works fine on 2.0.8. Download that one.
I was also helping with this mod last time. But with no authorisation, this mod cannot be upgraded. Ask if you are not sure how to install it properly. Others will definitely help.

Offline ChasT

  • Semi-Newbie
  • *
  • Posts: 10
Re: View Only Boards
« Reply #642 on: December 10, 2015, 01:38:35 AM »
This is a nice mod and works on 2.0.11.
However when guest is refused, they are presented with a 403 notice.
Is there a way to have them directed to must login screen?

Offline ChasT

  • Semi-Newbie
  • *
  • Posts: 10
Re: View Only Boards
« Reply #643 on: December 10, 2015, 04:28:48 PM »
Exploring this mod a little further....

It was originally written for SMF 1.x.x and did everything it was supposed to do as alluded by earlier comments in this subject "View Only Boards". When a guest would try to enter a blocked area they would be redirected to a login register page.

For SMF 2.0.11 it does work as intended. The settings all are functional. The only difference is that the guest gets redirected to a 403 "Sorry, but you have no access to this page." Search engines pick this up, but it would be better if the guest was redirected to the original intent, that is to a login register page.

In the Configuration - General  One may block Guest from complete forum with the resultant effect they are redirected to login register page.

In the change to SMF 2.x.x it appears everything works as intended Except the hook to go to the login register page has changed to a 403 Error page. :(

Anyone Any ideas how to correct this?

Offline Tonyvic

  • Jr. Member
  • **
  • Posts: 155
  • Gender: Male
Re: View Only Boards
« Reply #644 on: August 03, 2016, 02:26:40 PM »
In the hope someone knows the answer here goes:
For a few months now Google and Bing Bots have been producing errors from line 832 of load.php
Code: [Select]
elseif (count(array_intersect($user_info['groups'], $board_info['groups_view'])) == 0 || empty($modSettings['vob_allowMessageIndexView']))
Usually between 40 and 60 errors per day, any help to prevent this will be greatly appreciated.

Offline AllMassive

  • Jr. Member
  • **
  • Posts: 141
  • Gender: Male
Re: View Only Boards
« Reply #645 on: February 02, 2018, 05:48:46 PM »
Installed this Mod ages ago, but then upgrade continuously until 2.0.15 and it mainly still works.
The only error is that it doesnt show the 'new  posts' on the 'latest posts' to guests - or did i accidentally change some acces-flags ?

Offline rubbishnor

  • Semi-Newbie
  • *
  • Posts: 24
  • Gender: Male
Re: View Only Boards
« Reply #646 on: June 04, 2018, 04:53:19 AM »
please help me

smf version 2.0.15

I can not this code 

Code: [Select]
foreach ($context['latest_posts'] as $post)
echo '
<dt>

i find this code

Code: [Select]
foreach ($context['latest_posts'] as $post)
                    {
          echo '
                        <tr>

then can not replace with this

Code: [Select]
foreach ($context['latest_posts'] as $post)
echo '
<dt ' , ($post['board']['protected'] ? 'class="vob_protected"' : '') , '>
« Last Edit: June 04, 2018, 05:25:38 AM by rubbishnor »