Advertisement:

Author Topic: Pretty URLs  (Read 2348437 times)

Offline AllanD

  • Sr. Member
  • ****
  • Posts: 763
  • Gender: Male
  • It's All Good
    • KnD Hosting
Re: Pretty URLs
« Reply #7960 on: June 06, 2020, 08:40:32 PM »
use the paraphraser on the download page and make sure all edits were done
if still after that it's not working use the paraphraser to find the edits and revert them

I was hoping to not have to go through all that lol
Check out this great sites.
KnD Hosting

Offline shadav

  • Support Specialist
  • Sophist Member
  • *
  • Posts: 1,340
  • Gender: Female
    • shadav on Facebook
    • leashadav on GitHub
    • Ask The Muslims: A Place To Ask Honest Questions and Receive Respectful Answers
Re: Pretty URLs
« Reply #7961 on: June 06, 2020, 09:07:42 PM »
 :laugh: I understand your pain

I'd assume that it has to be something with the htaccess file....use the paraphraser and make sure that the edits to it are correct

Offline shadav

  • Support Specialist
  • Sophist Member
  • *
  • Posts: 1,340
  • Gender: Female
    • shadav on Facebook
    • leashadav on GitHub
    • Ask The Muslims: A Place To Ask Honest Questions and Receive Respectful Answers
Re: Pretty URLs
« Reply #7962 on: June 06, 2020, 09:16:06 PM »
not really a fix but this might help for you to disable the mod

https://code.google.com/archive/p/prettyurls/wikis/TroubleShooting.wiki

Quote
If after installing the mod every link is broken, there is probably a problem with your server (it may not support mod_rewrite or per-directory .htaccess configuration files). To fix the links so that the problem can be diagnosed and fixed, or so you can uninstall the mod, create a new .php file with this code:

<?php require_once(dirname(__FILE__) . '/SSI.php'); updateSettings(array('pretty_enable_filters' => '0')); ?>

Upload the file to the same location as your forum's SSI.php and open it with your web browser. Then don't forget to delete it!

Offline AllanD

  • Sr. Member
  • ****
  • Posts: 763
  • Gender: Male
  • It's All Good
    • KnD Hosting
Re: Pretty URLs
« Reply #7963 on: June 06, 2020, 09:30:57 PM »
going to have to go that route since all the files were right. Thank you for the help.
Check out this great sites.
KnD Hosting

Offline AllanD

  • Sr. Member
  • ****
  • Posts: 763
  • Gender: Male
  • It's All Good
    • KnD Hosting
Re: Pretty URLs
« Reply #7964 on: June 06, 2020, 09:57:51 PM »
That got it work so I could uninstall the mod again thank you. Also for anyone that wants to know this was causing the error.


8:  Undefined index:  pretty_bufferusecache

Code: [Select]
<input type="checkbox" name="pretty_bufferusecache" id="pretty_bufferusecache"', ($modSettings['pretty_bufferusecache'] ? ' checked="checked"' : ''), ' />

Themes/default/PrettyUrls.template.php(line 92)



Check out this great sites.
KnD Hosting

Online vbgamer45

  • Customizer
  • SMF Super Hero
  • *
  • Posts: 23,501
    • smfhacks on Facebook
    • VBGAMER45 on GitHub
    • @createaforum on Twitter
    • SMF For Free
Re: Pretty URLs
« Reply #7965 on: June 06, 2020, 10:55:08 PM »
No idea haven't been able to solve it.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Offline shadav

  • Support Specialist
  • Sophist Member
  • *
  • Posts: 1,340
  • Gender: Female
    • shadav on Facebook
    • leashadav on GitHub
    • Ask The Muslims: A Place To Ask Honest Questions and Receive Respectful Answers
Re: Pretty URLs
« Reply #7966 on: June 07, 2020, 01:28:00 AM »
ok starting up a new project and installed this and ran into a strange error
I could not use the menu (either frontend or admin)
front end the dropdown menu wouldn't work at all, admin the dropdown menu would dropdown but none of the "links" were clickable....

with the newest pretty url's installed (2.3)
on a 2.0.17
with these others installed
Sorted Package Manager Listing
Anti-Spam Links
Optimus
Unknown Actions
Sisyphus
Custom BBCodes Manager

using theme Greeny

it seems to only be this theme that is having this issue, I check other themes installed and they all work
any suggestions?
I'm still having this issue....
Diego installed the theme and the mod on his site and didn't reproduce the error....
http://shadav.com/forum/
I can pm you a test account log in if you can take a look and maybe figure out what's causing the issue? (you have to be logged in to use the members link and stuff)

Offline shadav

  • Support Specialist
  • Sophist Member
  • *
  • Posts: 1,340
  • Gender: Female
    • shadav on Facebook
    • leashadav on GitHub
    • Ask The Muslims: A Place To Ask Honest Questions and Receive Respectful Answers
Re: Pretty URLs
« Reply #7967 on: June 07, 2020, 03:49:33 AM »
I finally figured it out....it's the scrolling-nav.js in the greeny theme

for future reference if someone else uses that theme

fixed it by removing all of the instances of #forum from themes/greeny/index.template.php
and then in themes/greeny/scripts/scrolling-nav.js

find
Code: [Select]
    $("#forum a").not(".dd-selected, .dd-option, .bbc_link").each(function(i){
        var titulo = $(this).attr("href");
            if (this.href.indexOf("#") != -1 || this.href.indexOf("javascript") != -1)
            {
                 $(this).attr("href", titulo);   
            }
             else
            {
               $(this).attr("href", titulo + "#forum");
replace
Code: [Select]
    $("a").not(".dd-selected, .dd-option, .bbc_link").each(function(i){
        var titulo = $(this).attr("href");
            if (this.href.indexOf("#") != -1 || this.href.indexOf("javascript") != -1)
            {
                 $(this).attr("href", titulo);   
            }
             else
            {
               $(this).attr("href", titulo);

now it seems to be working

Offline digger

  • Sr. Member
  • ****
  • Posts: 786
  • Gender: Male
    • realdigger on GitHub
    • SMF Russian Community
Re: Pretty URLs
« Reply #7968 on: June 09, 2020, 08:55:46 AM »
Hi.
I have error when try to install ot remove any mod.
"admin" is added to ignore actions list.

PHP Fatal error:  Allowed memory size of 134217728 bytes exhausted (tried to allocate 23068736 bytes) in /.../Sources/PrettyUrls-Filters.php on line 304

$replacement .= (strpos($replacement'?') === false '?' ';') . (isset($PHPSESSID[0]) ? $PHPSESSID[0] : '') . ';' . (isset($sesc[0]) ? $sesc[0] : '') . (isset($session_var[0]) ? $session_var[0] : '') . (isset($fragment[0]) ? $fragment[0] : '');



Online vbgamer45

  • Customizer
  • SMF Super Hero
  • *
  • Posts: 23,501
    • smfhacks on Facebook
    • VBGAMER45 on GitHub
    • @createaforum on Twitter
    • SMF For Free
Re: Pretty URLs
« Reply #7969 on: June 09, 2020, 09:08:03 AM »
What SMF version?
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Offline digger

  • Sr. Member
  • ****
  • Posts: 786
  • Gender: Male
    • realdigger on GitHub
    • SMF Russian Community
Re: Pretty URLs
« Reply #7970 on: June 09, 2020, 09:09:06 AM »

Offline Yariksat

  • Semi-Newbie
  • *
  • Posts: 50
Re: Pretty URLs
« Reply #7971 on: June 18, 2020, 01:27:09 PM »
What SMF version?
The same error when trying to clear the cache
Will there be a correction?
2.0.17

Online vbgamer45

  • Customizer
  • SMF Super Hero
  • *
  • Posts: 23,501
    • smfhacks on Facebook
    • VBGAMER45 on GitHub
    • @createaforum on Twitter
    • SMF For Free
Re: Pretty URLs
« Reply #7972 on: June 18, 2020, 01:46:01 PM »
What filters do you have enabled?
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Offline Yariksat

  • Semi-Newbie
  • *
  • Posts: 50
Re: Pretty URLs
« Reply #7973 on: June 18, 2020, 02:21:22 PM »
What filters do you have enabled?
All
Understood with caching, this is not this mod
But with the removal of mods the exact same error
And with the installation. I disable the mod to add or remove mods

Offline RGMears

  • Semi-Newbie
  • *
  • Posts: 51
    • studio five
Re: Pretty URLs
« Reply #7974 on: June 25, 2020, 11:26:06 AM »
I am working on a new forum. I have many mods installed. Among them is Pretty URLs. I cannot access the template for that mod. And, today, I tried changing the "Pretty URLs" name under boards. Now I cannot access the page at all. The url in the browser does not reference the page. And there is no entry for either the new or the old name in the database.

Offline drewactual

  • Sr. Member
  • ****
  • Posts: 917
    • College Football Fan Site CFB51
Re: Pretty URLs
« Reply #7975 on: June 25, 2020, 11:34:59 AM »
how did you go about "Changing the PrettyURL's name under boards"?  can you expound upon that and exactly what you were seeking to accomplish?  I'm certainly willing to assist, but I don't know what was going on here...

Offline RGMears

  • Semi-Newbie
  • *
  • Posts: 51
    • studio five
Re: Pretty URLs
« Reply #7976 on: June 25, 2020, 05:01:15 PM »
@drewactual
Thanks for the reply.
I was on this page: Admin > Manage Boards. Pretty URLs is an option ... pretty_urls-1.png
I tapped on it and was taken to the page shown in ... pretty_urls-2.png
I thought I could change the name, which is what I wanted to do. That is shorten "flora-~-rushes-sedges" to just "rushes-sedges".
Tapping on the coloured box (without text) adds the second title. However, the board itself (on the forum) disappears regardless whether or not I delete the first label. And when checking the database (after deleting the first label) I found the pretty_url_boards table for that item is gone. I then created a whole new board but it didn't take; IE: does not show in PrettyURLs in the database. In both instances, the text from the url is shortened to a number, 2 for the first change, 68 for the new board.

Offline RGMears

  • Semi-Newbie
  • *
  • Posts: 51
    • studio five
Re: Pretty URLs
« Reply #7977 on: June 25, 2020, 05:15:53 PM »
I should add that when I tap on the Pretty URLs link in the Admin menu I get: "Unable to load the 'PrettyUrls' template."

Offline shadav

  • Support Specialist
  • Sophist Member
  • *
  • Posts: 1,340
  • Gender: Female
    • shadav on Facebook
    • leashadav on GitHub
    • Ask The Muslims: A Place To Ask Honest Questions and Receive Respectful Answers
Re: Pretty URLs
« Reply #7978 on: June 25, 2020, 07:51:50 PM »
I'm not sure if you can use the & in the url
also after adding the new pretty url, did you set it as primary?

you may also have to then go to pretty urls in admin and Run maintenance tasks

as for the Unable to load the 'PrettyUrls error....sounds like it didn't fully install, use the parse and make sure that all edits were done correctly and all files were uploaded to the proper places

Offline drewactual

  • Sr. Member
  • ****
  • Posts: 917
    • College Football Fan Site CFB51
Re: Pretty URLs
« Reply #7979 on: June 25, 2020, 09:40:19 PM »
first and perhaps most important, dump your cache.