• Welcome to Simple Machines Community Forum. Please login or sign up.
September 28, 2021, 04:47:19 PM

News:

Bored?  Looking to kill some time?  Want to chat with other SMF users?  Join us in IRC chat or Discord


Unable to load the main template

Started by sektor, February 08, 2007, 08:06:45 AM

Previous topic - Next topic

sektor

February 08, 2007, 08:06:45 AM Last Edit: February 08, 2007, 09:50:22 PM by Orstio
I have a custom template on my website.

I am not sure when this started, but if i try to make changes to the configuration (via the bridged forum) i get:

"Unable to load the main template".

This does NOT occur when i make changes directly from SMF (using the same custom theme, or any other theme).

I searched the forum for this error and applied whatever fix was suggested.

ottoman1990

You might change the default template name. Control that if the name is the same the template you use.
smf öğreniyor | learning smf
link: www.cbaalmekan.com
link: www.pansiyon17.com

sektor

My custom template and the default template have a different name

ottoman1990

smf öğreniyor | learning smf
link: www.cbaalmekan.com
link: www.pansiyon17.com

sektor

oh :)

I just renamed the default theme with the same name as my custom theme, but nothing changed, i am still getting the error.


ottoman1990

Can you give me the link?
And did you fix Theme url, Theme images url?
smf öğreniyor | learning smf
link: www.cbaalmekan.com
link: www.pansiyon17.com

sektor

i doubt it that this is an SMF or a template issue.

I just switched to the default 1.1.1 theme via the bridged from, and i am still getting the error.
But if i access the forum directly, i have no problem even with my custom template.

I think this started since i upgraded to Bridge 1.1.7, but i am not sure...

Orstio will save the day

Kindred

ottoman,  please don't help like that... you are wrong, and renaming the DEFAULT template to match an existing template can mess things up...

every theme should have a different name.

Al0000, please give us a URL to look at this.
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

ottoman1990

Quote from: Kindred on February 08, 2007, 08:36:55 AM
ottoman,  please don't help like that... you are wrong, and renaming the DEFAULT template to match an existing template can mess things up...

every theme should have a different name.

Al0000, please give us a URL to look at this.

No I mean that:
The default theme name and the theme folder name al0000 uses must be the same. This is the solving.
smf öğreniyor | learning smf
link: www.cbaalmekan.com
link: www.pansiyon17.com

Kindred

February 08, 2007, 08:42:53 AM #9 Last Edit: February 08, 2007, 08:44:30 AM by Kindred
***NO***

You should NEVER rename the default theme folder!  You should **NEVER** rename the default theme folder to be the name of your custom theme!!!

Ottoman,
this appears to be somehow related to his bridging. Please do not throw random answers out, especially since he has already disproven your point by indicating the his site works fine when directly accessed and onyl bumps when accessed through the bridge.
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

sektor


ottoman1990

I am realy sorry. I have written DEFAULT THEME but I want to mean CUSTOM THEME. (I can not explain my thougts. Sorry...)
smf öğreniyor | learning smf
link: www.cbaalmekan.com
link: www.pansiyon17.com

sektor

I temporarily closed my website since things got messed up.

How do i fix this now? :)
Where are the theme's settings located?

sektor

All the administration links have disappeared, that's why i need to know where each theme's settings are located.

Settings.template.php does not include theme name or location/URL

thanx

ottoman1990

smf öğreniyor | learning smf
link: www.cbaalmekan.com
link: www.pansiyon17.com

sektor

I have fixed my templates.

Kindred, i have included my URL to a PM. I cannot give out the URL to the public.
Thanx

Kindred

February 08, 2007, 09:21:40 AM #16 Last Edit: February 08, 2007, 09:23:24 AM by Kindred
understood.

You have fixed your template...   do you still have a problem?   If so, you can discuss any specific remaining issues with me in PM...

BTW: I notice that your sticky icon is missing in the theme you have selected....
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

sektor

Unfortunately i didn't catch Kindred online.
If anyone else is willing to help me, please say so.

There are currently three issues that i can't resolve:

1. I get "Unable to load the main template" when i try to make a change in the configuration
2. Polls are not seen for some reason. You CAN open a open, the post will be seen, but it will not include a poll.
3. Moderator reports do not include the user's message

Orstio

Quote1. I get "Unable to load the main template" when i try to make a change in the configuration

Can you copy the URL from this error, and paste it here?  (Edit out the actual URL if you wish, I just need to see the query string).

sektor

Sure,

That is:

component/option,com_smf/Itemid,168/action,featuresettings2/save/sa,basic

Advertisement: