Advertisement:

Author Topic: Probleme mit dem Paket-Manager...  (Read 193658 times)

Offline Daniel D.

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 4,426
  • Gender: Male
Probleme mit dem Paket-Manager...
« on: February 18, 2007, 12:08:13 PM »
Sollte das Installieren mit dem Paket-Manager nicht funkionieren, probiert bitte folgendes aus:

Erstellt im Ordner "Packages" zwei neue Ordner mit den Namen "tmp" und "temp". Als Attribute (CHMOD) müssen beide 666 haben. Ihr solltet unabhängig davon natürlich auch prüfen, ob die Dateien bzw. Ordner der zu überschreibenden Dateien ebenfalls das Attribut 777 haben (oder 755, 666 versuchen), da sonst keine Datei verändert werden kann!
« Last Edit: February 20, 2007, 10:51:15 AM by Daniel D. »

Offline Jorin

  • SMF Hero
  • ******
  • Posts: 2,021
  • Gender: Male
    • ElkArte-Hilfe.de
Re: Probleme mit dem Paket-Manager...
« Reply #1 on: February 19, 2007, 07:28:38 AM »
Ich dachte, tmp reicht? Braucht es zwingend auch temp?

Offline Daniel D.

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 4,426
  • Gender: Male
Re: Probleme mit dem Paket-Manager...
« Reply #2 on: February 19, 2007, 10:44:43 AM »
Bei mir hat es geholfen.

Offline ディン1031

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 4,599
  • Gender: Male
  • はるひ! :P
    • ~DIN1031
Re: Probleme mit dem Paket-Manager...
« Reply #3 on: February 20, 2007, 05:09:54 AM »
Ich dachte, tmp reicht? Braucht es zwingend auch temp?
ja ;) dies legt smf kurzzeitig an um daten zu entpacken *g*. Und wenn man dem verzeichniss 666 gibt fuktionieren die meisten package installation da er dann schreib/lese recht im verzeichniss hat :). (777, hat zur folge das man das nach jeder installation neu machen muß XD, weil er es anschliesen immer löscht glaub bei 666 darf er nur die geschrieben dateien vom verzeichniss löschen, aber temp bleibt erhalten).

Gruß
DIN1031
« Last Edit: February 20, 2007, 05:25:52 AM by DIN1031 »
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

Offline Daniel D.

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 4,426
  • Gender: Male
Re: Probleme mit dem Paket-Manager...
« Reply #4 on: February 20, 2007, 10:50:42 AM »
Oh, das mit 666 hatte ich falsch geschrieben... :-[

Offline Jorin

  • SMF Hero
  • ******
  • Posts: 2,021
  • Gender: Male
    • ElkArte-Hilfe.de
Re: Probleme mit dem Paket-Manager...
« Reply #5 on: February 21, 2007, 08:28:56 AM »
Danke, da muss ich auch mal unsere FAQ überarbeiten...

Offline Ferrika

  • Jr. Member
  • **
  • Posts: 375
  • Gender: Female
    • witch's hexenküche
Re: Probleme mit dem Paket-Manager...
« Reply #6 on: March 01, 2007, 06:06:12 AM »
Problem mit dem Paket-Manager kann aber auch auftreten, wenn der Provider den save-mode auf on gesetzt hat, wie das bei mir der fall ist. ich kann auf meinem webspace keine einzige modifikation ausführen... (wobei mir der safe-mode so trotzdem lieber ist... führ ich halt modifikationen auf dem lokalhost aus und kopiers rüber *g*)

gruß Ferrika
was ich nicht will, das man mir tu, das füg ich keinem andren zu

Offline Daniel D.

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 4,426
  • Gender: Male
Re: Probleme mit dem Paket-Manager...
« Reply #7 on: March 01, 2007, 10:15:46 AM »
Das ist nichts neues. Es ging auch nur um einen Versuch mehr den man hat, bevor man gleich aufgibt.

Offline Ferrika

  • Jr. Member
  • **
  • Posts: 375
  • Gender: Female
    • witch's hexenküche
Re: Probleme mit dem Paket-Manager...
« Reply #8 on: March 01, 2007, 03:42:59 PM »
dass das für euch nix neues ist, war schon klar. aber da die beiträge hier ja mehr für die user geschrieben werden, die etwas hilfloser sind, wär das für diese vielleicht mal interessant zu wissen. dacht ich so ;-)

gruß Ferrika
was ich nicht will, das man mir tu, das füg ich keinem andren zu

Offline AnTiMASKe

  • Semi-Newbie
  • *
  • Posts: 43
    • Teknotek Group Webmaster Hizmetleri
Re: Probleme mit dem Paket-Manager...
« Reply #9 on: March 13, 2007, 01:13:33 PM »
ja ja

Offline ディン1031

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 4,599
  • Gender: Male
  • はるひ! :P
    • ~DIN1031
Re: Probleme mit dem Paket-Manager...
« Reply #10 on: March 22, 2007, 06:59:56 AM »
Alternativ bietet sich jetzt auch an diesen Mod zu instllieren.

http://custom.simplemachines.org/mods/index.php?mod=724

Mit diesen wird das temp verzeichniss nicht mehr gelöscht, wichtig dabei ist jedoch das dann ein temp verzeichniss erstellt wird mit den rechten 777 damit mods installierbar werden aber denoch das Verzeichniss geleert werden kann.

Gruß
DIN1031
Support only via MOD Thread! NO PM Support!
My Forum: ayu][kult Forum
My Mods: My Small Mod Collection
My Parser: DIN1031's ModParser
Current Info: More away the next days, because i've to much work to do :x

Offline frizz

  • Semi-Newbie
  • *
  • Posts: 18
Re: Probleme mit dem Paket-Manager...
« Reply #11 on: April 01, 2007, 07:03:27 AM »
das problem is des , ich komm ned mal dazu ein mod zu installen
hab bereits beide ordner dazu gefügt
temp und tmp
hab alle ordner und dateien im board verzeichnis auf 777 gestellt
dann wenn ich auf mod anwenden klicke kommt eine rote fehlermeldung
woran liegt das?!?
bitte um hilfe

mfg frizz

Offline frizz

  • Semi-Newbie
  • *
  • Posts: 18
Re: Probleme mit dem Paket-Manager...
« Reply #12 on: April 05, 2007, 03:22:34 AM »
jedes mal wenn ich bestimmte mods installen will(sind laut angaben mit meiner board version 1.1.2 kompatibel) kommt erst die rote fehlermeldung und wenn ich dann auf installieren klicke kommt das hier

Fatal error: packageinstall(): Failed opening required '/home/www/*****/html/board/Packages/temp/./reasonforeditinginstall.php' (include_path='.') in /home/www/*****/html/board/Sources/Packages.php on line 552

was is da falsch!?!?
bitte um hilfe

mfg ilovevalla

Offline Jorin

  • SMF Hero
  • ******
  • Posts: 2,021
  • Gender: Male
    • ElkArte-Hilfe.de
Re: Probleme mit dem Paket-Manager...
« Reply #13 on: April 05, 2007, 04:20:09 AM »
Schau mittels php-info mal bitte nach, ob bei dir der Safemode aktiv ist. Das würde dieses Verhalten erklären.

Offline frizz

  • Semi-Newbie
  • *
  • Posts: 18
Re: Probleme mit dem Paket-Manager...
« Reply #14 on: April 05, 2007, 06:11:37 AM »
ja safe mode ist aktiv wie mach ich die aus!ß!?

mfg

Offline Jorin

  • SMF Hero
  • ******
  • Posts: 2,021
  • Gender: Male
    • ElkArte-Hilfe.de
Re: Probleme mit dem Paket-Manager...
« Reply #15 on: April 05, 2007, 06:14:51 AM »
Das kann nur dein Hoster. Frag mal bei dem nach. Mit aktiviertem Safemode kannst du den Paketmanager nicht nutzen, auch nicht für Updates des SMF.

Offline frizz

  • Semi-Newbie
  • *
  • Posts: 18
Re: Probleme mit dem Paket-Manager...
« Reply #16 on: April 05, 2007, 06:24:28 AM »
okay vielen dank für die hilfe

welche nachteile hat das abschalten von safe mode!?!?
bitte um kurze genaue stichpunktartige infos

mfg frizz

Offline Jorin

  • SMF Hero
  • ******
  • Posts: 2,021
  • Gender: Male
    • ElkArte-Hilfe.de
Re: Probleme mit dem Paket-Manager...
« Reply #17 on: April 05, 2007, 06:34:02 AM »

Offline sgvg

  • Newbie
  • *
  • Posts: 7
    • http://www.cyberserv.de/nboard/index.php
Re: Probleme mit dem Paket-Manager...
« Reply #18 on: April 18, 2007, 10:05:12 AM »
Hi, eine Frage zu den Zugriffsrechten. Bei welchen Ordnern bzw. Dateien muss ich die Zugriffsrechte ändern um die aktuellen Pakete einspielen zu können? Wenn ich die Pakete einspiele, bleiben dann meine einstellungen und die einstellungen am Theme erhalten?

Wenn ich den Paket-Manager starte kommt diese Meldung:
Es wurde mindestens ein Fehler beim Test der Installation des Paketes gefunden. Es wird dringend empfohlen, nicht mit der Installation fortzufahren, wenn Sie sich nicht ausreichend auskennen oder keine aktuelle Sicherung gemacht haben. Diese Fehlermeldung kann auf einen Konflikt zwischen dem zu installierenden und einem existierenden Paket hinweisen, auf einen Fehler im Paket selbst oder auf eine Inkompatibilität zwischen dem Paket und der SMF Version.

Bei den Paketen smf_1-1-2.mod und smf_1-1-2_can_fail.xml steht Parse-Error.

Danke!
« Last Edit: April 18, 2007, 10:22:22 AM by sgvg »

Offline flori76

  • Newbie
  • *
  • Posts: 4
Re: Probleme mit dem Paket-Manager...
« Reply #19 on: April 28, 2007, 08:06:48 AM »
Ich hab auch ein Problem mit dem Paketmanager. Ich kann zwar das Paket hochspielen und im Manager auswählen, aber nach der Auflistung des Inhaltes sowie der Information, wie die Installation ausgeführt wird, wenn ich auf den Knopf "jetzt installieren" klicke, passiert nix... gar nix...
Save-mod ist aus, das hab ich überprüft, die Verzeichnisse sind mit chmod 777 versehn.