• Welcome to Simple Machines Community Forum. Please login or sign up.

Allowing guests to see all Boards but not entering

Started by trenchteam, September 05, 2004, 11:19:01 PM

Previous topic - Next topic

babjusi

Quote from: teamvtec on January 26, 2007, 06:59:08 PM
Quote from: babjusi on January 26, 2007, 06:30:04 PM
What I meant is, that isn''t that risky to use a mod which isn''t approved yet?

Why should it be? it's just code... not a trojan horse or something.
And if you have troubles after installing the mod (which i doubt) then ask Rudolf.
I really don't see the problem here.


I am very sure that it ain''t anything like that, I was only wondering if it was safe to use a mod if it ain''t approved yet. Personally, I will wait till it gets approved, which I wish it could be very soon, cause I find it a very great and handy mod

Krysia

The mod still hasn't been approved?  ::)

It sounds like the perfect solution. Reading through this topic has made me dizzy, and I'm so glad someone with know-how figured out a mod for creating "incentive boards". ;)

Thank you!



undysided

February 03, 2007, 12:46:22 PM #242 Last Edit: February 03, 2007, 03:36:34 PM by undysided
Hi All

When I try to install the 'View_Only_Boards_1.0' mod on version 1.1.1 I get the following errors. I used the package manager

Quote
Installing this package will perform the following actions:  Type Action Description
1. Execute Code DB.php 
2. Execute Modification sources.xml Modification parse error
3. Execute Modification - Modification parse error
4. Execute Modification themes.xml Modification parse error
5. Execute Modification - Modification parse error

How can I fix? All help appreciated

babjusi

Quote from: Krysia on January 29, 2007, 04:54:46 PM
The mod still hasn't been approved?  ::)

It sounds like the perfect solution. Reading through this topic has made me dizzy, and I'm so glad someone with know-how figured out a mod for creating "incentive boards". ;)

Thank you!

This mod got approved some days ago now

undysided

February 05, 2007, 08:48:06 AM #244 Last Edit: February 05, 2007, 08:51:32 AM by undysided
Quote from: undysided on February 03, 2007, 12:46:22 PM
Hi All

When I try to install the 'View_Only_Boards_1.0' mod on SMF 1.1.1 I get the following errors. I used the package manager to upload

Quote
Installing this package will perform the following actions:  Type Action Description
1. Execute Code DB.php 
2. Execute Modification sources.xml Modification parse error
3. Execute Modification - Modification parse error
4. Execute Modification themes.xml Modification parse error
5. Execute Modification - Modification parse error

How can I fix? All help appreciated

Is there anyone able to help me with the above problem(s)?

Thanks

redone

Make sure the following files are chmodded to 777 or 755 depending on what your host allows:

/Sources/BoardIndex.php   
/Sources/ManageBoards.php   
/Sources/Subs-Boards.php   
Sources/Load.php   
/Sources/ModSettings.php   
/Themes/default/ManageBoards.template.php   
/Themes/default/languages/ManageBoards.english.php
/Themes/default/languages/ModSettings.english.php

I was able to install it without any issues. It could be related to how your web host has the server configured. Can you install other packages without a problem?

Failing that you are left with installing the mod manually I am afraid.


undysided

February 05, 2007, 11:11:35 AM #246 Last Edit: February 05, 2007, 11:13:36 AM by undysided
Quote from: redone on February 05, 2007, 09:14:50 AM
Make sure the following files are chmodded to 777 or 755 depending on what your host allows:

/Sources/BoardIndex.php   
/Sources/ManageBoards.php   
/Sources/Subs-Boards.php   
Sources/Load.php   
/Sources/ModSettings.php   
/Themes/default/ManageBoards.template.php   
/Themes/default/languages/ManageBoards.english.php
/Themes/default/languages/ModSettings.english.php

I was able to install it without any issues. It could be related to how your web host has the server configured. Can you install other packages without a problem?

Failing that you are left with installing the mod manually I am afraid.

Thanks for your reply, I've checked permissions & they are fine. It seems I'm not able upload any kind of mod through package manager so it's probly to do with my host.

Is there anywhere that tells me how to install the View_Only_Boards_1.0 mod manually? I checked the files of the mod to see if there were instructions on how to install manually but couldn't find any

Thanks for your help

Saku

Quote from: Oldiesmann on January 18, 2007, 04:50:37 PM
You didn't finish the conditional statement...

$request = db_query("
SELECT
m.posterTime, ms.subject, m.ID_TOPIC, m.ID_MEMBER, m.ID_MSG, b.ID_BOARD, b.name AS bName,
IFNULL(mem.realName, m.posterName) AS posterName, " . ($user_info['is_guest'] ? '1 AS isRead, 0 AS new_from' : '
IFNULL(lt.ID_MSG, IFNULL(lmr.ID_MSG, 0)) >= m.ID_MSG_MODIFIED AS isRead,
IFNULL(lt.ID_MSG, IFNULL(lmr.ID_MSG, -1)) + 1 AS new_from') . ", LEFT(m.body, 384) AS body, m.smileysEnabled, m.icon
FROM ({$db_prefix}messages AS m, {$db_prefix}topics AS t, {$db_prefix}boards AS b, {$db_prefix}messages AS ms)
LEFT JOIN {$db_prefix}members AS mem ON (mem.ID_MEMBER = m.ID_MEMBER)" . (!$user_info['is_guest'] ? "
LEFT JOIN {$db_prefix}log_topics AS lt ON (lt.ID_TOPIC = t.ID_TOPIC AND lt.ID_MEMBER = $ID_MEMBER)
LEFT JOIN {$db_prefix}log_mark_read AS lmr ON (lmr.ID_BOARD = b.ID_BOARD AND lmr.ID_MEMBER = $ID_MEMBER)" : '') . "
WHERE t.ID_LAST_MSG >= " . ($modSettings['maxMsgID'] - 500 * min($num_recent, 5)) . "
AND t.ID_LAST_MSG = m.ID_MSG
AND b.ID_BOARD = t.ID_BOARD" . (empty($exclude_boards) ? '' : "
AND b.ID_BOARD NOT IN (" . implode(', ', $exclude_boards) . ")") . "
AND $user_info[query_see_board]" . !empty($modSettings['cbv_allowMessageIndexView']) ? "
AND ms.ID_MSG = t.ID_FIRST_MSG" : '' . "
ORDER BY t.ID_LAST_MSG DESC
LIMIT $num_recent", __FILE__, __LINE__);


Didn't work :(

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND ms.ID_MSG = t.ID_FIRST_MSG' at line 1
Fichier: /public_html/smf/SSI.php
Line: 364

vconcept

I'm using the SSI function "SSI_RecentTopics" to display some infos (SMF forum new topics titles) on my homepage. Since I've applied the MOD nobody (also the admins) can show theses infos. To be more precise about how I've configured the MOD, I make it to allow all people to show into the forum the info until the title of the thread. When the user, who is not logged, try to click on a thread to see the content, the system then asks it to logon or to register.


Because I really want that the guests can see at least the topic title into the forum, how can I do to also allow the "SSI RecentTopics" to work again?


Thanks for your help!


jeff1osu

Hi All,

I am completely new to SMF so forgive my ignorance.  I have a group of users I would like to put in an Unauthorized group and then allow them only to see the forum topics but not read the threads, post, etc.  I may at a later time pull them out one by one and give them access again.  Any ideas?  Any help would be greatly appreciated.

Thanks,
jeff1osu

daragor

Webscom: Wordpress + SMF
Software Libre, Noticias y Entretenimiento.-

Widmo

Quote from: Rudolf on January 04, 2007, 05:39:49 PM
I renamed the mod and it's ready for use.
View Only Boards 1.0
Link to Mod
hxxp:digilander.libero.it/rudoka/smfmods/voboards/View_Only_Boards_1.0.zip [nonactive]

If you have any question post it in the mod's support topic (you will find once it is approved).

Sorry but this is ******, because i make search topic and enter to him, so i dont must be logged

Sorry for my english
Sorry for my english

mrandall131

I'm still using the original "trick" and I have no problems with it at all.  And, just upgraded to the latest version of SMF.

Yellowrose

Ok I've gone through this topic and just can't understand a lot of it. It seems to jump form one type of access and permission to another.

My problem is I run a game fansite. I have enabled access to the boards I want guests to be able view and read and then set permissions so guests can not post. All seems fine but when you acess the board as a guest you ge the message that the board administrator has required you to re4gister  or something like that.

I love SMF and use it on 2 sites

Is there not something that can be done for a view permission to be added to make this easier to do.

most other forum software has this option where you can set a read only option for certain boards and certain membergroups

An example of what I would like to do is this (x = permissions allowed)
                                     guest        guest          guest
board name                    access       read all        post   

general rules                      x             x                  0           
general discussion               x             x                  0         
downloads discussion           x             x                  0         
game info                          x             x                  0


I guess what I am asking for is a read only option for guests based on the board access permission.

I can give them access to read the board and all posts pertaining to say new download releases so they can see what files we have to offer but they can't post

They can see the tech support forum and read everything but can't post

But they can't see anything where the guest access is unchecked

As it stands now I have allowed access to guests for certain boards and childboards in the access and then gone into the usergroups and added permissions for the boards statistics and the gallery and the Search for posts and topics but when I check by trying to log in as a guest I get this message

Warning

Only registered members are allowed to access this section please login below or register an accout with site name

I want guests to be able to have the accesses I have allowed.

This has only come about since the upgrade to 1.1.2 and the addition of TP 9.8 prior to a recent server move and software upgrades my guests were allowed to view the forums where access was given but not post as per usergroup permissions

I have the following mods installed on a fresh install of SMF 1.1.2

Mod Name                         Version 
1. Reason For Editing Mod      1.14   
2. vWarn Mod                      1.10   
3. Custom Profile Field Mod     3.16     
4. Admin Notepad                 1.0   
5. Save PM as HTML             1.0.2     
6. Country Flags                   1.0.1   
7. TinyPortal                        0.983               
8. PhpInfo                           1.1     
9. SMF                               1.1.2 Update Package 1.1.2 
10. Display Age and Location next to posts    1.0     
11. vReportBoard Mod           0.97     
12. LogModAccountEdits        1.8     
13. Users Online Today Mod   1.4.0     
14. SMF Gallery Lite              1.7.1   
15. Who Voted What?           1.1.2   
16. Gender On Registration     1.0     
17. Move Old Topics              1.2   
18. SmileyLimit                     1.0 
19. nwsw.nwswAdminAttachAnything 1.1 RC3   
20. LimitPostsPerDay             1.1_BETA   
21. Signature Permission         1.0   



         

jellybelly

Quote from: forgyx on December 02, 2004, 12:33:23 PM
Wow! I find a solution!
I don't believe in myself!!!

well, in boardindex.php i changed:
WHERE $user_info[query_see_board]
AND b.ID_CAT = c.ID_CAT
AND b.childLevel <= 1
ORDER BY c.catOrder, b.childLevel, b.boardOrder", __FILE__, __LINE__);



with:
WHERE&nbsp; b.ID_CAT = c.ID_CAT
AND b.childLevel <= 1
ORDER BY c.catOrder, b.childLevel, b.boardOrder", __FILE__, __LINE__);


it's work, now all forum are visible (only eheh ;D)

thank's Oldiesmann for lost time with me....


Thanks for your solution i was looking for this option now when my guests try to enter a forum they are not allowed they get this message

(The topic or board you are looking for appears to be either missing or off limits to you.)

Klozi

Well that's pretty cool, but I need a solution that guests can't access any board but there are two or three boards accessable for guest. I need this for news boards wich SSI.

edchapman

Sorry I know this topic is getting old...
count this as a update I guess.
I'm running 1.1.4 and tried it. It did nothing for me.
I would like guests and google spiders to see what's on the forum but not enter into the topic.

perava1234

I replace this code in boardIndex:
WHERE $user_info[query_see_board]

with

WHERE ($user_info[query_see_board]" . ($user_info['is_guest'] ? " OR hxxp:b.id [nonactive]_BOARD IN (##, ##, ##)" : '') . ")

but when i run my web, I have next mistake:

Database Error
Please try again. If you come back to this error screen, report the error to an administrator

when I register, everething ok, but guest have mistake when come on my web
How I decide this problem.

codenaught

That code worked for me peraval1234. Perhaps you can show a little more of the code to see where it could have gone wrong, mine has:

WHERE ($user_info[query_see_board]" . ($user_info['is_guest'] ? " OR b.ID_BOARD IN (1, 2, 3)" : '') . ")" . (empty($modSettings['countChildPosts']) ? "
AND b.childLevel <= 1" : ''), __FILE__, __LINE__);
Dev Consultant
Former SMF Doc Coordinator

Advertisement: