• Welcome to Simple Machines Community Forum. Please login or sign up.
January 25, 2022, 05:44:37 PM

News:

Want to get involved in developing SMF, then why not lend a hand on our github!


Welcome Topic

Started by SMFHacks.com Team, May 07, 2007, 09:42:29 PM

Previous topic - Next topic

vbgamer45

Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Sean Dempsey

I am having difficulty getting this mod to work. It's a new forum just getting off the ground. I am new to SMF so I have been doing things really slowly and carefully.

I'm running 2.0.10 hosted on Netfirms.

Other Packages installed:
Default Avatar    2.3
FantasticSmileys 1.0
Karma Buttons 1.1
Simple Audio Video Embedder    3.2
RSS Feed Poster 4.1

I installed it once and it appeared to work ok but there was no option to change setting after the initial set during install. I uninstalled it and tried to reinstall it. This is where it all went wrong.
I got an error message which I traced to a difference in the number of spaces one of the lines searched for was tabbed in. I edited my file to match and the install seemed to run ok but no topics were created. This time I used the parser and manually edited everything back to normal and deleted any uploaded files one at a time.

I then changed my registration setting from email activated to immediate.

Reinstalled without success.

Again used the parser details to undo everything.

I'm mystified.

Sean Dempsey

I've reinstalled it again from scratch and it seems to be working. However the welcome topic has been posted twice for the last new poster. Maybe that is a glitch, they might have been in the process of registering as I was doing the install. I'll post any progress.

Sean Dempsey

I've given up on this mod. After a clean install it doesn't create a welcome thread.

shadowcrew

Hi Guys,

I have searched the thread and read through (mostly) every page but cant find an answer to my problem. Until the last page, I have a similar problem to Sean Dempsey above in that my welcome message posts twice every time a new member signs up? I know its an older thread so I hope it is still being monitored by someone.

I am not sure what information would be helpful to you guys to help me find a solution but I will happily post whatever you need.

Using smf 2.0.11 with very few other mods installed.

Thank you in advance for your help.


Kindred

Chances are that you installed the mod twice...  in which case, the only solution is to manually remove the duplicated code
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

shadowcrew

November 13, 2015, 12:04:01 PM #686 Last Edit: November 13, 2015, 12:21:02 PM by shadowcrew
Quote from: Kindred on November 12, 2015, 05:33:06 PM
Chances are that you installed the mod twice...  in which case, the only solution is to manually remove the duplicated code

Thanks Kindred.

I can only see it once on my package list. I appreciate that wouldn't necessarily show me how many times it was installed. I am not sure how to remove the code manually as there is only one set of files on my server, no duplicate entries?

I guess I could just uninstall and try it again?

Thanks for your help.

EDIT: This is what it is telling me when I try to uninstall.

vbgamer45

Upload package to http://www.smfhacks.com/smf-package-parser.html and make sure edits only occur once.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

shadowcrew

Thank you vbgamer45. I will try that now.

shadowcrew

Thanks for your help. Sometimes you just need a prompt in the right direction. So on the pic I posted I clicked on the icon on the left for all three files register.php (I didnt realise you could do this) as I am new to coding and its all self taught I wasnt really sure what to do however clicking these brings up a pop up window with what you need to edit.

It asked me to find
SELECT id_member, validation_code, member_name, real_name, email_address, is_activated, passwd, lngfile, last_login
and replace with
SELECT id_member, validation_code, member_name, real_name, email_address, is_activated, passwd, lngfile

And find

   // Welcome Topic Mod

   if (empty($row['last_login']))
   {

      global $sourcedir;
      require_once($sourcedir . '/WelcomeTopic2.php');

      DoWelcomePost($row['member_name']);

   }

   // End Welcome Topic Mod


And replace with
// Let the integration know that they've been activated!
   call_integration_hook('integrate_activate', array($row['member_name']));


However I noticed that the above code was already added but the code that needed replacing was still there. I removed the code that should have been replaced in the second instance and it all seems to be working perfectly.

This is a great mod so thank you for your time and advice. Much appreciated.

Good work.

vbgamer45

Glad that you have it working!
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

jfleming40

I used Package Installer, didn't work. Ran it through the Package Parser and confirmed each change has happened, still not working... I've configured it to my liking, no luck.


Not sure what to do.

skb

I tried the same steps that "shadowcrew" & vbgamer suggested, and it worked. The duplicate Welcomes are now gone.

Thanks indeed. Much appreciated.

SMF 2.1 RC4 (default theme) / TP 2.1.0

vbgamer45

Glad you have it working!
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Ian Mc

Hoping I can get some pointers on an issue I have when this mod is installed. I'm hoping someone can send me in the right direction with what to look for as I absolutely love this mod and really want it to be working properly. Using 2.0.11

The mod installs perfectly. No duplicate entries with the code and it posts exactly where I've set it to etc.

The problem I have relates to account activation either by admin or by email. I'll try to explain as best I can.

If activation is by email the member receives the activation email, clicks on the link but the link just hangs in the browser and times out, as a result the account doesn't get activated.

If activation is by Admin, the account does activate, the welcome post is posted. But while this is going on the admin panel hangs and times out and the member doesn't receive the confirmation email.

When I remove the mod all registration methods work perfectly. No errors are shown in the log.

I'm just hoping that someone might know what file I should be looking in to find a conflict etc. If anyone could give me any pointers I'd be very grateful !!

Edit- I should also add I'm using SMTP for mail on the forum and not php (in case this is relevant)

vbgamer45

That is odd that it hangs. Does it hang if you don't have the welcome topic mod installed?
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Ian Mc

Quote from: vbgamer45 on July 07, 2016, 01:14:09 PM
That is odd that it hangs. Does it hang if you don't have the welcome topic mod installed?

Quite literally in the last ten minutes I've got it working. For some reason the Akismet Anti Spam Add On was causing the problem. After a week of trying to get this working and a clear error log, all of a sudden Akismet appeared in the error log and it was blocking the activation code!  I uninstalled Askismet and everything is working to perfection. Akismet was only interfering whilst the welcome mod was installed, no issues without the mod.

Akismet has had to go. This is a fantastic mod.

vbgamer45

Glad to know and glad you have it working
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Chaoticone

Quote from: shadowcrew on November 13, 2015, 12:55:51 PM
Thanks for your help. Sometimes you just need a prompt in the right direction. So on the pic I posted I clicked on the icon on the left for all three files register.php (I didnt realise you could do this) as I am new to coding and its all self taught I wasnt really sure what to do however clicking these brings up a pop up window with what you need to edit.

It asked me to find
SELECT id_member, validation_code, member_name, real_name, email_address, is_activated, passwd, lngfile, last_login
and replace with
SELECT id_member, validation_code, member_name, real_name, email_address, is_activated, passwd, lngfile

And find

   // Welcome Topic Mod

   if (empty($row['last_login']))
   {

      global $sourcedir;
      require_once($sourcedir . '/WelcomeTopic2.php');

      DoWelcomePost($row['member_name']);

   }

   // End Welcome Topic Mod


And replace with
// Let the integration know that they've been activated!
   call_integration_hook('integrate_activate', array($row['member_name']));


However I noticed that the above code was already added but the code that needed replacing was still there. I removed the code that should have been replaced in the second instance and it all seems to be working perfectly.

This is a great mod so thank you for your time and advice. Much appreciated.

Good work.

I was having the same issue. Each new member's first login was generating two welcome topics. In the Sources\Register.php file I found the following chunk of code.

// Let the integration know that they've been activated!
call_integration_hook('integrate_activate', array($row['member_name']));

// Welcome Topic Mod

if (empty($row['last_login']))
{

global $sourcedir;
require_once($sourcedir . '/WelcomeTopic2.php');

DoWelcomePost($row['member_name']);

}

// End Welcome Topic Mod

// Welcome Topic Mod
global $sourcedir;
require_once($sourcedir . '/WelcomeTopic2.php');

DoWelcomePost($row['member_name']);


// End Welcome Topic Mod


// Validation complete - update the database!
updateMemberData($row['id_member'], array('is_activated' => 1, 'validation_code' => ''));


I commented out the redundant bits and it seems to be working fine now (I have not tested manually registering a new member yet though). This is what the chunk of code looked like after editing.

// Let the integration know that they've been activated!
call_integration_hook('integrate_activate', array($row['member_name']));

// Welcome Topic Mod

if (empty($row['last_login']))
{

global $sourcedir;
require_once($sourcedir . '/WelcomeTopic2.php');

DoWelcomePost($row['member_name']);

}

// End Welcome Topic Mod

// Welcome Topic Mod
//global $sourcedir;
//require_once($sourcedir . '/WelcomeTopic2.php');

//DoWelcomePost($row['member_name']);


// End Welcome Topic Mod


// Validation complete - update the database!
updateMemberData($row['id_member'], array('is_activated' => 1, 'validation_code' => ''));


I'm not sure what went sideways when installing but this did happen with a single install. Anyway, its a great mod. Thanks for sharing it! I hope this helps and if I can do anything else to help narrow the issue down let me know.

SMFHacks.com Team

2.3
!Fixed bug with SMF 2.0.x with double welcome topics occurring. You must uninstall the old version first then install the new version.
Disclaimer: SMFHacks.com Team is not affiliated with the SMF Team or the SimpleMachines NPO.

http://ForumRankings.net - Get Forum Ranked!
SMFHacks.com -  Paid Modifications for SMF
Latest Mods:
Community Suite
Newsletter Pro SMF Gallery Pro SMF Classifieds SMF Store

Advertisement: