• Welcome to Simple Machines Community Forum. Please login or sign up.
December 07, 2021, 03:01:36 PM

News:

Bored?  Looking to kill some time?  Want to chat with other SMF users?  Join us in IRC chat or Discord


Πρόβλημα ελληνικών με το Felblog για TP 0.9.8

Started by dimdom, June 16, 2007, 11:28:36 AM

Previous topic - Next topic

dimdom

agridoc σε ευχαριστώ για την απάνηση που μου εστειλες στο δικο μου πιμι.

Έχω 1.1.2 και TP 0.98.

Δεν έχω πρόβλημα με τα Ελληνικά στα άρθρα του TP.

Το πρόβλημά μου εντοπίζεται με τα Ελληνικά στο FelBlog και μόνο εκεί.

Αν μπορείς να με βοηθήσεις θα το εκτιμήσω πάρα πολύ!

Σε ευχαριστώ.

(Έχω εγκαταστήσει την νέα έκδοση για 0.98 και 1.1.2 και κατά τα άλλα τα blogs δουλεύουν μία χραά).

agridoc

Δεν έχω δει το νέο Felblog. Νομίζω οτι το πρόβλημα εντοπίζεται στον editor. Χρησιμοποιείς τον FCK; Δοκίμασε τον Wizzywig και πες μου αν κάνει τα ίδια.

Δώσε περισσότερες λεπτομέρειες για το πρόβλημα.
  For Greek aeromodellers and our friends around the world  - Greek Button sets for SMF - Greeklish to Greek mod
Δeν αφιερώνω χρόνο για μηνύματα σε greeklish.

dimdom

Όπως έγραψα και σε άλλο θρεντ από το οποίο ουδέποτε έλαβα απάντηση...

I run a TP forum on 1.1.2 and TP 0.83. I installed FelBlog and everything works fine except that my forum is in Greek and all i see when i go to the blog pages is strange symbols instead of normal greek letters. If i write in english there is no problem because i use the English language from server settings which allow me to write and read right in Greek and in English too. All my sql tables works fine in utf 8 general ci and the rest of my forum displays greek letters beautifully.

So, am i doing something wrong or there is a character encoding setting somewhere in felblogs php files that i should turn it to utf-8?

Has it something to do with the "loadlanguage('FelBlog');" in felblog.php?



Με όποιον έντιτορ και να δουλέψω, τα ελληνικά στους τίτλους κάθε άρθρου στο μπλογκ, αλλά και του ίδιου του ονόματος του κάθε μπλογκ (αν ο χρήστης χρησιμοποιεί ελληνικό νικ) δεν φαίνονται σωστά.

dimdom

1. Οι έντιτορς (όλοι) γράφουν σωστά ελληνικά. Και φαίνονται σωστά. Όταν κάνεις έντιτ όμως (σε οποιονδήποτε) τα ελληνικά γίνονται κινέζικα. Οί τίτλοι των άρθρων όμως καθώς και οι τίτλοι των blogs εμφανίζονται κινέζικα.

Με τους έντιτορς του TP δεν έχω πρόβλημα, πράγμα που σημαίνει ότι το πρόβλημα είναι κάπου στην κωδικοποίηση των σελίδων του FelBlog.

dimdom

Αν θέλεις, επανεγκαθιστώ το module (το έβγαλα μόλις είδα ότι παρουσίαζε τα παραπάνω προβλήματα) γαι να το δεις κατευθείαν στο φόρουμ.

agridoc

Εχεις δίκιο, στο TP 0.9.8 υπάρχει μόνο μια τροποποίηση που πρέπει να γίνει για τον FCK editor και αυτό αφορά τον κώδικα HTML, όχι την απεικόνιση.

Εγκατέστησα το Felblog σε ένα δοκιμαστικό φόρουμ.

Κάνε την παρακάτω αλλαγή.

Στο αρχείο FelBlog.template.php (θα το βρεις στο / Themes/default)

Γραμμή 403 (Felblog 0.82)

Αντί για

<textarea rows="15" cols="50" style="width: 99%;" name="body" id="body" wrap="on">'.htmlentities($blog['body']).'</textarea>';

Βάζουμε

<textarea rows="15" cols="50" style="width: 99%;" name="body" id="body" wrap="on">'.$blog['body'].'</textarea>';

Νομίζω οτι θα μπορέσεις να το δουλέψεις έτσι.

Υπάρχουν ακόμα 7 σημεία όπου χρησιμοποιείται το htmlentities() στο FelBlog.php (στο /Sources) αλλά πρέπει να τα δω σιγά σιγά, θα επικοινωνήσω και με την Feline.
  For Greek aeromodellers and our friends around the world  - Greek Button sets for SMF - Greeklish to Greek mod
Δeν αφιερώνω χρόνο για μηνύματα σε greeklish.

dimdom

Θα κάνω αυτό που προτείνεις και θα σου απαντήσω αν δούλεψε.

Ευχαριστώ για τον κόπο σου.

dimdom

Δυστυχώς, δεν άλλαξε τίποτα (αν και χρειάστηκε να προσθέσω ένα ; στο τέλος του κώδικα.

Συνεχίζονται τα κινέζικα.

agridoc

Είδες τι παθαίνεις άμα βιάζεσαι, μου ξέφυγε το ";" στο copy - paste.  :D

Η λύση αυτή δούλεψε για windows-1253. Δεν έχω αυτή την στιγμή test install σε UTF-8.
  For Greek aeromodellers and our friends around the world  - Greek Button sets for SMF - Greeklish to Greek mod
Δeν αφιερώνω χρόνο για μηνύματα σε greeklish.

dimdom

Quote from: agridoc on June 16, 2007, 03:06:51 PM
Είδες τι παθαίνεις άμα βιάζεσαι, μου ξέφυγε το ";" στο copy - paste.  :D

Η λύση αυτή δούλεψε για windows-1253. Δεν έχω αυτή την στιγμή test install σε UTF-8.

Όντως, εγώ έχω κωδικοποίηση UTF-8.

Thanks, και περιμένω σύντομα την λύση! :)

agridoc

Εκανα ένα δοκιμαστικό test install σε UTF-8. Δυστυχώς εκεί τα πράγματα δεν είναι τόσο εύκολα. Θα χρειαστεί να ξαναγραφεί ένα μεγάλο μέρος του κώδικα (εκτός αν μου διαφεύγει κάτι απλό  ;D ).
  For Greek aeromodellers and our friends around the world  - Greek Button sets for SMF - Greeklish to Greek mod
Δeν αφιερώνω χρόνο για μηνύματα σε greeklish.

dimdom

Λοιπόν...

Εγκατέστησα την νέα έκδοση (0.85) και εν μέρει το πρόβλημα έχει λυθεί.

Τώρα εμφανίζονται σωστα τα Ελληνικά στους τίτλους και στα κείμενα αλλά:

Όταν προσπαθείς να κάνεις έντιτ τα ελληνικά εξαφανίζονται και στην θέση τους εμφανίζονται κινέζικα...

Κάτι πρέπει να αλλάξω στους έντιτορς και δεν ξέρω τι...



EDIT: Με την νέα έκδοση λύθηκαν αυτά τα προβλήματα


agridoc

Το Felblog είναι σε εξέλιξη, η Feline έγραψε οτι δοκιμάζει ένα νέο editor.

Δεν ξέρω αν θα βρω χρόνο να δω τι έχει κάνει.
  For Greek aeromodellers and our friends around the world  - Greek Button sets for SMF - Greeklish to Greek mod
Δeν αφιερώνω χρόνο για μηνύματα σε greeklish.

Advertisement: