News:

SMF 2.0.19 has been released! Please update. Read more.

Main Menu

Bookmarks

Started by Matthew K., July 16, 2007, 01:07:24 PM

Previous topic - Next topic

Illori

it installed just fine on my RC5 install, menu option included.

henrik1782

My favorite mods: Forum Firewall, httBL, MessagePreviewOnHover, BoardHover Mod, VB Style Board Index, Separate Replies and Views Column, Realtime clock by Joker, ENotify, Topic Solved.

noaccess

What do I need to change to make this work in 2.0 RC5? because right now it says that it's not made for this version.

Kindred

2.0 has an emulation option built in. Click advanced at the package manager screen
Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

noaccess

I used the emulation button, it installed without any errors. However, there is no "Add bookmarks" button, only the main my bookmarks page is visible.

Illori

then you need to manually add that button, and it should work just fine. parse the mod and find the edit then add it.

ccentre

Quote from: Illori on March 20, 2011, 07:09:18 AM
then you need to manually add that button, and it should work just fine. parse the mod and find the edit then add it.

How to add the button manually?

Kindred

run the manual-parse instructions and install the code into the appropriate template files for your custom theme.
Слaва
Украинi

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

henrik1782

QuoteHow to add the button manually?

Install the mod with emulation option.

In Display.template.php find
'reply' => array('test' => 'can_reply', 'text' => 'reply', 'image' => 'reply.gif', 'lang' => true, 'url' => $scripturl . '?action=post;topic=' . $context['current_topic'] . '.' . $context['start'] . ';last_msg=' . $context['topic_last_message'], 'active' => true),

and replace with
'reply' => array('test' => 'can_reply', 'text' => 'reply', 'image' => 'reply.gif', 'lang' => true, 'url' => $scripturl . '?action=post;topic=' . $context['current_topic'] . '.' . $context['start'] . ';last_msg=' . $context['topic_last_message'], 'active' => true),
'bookmark' => array('test' => 'can_make_bookmarks', 'text' => 'bookmark_add', 'lang' => true, 'url' => $scripturl . '?action=bookmarks;sa=add;topic=' . $context['current_topic'] . ';' . $context['session_var'] . '=' . $context['session_id']),


and everything works just fine.
My favorite mods: Forum Firewall, httBL, MessagePreviewOnHover, BoardHover Mod, VB Style Board Index, Separate Replies and Views Column, Realtime clock by Joker, ENotify, Topic Solved.

NHWD

I'm not sure if this does.. but it would be useful if it also added bookmarks to the member's list of notification topics. Does it?

Illori

no it does not. and at this time it seems like this mod is no longer supported by its author.

NHWD


cosmicxxx

my first post...

please can anybody help me out here. i have smf 1.1.11 and follow the parse file instruction for it


the problem is, the My Bookmark menu is only visible when admin account is logged in.

ive check the permission page in admin settings, but there is no settings to set for bookmarks

therefore, i cant permit any group to access the my bookmarks mod.


TomW

Quote from: cosmicxxx on April 22, 2011, 03:52:06 AM
my first post...

please can anybody help me out here. i have smf 1.1.11 and follow the parse file instruction for it


the problem is, the My Bookmark menu is only visible when admin account is logged in.

ive check the permission page in admin settings, but there is no settings to set for bookmarks

therefore, i cant permit any group to access the my bookmarks mod.

You need to set the permissions for each membergroup.  That will take care of it.

cosmicxxx

Solved!

I have custom theme... need to edit those too.

ChaosEnergy

Quote from: henrik1782 on March 30, 2011, 05:16:54 AM
QuoteHow to add the button manually?

Install the mod with emulation option.

In Display.template.php find
'reply' => array('test' => 'can_reply', 'text' => 'reply', 'image' => 'reply.gif', 'lang' => true, 'url' => $scripturl . '?action=post;topic=' . $context['current_topic'] . '.' . $context['start'] . ';last_msg=' . $context['topic_last_message'], 'active' => true),

and replace with
'reply' => array('test' => 'can_reply', 'text' => 'reply', 'image' => 'reply.gif', 'lang' => true, 'url' => $scripturl . '?action=post;topic=' . $context['current_topic'] . '.' . $context['start'] . ';last_msg=' . $context['topic_last_message'], 'active' => true),
'bookmark' => array('test' => 'can_make_bookmarks', 'text' => 'bookmark_add', 'lang' => true, 'url' => $scripturl . '?action=bookmarks;sa=add;topic=' . $context['current_topic'] . ';' . $context['session_var'] . '=' . $context['session_id']),


and everything works just fine.

Thanks, it helped for 2.0 final
Chaos Empire ®

Jessica.

#636
edit: never mind. for some reason the code to add the button didn't get applied
Testing Zone - SMF 2.0.7, default Curve
School & Chat - phpBB3, over 170 mods installed, official live forum

I use the latest version of Chrome

phpBB: Forum = a section; Board = whole site
SMF: Forum = whole site; Board = a section

lazylivin

Just wanted you to know my forum members love this mod. Hope to have it available on SMF 2.0 Gold soon.

Inti31

#638
@lazylivin
it still runs fine on 2.0 Gold...
I've implemented that mod in my testforum, everything okay...

I modified the whole package (german only) that the installation runs in standard mode (2.0 Gold)  so there is no need to use the compatible mode...

Modification-german-utf8.php

// Start  Lesezeichen
$txt['bookmarks'] = 'Meine Lesezeichen';
$txt['bookmark_list'] = 'Lesezeichen';
$txt['bookmark_list_empty'] = 'Du hast momentan keine Lesezeichen angelegt. Dies kannst du mit \'Lesezeichen hinzufügen\' in den Threads erledigen.';
$txt['bookmark_open_window'] = 'In neuem Fenster öffnen';
$txt['bookmark_delete'] = 'Lesezeichen löschen';
$txt['bookmark_delete_success'] = '%1$s Lesezeichen wurden erfolgreich gelöscht!';
$txt['bookmark_delete_failure'] = 'Nicht alle Lesezeichen konnten gelöscht werden.';
$txt['bookmark_add'] = 'Lesezeichen hinzufügen';
$txt['bookmark_add_success'] = 'Thread erfolgreich Deinen Lesezeichen hinzugefügt!';
$txt['bookmark_add_exists'] = 'Dieser Thread befindet sich bereits in Deinen Lesezeichen!';
$txt['bookmark_add_failed'] = 'Es ist ein Fehler beim Hinzufügen des Threads zu Deinen Lesezeichen aufgetreten!';
$txt['permissionname_make_bookmarks'] = 'Erstelle Lesezeichen für Theads';
$txt['cannot_make_bookmarks'] = 'Du hast keine Berechtigung, Lesezeichen zu erstellen.';
// Ende Lesezeichen
my forum
my testforum


my mods - which I only made them work for 2.0 Gold:
Topics Filter v3.2 SMF 2.0 Gold
MemberNumber

wwwserfer

Hi!

try to install this mod on SMF 1.1.14...
on pressing install ---> blank screen... & nothing...

in error logs:

Quote256: parse_path(): There should never be an empty filename
File: /home/...../site.com/docs/Sources/Subs-Package.php
Line: 1126

1024: Undefined XML attribute: destination from /home/...../site.com/docs/Sources/Subs-Package.php on line 867
File: /home/......./site.com/docs/Sources/Subs-Package.php
Line: 2365

1024: Undefined XML attribute: name from /home/....../site.com/docs/Sources/Subs-Package.php on line 861
File: /home/......./site.com/docs/Sources/Subs-Package.php
Line: 2365

v.1.1.14 not supported? or other...? ???

Advertisement: