News:

Want to get involved in developing SMF, then why not lend a hand on our github!

Main Menu

instalando mod - - consulta

Started by ignacio85r, October 21, 2014, 09:08:56 AM

Previous topic - Next topic

ArgentinaIRC

Bueno, pega aqui lo que hay en la linea 468 del mismo archivo de hace rato.

ignacio85r

Aqui esta desde la linea 464 a la 480

// Auto Embed Media Pro

$showInfo =
   
if ($showInfo == true)
    {
if (!isset($autoMediaLoaded))
{
$buffer = preg_replace('~(, Simple Machines LLC</a>)~', ', Simple Machines LLC</a><br /><a href="http://www.createaforum.com" target="_blank">Simple Audio Video Embedder</a>', $buffer);
$buffer = preg_replace('~(class="new_win">Simple Machines</a>)~', 'class="new_win">Simple Machines</a><br /><a href="http://www.createaforum.com" target="_blank">Simple Audio Video Embedder</a>', $buffer);
$autoMediaLoaded = 1;
}
}

// End Auto Embed Media Pro

// If $scripturl is set to nothing, or the SID is not defined (SSI?) just quit.

ArgentinaIRC

Borra todo lo que acabas de pegar,.borra todo eso y sobreescribi el mismo archivo de recien.

Hace un backup por las dudas.

ignacio85r

ocea lo dejo como estaba antes de la modificacion??  ???

ArgentinaIRC

No, dejalo como estaba despues, hazme caso, el.codigo estaba llamando a una funcion que no existe, por eso modificalo al que ya estaba mpdificado sin la funcion, a.eso hacele lo que te explique en mi anterior post y contame como.va.

ignacio85r

bien por lo menos veo algo ya...
pero me devuelve el siguiente error arriba del todo..



Suki

Primero hay que identificar lo que estás trantando de hacer, ¿estás tratandod einstalar o desinstalar el mod?
Si estás tratando de instalarlo entonces no deberías de quitar código, deberías de ponerlo, en tu primero error por ejemplo, si el código estaba llamando a una funciíon que no existe, es muy probable que solo tuvieras que agregar el archivo que contiene dicha función...

Utiliza el parser del mod para ver las modificaiones manuales que tienes que hacer.


Tu ultimo error es porque hay código despues del signo ?>  abre tu archivo  /Themes/default/languages/Modifications.english.php 

encuentra en signo ?> y muévelo hasta el final de archivo, no debe de haber nada después de ese signo.
Disclaimer: unless otherwise stated, all my posts are personal and does not represent any views or opinions held by Simple Machines.

Making tough decisions, so you don't have to.

ignacio85r

Lo estoy instalando... Solo q no se por que el otro usuario me dijo que quite el código

Suki

No lo sé pero la lógica indica que si estás instalando un mod y un error te dice que tu código está llamando a una función que no encuentra, significa que el archivo que contiene esa función no ha sido agregado, ya te dije antes que debes de mover todos los archivos a sus respectivas carpetas:

Quote from: Suki on October 21, 2014, 09:27:56 AM
Debes de mover los archivos indicados a la carpeta indicada:

Move the included file "AutoEmbedMediaPro2.php" to "./Sources".
Mover el archivo "AutoEmbedMediaPro2.php" a la carpeta /Sources.


El archivo AutoEmbedMediaProInstall2.php lo subes a la carpeta raiz de tu foro que es la que contiene el archivo SSI.php y lo llamas desde tu navegador para ejecutarlo:  misitio.com/foro/AutoEmbedMediaProInstall2.php

Hazlo después de haber movido todos los archivos y de haber realizado cualquier modificación manual que el mod requiera.
Disclaimer: unless otherwise stated, all my posts are personal and does not represent any views or opinions held by Simple Machines.

Making tough decisions, so you don't have to.

ignacio85r


ArgentinaIRC

Ignacio, disculpame, no me habia dado cuenta que lo estabas instalando, a pesar de estar en el titulo, disculpame no me di cuenta.

Saludos y que la Virgen te cubra con su manto.

Advertisement: