• Welcome to Simple Machines Community Forum. Please login or sign up.
January 17, 2022, 09:49:38 PM

News:

Join the Facebook Fan Page.


Errors / crash

Started by kathylene, December 19, 2007, 12:11:32 PM

Previous topic - Next topic

kathylene

Yesterday we all of the sudden started getting some memory errors and crash errors.

Database Error: Incorrect key file for table './forums_smf/smf_log_online.MYI'; try to repair it
File: /hermes/web01/b887/pow.projectjason/htdocs/forums/Sources/Subs.php
Line: 2666

Database Error: Out of memory (Needed 4194260 bytes)
File: /hermes/web01/b887/pow.projectjason/htdocs/forums/Sources/Subs.php
Line: 2666

Database Error: Table './forums_smf/smf_log_online' is marked as crashed and should be repaired
File: /hermes/web01/b887/pow.projectjason/htdocs/forums/Sources/Subs.php
Line: 2666

When I look at the subs.php file on line 2666 this is what is listed

            WHERE " . ($do_delete ? "logTime < NOW() - INTERVAL " . ($modSettings['lastActive'] * 60) . ' SECOND' : '') . ($do_delete && !empty($ID_MEMBER) ? ' OR ' : '') . (empty($ID_MEMBER) ? '' : "ID_MEMBER = $ID_MEMBER"), __FILE__, __LINE__);

We are using the default template (I just changed some of the images)


When I look at our database, everything is optimized, however several times the smf_log_online displays   'in use'  and I can't even access it in MySQL Admin.

I turned off the 'Who's Online' to see if that would help with the errors but it is not.

I've tried the "Repair" feature with both SMF and MySQL to repair the smf_log_online and it says it repairs it however, still getting problems.

Can someone help with this error? Is there a place where I can get a new smf_log_online table.


SlammedDime

Run this query in phpmyadmin... it will remove the table and then create a new one.

DROP TABLE IF EXISTS `smf_log_online`;
CREATE TABLE IF NOT EXISTS `smf_log_online` (
  `session` varchar(32) NOT NULL default '',
  `logTime` timestamp NOT NULL default CURRENT_TIMESTAMP on update CURRENT_TIMESTAMP,
  `ID_MEMBER` mediumint(8) unsigned NOT NULL default '0',
  `ip` int(10) unsigned NOT NULL default '0',
  `url` text NOT NULL,
  PRIMARY KEY  (`session`),
  KEY `logTime` (`logTime`),
  KEY `ID_MEMBER` (`ID_MEMBER`)
) ENGINE=MyISAM;
SlammedDime
Former Lead Customizer
BitBucket Projects
GeekStorage.com Hosting
                      My Mods
SimpleSEF
Ajax Quick Reply
Sitemap
more...
                     

kathylene

Thank you. I ran the script and things were okay for awhile but the errors are back.

Right now I am going to wait for our hosting server to respond to our MySQL errors. I am thinking the lead cause is the MySQL server itself since it also errors out when we try to get into MySQL Admin.

Thank you. I have bookmarked the topic and will respond back after our host takes a look at their server.


Advertisement: