Advertisement:

Author Topic: SimplePortal  (Read 1514825 times)

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 71,980
    • StoryBB/StoryBB on GitHub
Re: SimplePortal - 2.3.6 Released!
« Reply #4980 on: October 30, 2014, 02:38:25 PM »
Nope, that looks like it's a problem with the player. Also you generally should not be adding code like that directly into index.php, it will break other things.
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.

Offline Sono

  • Semi-Newbie
  • *
  • Posts: 83
Re: SimplePortal - 2.3.6 Released!
« Reply #4981 on: October 30, 2014, 02:45:37 PM »
Thanks, I will ask about it then in a Java coding forum.

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 71,980
    • StoryBB/StoryBB on GitHub
Re: SimplePortal - 2.3.6 Released!
« Reply #4982 on: October 30, 2014, 02:46:46 PM »
Just so we're clear - it's JavaScript not Java. The two are very, very different things.
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.

Offline Sono

  • Semi-Newbie
  • *
  • Posts: 83
Re: SimplePortal - 2.3.6 Released!
« Reply #4983 on: October 30, 2014, 02:59:26 PM »
Thank you! :D

Offline Padre gremista

  • Jr. Member
  • **
  • Posts: 236
  • Gender: Male
Re: SimplePortal - 2.3.6 Released!
« Reply #4984 on: October 31, 2014, 05:59:18 PM »
Is possible create a block with last posts in a board for the portal?

The blocks will be how in the image "after" that I annexed here in the post.
www.gremioemfoco.info - A comunidade gremista na internet.

Offline Bigguy

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 12,996
  • Gender: Male
  • Be nice, or else....
    • smfbigguy on GitHub
    • What's Ur Beef
Re: SimplePortal - 2.3.6 Released!
« Reply #4985 on: October 31, 2014, 10:58:30 PM »
Just wanted to say...using 2.3.6 on SMF 2.1 and they are getting along very nicely i must say. :)

Offline Padre gremista

  • Jr. Member
  • **
  • Posts: 236
  • Gender: Male
Re: SimplePortal - 2.3.6 Released!
« Reply #4986 on: November 02, 2014, 05:53:49 PM »
Nobody can help me?
www.gremioemfoco.info - A comunidade gremista na internet.

Offline Cylent1

  • Semi-Newbie
  • *
  • Posts: 46
    • Drummer Underground
Re: SimplePortal - 2.3.6 Released!
« Reply #4987 on: November 11, 2014, 11:38:31 PM »
I'm just gonna start by saying that the parse edits are not nearly correct to install into 2.0.9.
I have went through each edit, half of them were already edited, half of them were already edited and placed before what was supposed to be replaced, a couple of edits doesn't even exist in the files i'm supposed to edit.  WHAT A MESS!
I have a fresh install and default theme with no mods!  So does anybody else have this working on 2.0.9 Integrated?
If I install just like it is, there are no pretest errors and insatallation succeeds! But it will not let me use the integration feature.

Offline [SiNaN]

  • SMF Super Hero
  • *******
  • Posts: 11,526
  • Young and Foolish
    • SimplePortal
Re: SimplePortal - 2.3.6 Released!
« Reply #4988 on: November 13, 2014, 11:44:45 AM »
I just downloaded a fresh SMF 2.0.9 and SP 2.3.6. I could install it with absolutely no problems and integration mode works perfectly fine. Just remember that if you switch to the integration mode, you will need to set the display options for the blocks to be forum (or anything else like everything that covers it).
Former SMF Core Developer | My Mods | SimplePortal

Offline Cylent1

  • Semi-Newbie
  • *
  • Posts: 46
    • Drummer Underground
Re: SimplePortal - 2.3.6 Released!
« Reply #4989 on: November 13, 2014, 06:19:20 PM »
I just downloaded a fresh SMF 2.0.9 and SP 2.3.6. I could install it with absolutely no problems and integration mode works perfectly fine. Just remember that if you switch to the integration mode, you will need to set the display options for the blocks to be forum (or anything else like everything that covers it).

Yes! thanks that was my issue....  NOW SOLVED!  ;D

Offline NekoJonez

  • Full Member
  • ***
  • Posts: 503
  • Gender: Male
  • Stuff
    • @NekoJonez on Twitter
    • My blog
Re: SimplePortal - 2.3.6 Released!
« Reply #4990 on: November 17, 2014, 11:41:22 AM »
I'm curious, I added the "Who's Online" block, no issues except one visual one.

The users are listed underneath each other. I would like if they were besides each other. How do I do that?
Also, how can I show a legend of the colors that I use for the member groups?
Retro video game blogger, writer, actor, podcaster and general amazing dude.

Twitter
My Blog

Offline 420Connect.co.uk

  • Full Member
  • ***
  • Posts: 413
    • 420connect.info on Facebook
    • @4twentyconnect on Twitter
    • 420 Connect
Re: SimplePortal - 2.3.6 Released!
« Reply #4991 on: November 20, 2014, 01:01:10 PM »
I'd also be interested in implementing this ^^^^


But my own query is..

I'm only using SP as my website landing page but I'd like to change it so that clicking my forum logo will take you into the forum, rather than back to the landing page..

I don't imagine this being hard to change but can't seem to find the right file / code

As always, any help is appreciated! :)
www.420Connect.co.uk ~ A Social Network For The #CannabisCommunity ~ Come say "High" ;)

Offline Sono

  • Semi-Newbie
  • *
  • Posts: 83
Re: SimplePortal - 2.3.6 Released!
« Reply #4992 on: November 20, 2014, 06:42:13 PM »
Is it possible to make it available for a member to mark some of his new posts articles? Also: can I set an "Article" block to display the list of articles in scrollable format?

Offline MyTime

  • Jr. Member
  • **
  • Posts: 135
  • Do you remember that guy who quit?
    • The CannabisGamerClub
Re: SimplePortal - 2.3.6 Released!
« Reply #4993 on: November 24, 2014, 02:38:26 PM »
I haven't gotten a response from sp support, but I was wondering if anyone here knew how too customize it too were the blocks have a custom border added, like a textured bordered that helps it flow with the site too separate each block?

Offline Greygal

  • Semi-Newbie
  • *
  • Posts: 31
Re: SimplePortal - 2.3.6 Released!
« Reply #4994 on: November 26, 2014, 09:40:13 AM »
Attempting to install SimplePortal on 2.09, received the following error message for modifications to index.php:

Code: (Find) [Select]
      // Action and board are both empty... BoardIndex!
Code: (Replace) [Select]
      // Go catch it boy! Catch it!
      $sp_action = sportal_catch_action();
      if ($sp_action)
         return $sp_action;

      // Action and board are both empty... BoardIndex!

If someone could give me an idea where the "replace" code should be placed in index.php, I'll manually add it.  I can't find anything even remotely resembling the searched-for line on this particular edit.

That is the only error I am receiving.

Thanks in advance!

GG

EDIT:  Nevermind, I figured out what the problem is.  The search line apparently is looking for

 "      // Action and board are both empty... BoardIndex!"

followed by a blank line.  I ended up searching for "BoardIndex," found the line, added two tabs before it and a blank line after it, and the mod installed without any error messages.


Offline Herman's Mixen

  • SMF Hero
  • ******
  • Posts: 7,269
    • HermanMixen on Facebook
    • @Hermans_Mixen on Twitter
    • Herman's Mixen
Re: SimplePortal - 2.3.6 Released!
« Reply #4995 on: November 26, 2014, 09:46:16 AM »
Code: [Select]
[code snippet from the install.xml]
<modification xmlns="http://www.simplemachines.org/xml/modification" xmlns:smf="http://www.simplemachines.org/">
<id>[SiNaN]:SimplePortal</id>
<version>2.3.6</version>

<file name="$boarddir/index.php">
<operation>
<search position="replace"><![CDATA[require_once($sourcedir . '/Security.php');]]></search>
<add><![CDATA[require_once($sourcedir . '/Security.php');
require_once($sourcedir . '/Subs-Portal.php');]]></add>
</operation>
<operation>
<search position="replace"><![CDATA[ // Is the forum in maintenance mode? (doesn't apply to administrators.)
if (!empty($maintenance) && !allowedTo('admin_forum'))]]></search>
<add><![CDATA[ // Load SimplePortal.
sportal_init();

// Is the forum in maintenance mode? (doesn't apply to administrators.)
if (!empty($maintenance) && !allowedTo('admin_forum'))]]></add>
</operation>
<operation>
<search position="replace"><![CDATA[ // Action and board are both empty... BoardIndex!]]></search>
<add><![CDATA[ // Go catch it boy! Catch it!
$sp_action = sportal_catch_action();
if ($sp_action)
return $sp_action;

// Action and board are both empty... BoardIndex!]]></add>
</operation>
<operation>
<search position="replace"><![CDATA[ 'findmember' => array('Subs-Auth.php', 'JSMembers'),]]></search>
<add><![CDATA[ 'findmember' => array('Subs-Auth.php', 'JSMembers'),
'forum' => array('BoardIndex.php', 'BoardIndex'),
'portal' => array('PortalMain.php', 'sportal_main'),]]></add>
</operation>
<operation>
<search position="replace"><![CDATA[if (empty($_REQUEST['action']) || ]]></search>
<add><![CDATA[if (empty($_REQUEST['action']) || !($_REQUEST['action'] == 'portal' && isset($_GET['xml'])) && ]]></add>
</operation>
<operation>
<search position="replace"><![CDATA[ // Get the function and file to include - if it's not there, do the board index.]]></search>
<add><![CDATA[ if (!empty($context['disable_sp']))
unset($actionArray['portal'], $actionArray['forum']);

// Get the function and file to include - if it's not there, do the board index.]]></add>
</operation>
</file>


Met vriendelijke groet, The Burglar!

 House Mixes | Mixcloud | Any Intelligent fool can make things bigger, more complex, and more violent.
It takes a touch of genius - and a lot of courage - to move in the opposite direction. - Albert Einstein

Former Godfather of our dutch community ;)

Offline Greygal

  • Semi-Newbie
  • *
  • Posts: 31
Re: SimplePortal - 2.3.6 Released!
« Reply #4996 on: November 26, 2014, 09:47:50 AM »
Thanks Herman! I found it just as you posted it :)

The problem is it's searching for that line with two tabs before it and a blank line after.  Once I edited it thusly, it worked!

Thanks again!

GG

Offline Herman's Mixen

  • SMF Hero
  • ******
  • Posts: 7,269
    • HermanMixen on Facebook
    • @Hermans_Mixen on Twitter
    • Herman's Mixen
Re: SimplePortal - 2.3.6 Released!
« Reply #4997 on: November 26, 2014, 09:48:49 AM »
Your welcome :D
Met vriendelijke groet, The Burglar!

 House Mixes | Mixcloud | Any Intelligent fool can make things bigger, more complex, and more violent.
It takes a touch of genius - and a lot of courage - to move in the opposite direction. - Albert Einstein

Former Godfather of our dutch community ;)

Offline davidhs

  • Sophist Member
  • *****
  • Posts: 1,055
  • Gender: Male
Re: SimplePortal - 2.3.6 Released!
« Reply #4998 on: December 07, 2014, 01:39:48 PM »
I made a package for Spanish translation of SimplePortal 2.3.5 (based of translation 2.3.4 = 2.3.3 + new strings)

I attach this in SimplePortal website http://simpleportal.net/index.php?topic=11053.0
Language strings are same, this is valid for SimplePortal 2.3.6.

Offline lonewolfe2015

  • Newbie
  • *
  • Posts: 4
Re: SimplePortal - 2.3.6 Released!
« Reply #4999 on: December 10, 2014, 11:45:47 PM »
Just started using SimplePortal (and consequently getting readjusted to SMF after a few years away), is there anyway for me to shift the shoutbox from below the statistics area to below the forum? I'd like to have the shoutbox inbetween my forum view and my statistics/online users, etc.