Advertisement:

Author Topic: upgrade error  (Read 12135 times)

Offline junglejim42

  • Semi-Newbie
  • *
  • Posts: 44
upgrade error
« on: March 19, 2008, 09:25:45 AM »
upgrading smf 1.1.4 to 2.0 beta3



using a test forum with the same mods installed as my main forum I attempted to carry out the upgrade.  after the database upgrade was completed and I clicked continue I got the following error

: Unknown column 'a.attachmentType' in 'field list'
/home/getitri/public_html/smf5/Sources/Load.php
390

So thinking this may have something to do with having mods still installed, I carried out a fresh install of 1.1.4 and then carried out the upgrade again ending up with the same error message after clicking the continue button.  where am I going wrong, please??

when trying to view the test forum, I get the "in maintenance mode" message.
ps.  when starting the install, I had a message stating that there was older smf files still in the directory,  I selected "skip" at this point
« Last Edit: March 19, 2008, 09:28:00 AM by junglejim42 »

Offline Grudge

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 10,742
  • Gender: Male
  • Unofficial nuisance
Re: upgrade error
« Reply #1 on: March 19, 2008, 09:28:16 AM »
You have not uploaded the new 2.0 files - are you definitely using the "upgrade" set of files and not "update"
I'm only a half geek really...

Offline junglejim42

  • Semi-Newbie
  • *
  • Posts: 44
Re: upgrade error
« Reply #2 on: March 19, 2008, 09:29:26 AM »
using the file smf_2-0-beta3p_upgrade.zip

Offline junglejim42

  • Semi-Newbie
  • *
  • Posts: 44
Re: upgrade error
« Reply #3 on: March 19, 2008, 09:59:47 AM »
thought I would re-upload all files and start the upgrade again.
when starting the upgrade iwas given the option to continue from where the last upgrade stopped or to start again, so I started again.   more success this time all the way to finished, but with the following errors at the top of the final page

Notice: Undefined variable: context in /home/getitri/public_html/smf5/Themes/default/languages/index.english-utf8.php on line 46

Notice: Undefined variable: scripturl in /home/getitri/public_html/smf5/Themes/default/languages/index.english-utf8.php on line 165

Notice: Undefined variable: context in /home/getitri/public_html/smf5/Themes/default/languages/index.english-utf8.php on line 307

Notice: Undefined variable: boardurl in /home/getitri/public_html/smf5/Themes/default/languages/index.english-utf8.php on line 338

Notice: Undefined variable: scripturl in /home/getitri/public_html/smf5/Themes/default/languages/index.english-utf8.php on line 338

when trying to access the forum, i still get "in maintenance mode"

Offline junglejim42

  • Semi-Newbie
  • *
  • Posts: 44
Re: upgrade error
« Reply #4 on: March 19, 2008, 11:40:49 AM »
While waiting for a suitable reply, I've uninstalled everything and started from scratch.  still got the outdated files message at the begining which I skipped.  the installation finished with the same notices as before

Notice: Undefined variable: context in /home/getitri/public_html/smf6/Themes/default/languages/index.english-utf8.php on line 46

Notice: Undefined variable: scripturl in /home/getitri/public_html/smf6/Themes/default/languages/index.english-utf8.php on line 165

Notice: Undefined variable: context in /home/getitri/public_html/smf6/Themes/default/languages/index.english-utf8.php on line 307

Notice: Undefined variable: boardurl in /home/getitri/public_html/smf6/Themes/default/languages/index.english-utf8.php on line 338

Notice: Undefined variable: scripturl in /home/getitri/public_html/smf6/Themes/default/languages/index.english-utf8.php on line 338


do I ignore these

Offline Oldiesmann

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 24,872
  • Gender: Male
  • Ask me about the function DB :)
    • oldiesmann on Facebook
    • Oldiesmann on GitHub
    • https://www.linkedin.com/in/michaeleshom on LinkedIn
    • @oldiesmann on Twitter
    • Archie Comics Fan Forum
Re: upgrade error
« Reply #5 on: March 19, 2008, 12:08:48 PM »
Download the SMF 2.0 Beta 3 Public "upgrade" package, extract all the files to your computer and upload them to your forum directory, making sure to overwrite any existing files. After that you should run upgrade.php to ensure that all database changes are made.
Michael Eshom
Cincy Space - now open!

Offline junglejim42

  • Semi-Newbie
  • *
  • Posts: 44
Re: upgrade error
« Reply #6 on: March 19, 2008, 12:15:19 PM »
I forgot to mention on #4, the forum is actually working, it is just the notices that require clarification, whether they can be ignoredor not.

also further question
can the upgrade zip file be uploaded and then extracted.  or does if have to be extracted first before uploading

Offline IchBin™

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 11,115
  • Gender: Male
  • I don't speak German.
Re: upgrade error
« Reply #7 on: March 19, 2008, 12:16:39 PM »
You can extract after you upload with CPanel or any other tool if you have that option.
IchBin™        TinyPortal
Coding Guidelines       

Offline junglejim42

  • Semi-Newbie
  • *
  • Posts: 44
Re: upgrade error
« Reply #8 on: March 19, 2008, 12:21:40 PM »
many thanks for your help