• Welcome to Simple Machines Community Forum. Please login or sign up.

oCodeHandle has no properties

Started by dfelix, March 19, 2008, 09:50:40 PM

Previous topic - Next topic

dfelix

March 19, 2008, 09:50:40 PM Last Edit: March 19, 2008, 09:57:40 PM by dfelix
I'm struggling with 2.0 for more time than i expected...

If i install a clean version .. everything works ok.
If i upgrade from 1.1.4, everything looks ok, but none of the users has wysiwyg on by default.

When i try to Change current options for all members using this theme under the Current Theme/Member Options ... i start to get javascript errors.

Using Moz firebug...

oCodeHandle has no properties

addButton("b", "[b]", "[/b]")editor.js (line 692)

at.. oCodeHandle.instanceRef = this;
(editor.js (line 692))



Anyone got this problem?


karlbenson


dfelix

March 19, 2008, 10:23:37 PM #2 Last Edit: March 19, 2008, 10:32:42 PM by dfelix
default....

[nofollow]

flymo

I'm getting the same problem on a fresh install of 2.0 public beta 3. The WYSIWYG editor doesn't appear (as it does on simplemachines.org) and when I try to post I get the error 'the message body was left empty'. The error console shows the error in the subject line.

If I disable WYSIWYG, I can post.
--
Nick

flymo

OK I see now, you have to enable BBC code for WYSIWYG to work. That's not intuitive, but at least it works now
--
Nick

codenaught

It's basically because the WYSIWYG makes use of bbcode. When the post is submitted, it stores it using bbcode not html. If anything perhaps the one thing SMF can do is automatically disable the usage of the WYSIWYG editor if bbcode is disabled.

Going to let the developers know about this.

If you have bbcode disabled and have the WYSIWYG editor on you will get a javascript error and when you try to submit the post will get this error:

QuoteThe message body was left empty.
Dev Consultant
Former SMF Doc Coordinator

dfelix

I think it's a upgrade error...

I got this problem solved after deleting the entire default MSF theme from the upgraded site... then upload all the default template folder from de full install package.


karlbenson

For SMF staff reference.

AkaBugseyes bug report is 0001809:

Advertisement: