Advertisement:

Author Topic: Error messages in BlackRain20pb  (Read 2788 times)

Offline Powerbob

  • Full Member
  • ***
  • Posts: 673
  • Gender: Male
Error messages in BlackRain20pb
« on: March 30, 2008, 01:36:01 AM »
Hi I am receiving lots of error messages in the log;
I am using smf 2.0.b3 Public.

Quote
Apply Filter: Only show the errors with the same message
8: Undefined index: legend

Apply Filter: Only show the errors from this file

File: /home/xxx/public_html/xxx/Themes/BlackRain20bp/MessageIndex.template.php (main sub template - eval?)
Line: 392

any ideas what is causing this


Thanks

Bob



My SMF 2.1 Beta test site; http://www.pplb.net/smf21/index.php

Offline !Hachi!

  • SMF Hero
  • ******
  • Posts: 1,666
  • Gender: Male
    • pakurdu.net
Re: Error messages in BlackRain20pb
« Reply #1 on: March 30, 2008, 02:16:40 AM »
legend   any  mod related to this word?
Happy Ramadan

Offline Powerbob

  • Full Member
  • ***
  • Posts: 673
  • Gender: Male
Re: Error messages in BlackRain20pb
« Reply #2 on: March 30, 2008, 09:01:49 AM »
I have switched back to default skin for the time being.



My SMF 2.1 Beta test site; http://www.pplb.net/smf21/index.php

Offline Rumbaar

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 15,806
  • Gender: Male
  • Inherent Omniscience
    • Rumbaar.net
Re: Error messages in BlackRain20pb
« Reply #3 on: April 04, 2008, 06:32:09 PM »
Is that theme fully updated to run with SMF 2.*.  A lot of the old $txt[] strings have changed from 1.1.* to 2.* thus you'll get A LOT of undefined indexes if it's trying to find strings from the old version that are no longer in 2.*

But that being said 'legend' isn't part of the normal $txt[] strings in 1.1.* or 2.*

Try turning off Eval and finding the true source of the error, most likely in Index.template.php of your theme.  Search for 'legend'.
"An important reward for a job well done is a personal sense of worthwhile achievement."

[ Themes ]