• Welcome to Simple Machines Community Forum. Please login or sign up.
November 27, 2021, 08:51:19 AM

News:

SMF 2.1 RC4 has been released! Try it out and help us test! :) Read more.


Criical Error: Unable to find installers language file or files...

Started by prismatic, April 10, 2008, 04:56:33 PM

Previous topic - Next topic

prismatic

This is confusing, we took the tar.gz (smf_2-0-beta3p_install.tar.gz) and put it on our server and extracted the contents to our /forum directory. When we attempt to install the forum we get this,

Quote
A critical error has occurred.

This installer was unable to find the installer's language file or files. They should be found under:
/forum/Themes/default/languages

In some cases, FTP clients do not properly upload files with this many folders. Please double check to make sure you have uploaded all the files in the distribution.

If that doesn't help, please make sure this install.php file is in the same place as the Themes folder.

If you continue to get this error message, feel free to look to us for support.

What's weird is, using that EXACT same download, I can run it locally and have the installer proceed fine. I checked and the files the installer wants are in the location it says they're not. So everything is there, any ideas?

PHP Version 5.2.4
Apache/2.2.8 (Fedora)

Tested with safe mode on and off (just to see)

Any help will be appreciated, thanks guys :)

shadow82x

Try chmodding in FTP

/Themes/default/lanuges and all the files contained in it.


Also make sure all the files are displayed in there as in your download.
Colin B
Former Spammer, Customize, & Support Team Member

prismatic

The files are there and the folders are chmodded to 777. The issue appears to be the server returning an invalid $_SERVER["PHP_SELF"] variable, but I'm not sure.

shadow82x

It should be fine to ingnore the error though. Yeah like you said above it may be a minor server issue making the message be displayed. But if all the themes files are intact you should be good to go.
Colin B
Former Spammer, Customize, & Support Team Member

prismatic

Quote from: shadow82x on April 10, 2008, 06:47:36 PM
It should be fine to ingnore the error though. Yeah like you said above it may be a minor server issue making the message be displayed. But if all the themes files are intact you should be good to go.

I would love to ignore the error, unfortunately, it's  FATAL error and the installer shuts down..

Edit - Same result using the stable 1.1.4 version as well. This is a dedicated server so we can't expect any help from the host, so if anyone has any ideas we're open to em.

prismatic

Can a mod please move this to the install and upgrade help forum? Thank you :)


GOT IT WORKING

I used the web installer and it went fine. I'm still not sure what was wrong before but I thank you for taking the time to try and help :)


Advertisement: