Advertisement:

Author Topic: missing upload(file browsing) option in thread post/reply  (Read 3506 times)

Offline tican2

  • Newbie
  • *
  • Posts: 2
missing upload(file browsing) option in thread post/reply
« on: June 09, 2008, 08:47:16 PM »
We are using SMF 2 beta 3 . Somehow we could not see the option to attach file in Additional Options...  when create new thead or reply . Could someone please help us to enable this ?
Thanks

Tican2

Offline Oldiesmann

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 24,949
  • Gender: Male
  • Ask me about the function DB :)
    • oldiesmann on Facebook
    • Oldiesmann on GitHub
    • https://www.linkedin.com/in/michaeleshom on LinkedIn
    • @oldiesmann on Twitter
    • Archie Comics Fan Forum
Re: missing upload(file browsing) option in thread post/reply
« Reply #1 on: June 09, 2008, 10:25:02 PM »
First, make sure attachments are enabled:
Admin -> (Forum ->) Attachments and Avatars
Click the "Attachment Settings" tab
Select "Enable all attachments" next to "Attachments mode". Make sure "Encrypt stored filenames" is checked and set the other options to your liking.
Save the settings.


Next, give members permission to post attachments:
Admin -> (Members ->) Permissions
Click "Modify" next to a membergroup

If you're using the "Simple" permissions view:
Scroll down to the bottom, expand "Post Attachments" and check the box next to "Post Attachments"

If you're using the "Classic" permissions view:
Scroll down to the bottom
Check the box next to "View Attachments" and next to one of the "Post attachments" options

Repeat above for each membergroup.

If any boards are using custom profiles:
From the main permissions screen, click on "Board Permissions", then click on the name of the profile next to that board (you don't need to do it for the "Default" profile - the above steps will modify that profile), and repeat the above steps.
Michael Eshom
Cincy Space - now open!

Offline tican2

  • Newbie
  • *
  • Posts: 2
Re: missing upload(file browsing) option in thread post/reply
« Reply #2 on: June 10, 2008, 12:24:02 AM »
Thanks , i will check it out

Cheers,
Tican2

Offline mark299

  • Semi-Newbie
  • *
  • Posts: 24
Re: missing upload(file browsing) option in thread post/reply
« Reply #3 on: June 10, 2008, 09:33:19 AM »
First, make sure attachments are enabled:
Admin -> (Forum ->) Attachments and Avatars
Click the "Attachment Settings" tab
Select "Enable all attachments" next to "Attachments mode". Make sure "Encrypt stored filenames" is checked and set the other options to your liking.
Save the settings.


Next, give members permission to post attachments:
Admin -> (Members ->) Permissions
Click "Modify" next to a membergroup

If you're using the "Simple" permissions view:
Scroll down to the bottom, expand "Post Attachments" and check the box next to "Post Attachments"

If you're using the "Classic" permissions view:
Scroll down to the bottom
Check the box next to "View Attachments" and next to one of the "Post attachments" options

Repeat above for each membergroup.

If any boards are using custom profiles:
From the main permissions screen, click on "Board Permissions", then click on the name of the profile next to that board (you don't need to do it for the "Default" profile - the above steps will modify that profile), and repeat the above steps.


Thanks for the details. But we are facing a problem

I think its a BUG

We have enabled from before all the above steps, i have also doubled checked it, after you posted.

But it appears that none of us are getting the attachment option in the additional options. I am the admin of the forum, and even i cannot get the attachment option. If you are able to help me it would be very helpful. Thanks a lot.

Offline Rumbaar

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 15,806
  • Gender: Male
  • Inherent Omniscience
    • Rumbaar.net
Re: missing upload(file browsing) option in thread post/reply
« Reply #4 on: July 01, 2008, 06:13:23 AM »
It might be the known bug, have you set the number of attachments to 0 (ie unlimited)?  If so this will currently disable the attachments as a whole.  So set it to say 50 and you should now get the attachment option again.
"An important reward for a job well done is a personal sense of worthwhile achievement."

[ Themes ]

Offline indytechpro

  • Newbie
  • *
  • Posts: 1
Re: missing upload(file browsing) option in thread post/reply
« Reply #5 on: August 14, 2008, 11:52:45 AM »
Rumbaar, thank you, thank you for this helpful tip! I have been searching for an hour frustratingly trying to figure out why in the world I didn't have any attachment option on my SMF 2.0 Beta 3 forum. Very helpful advice.