Advertisement:

Author Topic: Database error  (Read 3048 times)

tk2012

  • Guest
Database error
« on: August 12, 2008, 06:56:43 PM »
I was on my forum browsing as normal when I hit my "HOME" tab to get back to the index.  When I did this, I was greeted with an error message:

Quote
Can't create/write to file '/var/lib/mysql/#sql_bd3_0.MYI' (Errcode: 13)
File: /var/www/html/community/Sources/Subs-Recent.php
Line: 61

I had never had an error show directly on a page previously, so of course I hit the "HOME" button again and subsequently got the same message.  I tested the other tabs one by one and everything worked, but the "FORM" button for the Custom Forms modification.  When I selected that tab, I got this error message:

Quote
Table 'motorstorm-rpms_org_community.motorstormrpms_org_community_cf_fields' doesn't exist
File: /var/www/html/community/Sources/CustomForm.php
Line: 315

I went to Admin and the settings are still listed under Modifications, but I can't edit the current forms or add new forms.

When trying to ADD a new form:
Quote
Table 'motorstorm-rpms_org_community.motorstormrpms_org_community_cf_fields' doesn't exist
File: /var/www/html/community/Sources/ManageSettings.php
Line: 2587

When trying to ACCESS a current form:
Quote
Table 'motorstorm-rpms_org_community.motorstormrpms_org_community_cf_fields' doesn't exist
File: /var/www/html/community/Sources/ManageSettings.php
Line: 2587

Now, I was thinking that it may be the Custom Forms causing this error, but when I tried to go into Admin > Forum > Boards, I was greeted with yet another error which relates to the first error when trying to obtain the index.

Quote
Can't create/write to file '/var/lib/mysql/#sql_bd3_0.MYI' (Errcode: 13)
File: /var/www/html/community/Sources/Subs-Boards.php
Line: 1038

I can get into posts that I have made by going to SEARCH and putting in a key word.  Then, I can scroll back thru the tree all the way until I would go back to the INDEX.  Then, I get the first error again.  So, I know that the rest of the forum is operating as normal and all the information is still contained.  I've even replied to my posts to check to see if new posts can be made and they can.  I even deleted my test posts, so functionality is still there.

The only other time I get an error is when I tried to make another back-up of the database.  If I try to save without the Table Structure, it will work.  If I try to save WITH the Table Structure I get the following error:

Quote
Can't create/write to file '/var/lib/mysql/#sql_bd3_0.MYI' (Errcode: 13)
File: /var/www/html/community/Sources/DumpDatabase.php
Line: 163

I've been trying to get better with learning things here, but I haven't even begun to try and understand databases.  Any assistance or help is greatly appreciated.
« Last Edit: August 15, 2008, 12:13:35 PM by tk2012 »

tk2012

  • Guest
Re: Database error
« Reply #1 on: August 13, 2008, 03:07:14 PM »
I have a backup of the forums from a day previous to this happening, but when I tried to load it I received errors about tables being missing.  Not exactly certain on that one since it was after about 4 hours of trying to figure all this stuff out and not knowing what really to do.

Offline Nathaniel

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 3,117
  • Gender: Male
    • Verbtest.com
Re: Database error
« Reply #2 on: August 13, 2008, 05:23:12 PM »
Well, for the Custom Form Mod problems, you should make sure that those tables do exist.

But overall, these problems look like issues with MySQL errors, not with SMF itself, I would recommend that you have a talk with your host.
SMF Friend (Former Support Specialist) | SimplePortal Developer
My SMF Mods | SimplePortal

"Quis custodiet ipsos custodes?" - Who will Guard the Guards?

Please don't send me ANY support related PMs. I will just delete them.

Offline karlbenson

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 15,630
  • Gender: Male
    • Lifeproof
Re: Database error
« Reply #3 on: August 13, 2008, 05:24:56 PM »
Yes you need to speak to your webhost.
You could try logging into phpmyadmin and repairing all your tables.

If that doesn't work, you may need to restart mysql (which is what I've had to do a couple of times with my server).

tk2012

  • Guest
Re: Database error
« Reply #4 on: August 13, 2008, 06:36:46 PM »
I can get into Myphpadmin on there, but would have no clue what to do...lol


I'm waiting to hear a reply from my host (Doteasy) after emailing them last night.  Am I going to lose everything that I have or???   I performed the backup thru ADMIN > MAINTENANCE > FORUM MAINTENANCE   and had all three fields checked.  I actually (hopefully luckily) did this the day before the problem happened.  Does having this backup save me from starting over at all?

tk2012

  • Guest
Re: Database error
« Reply #5 on: August 14, 2008, 09:21:12 PM »
Whewww... two days with the forum down, but all is well now.  It seems the Host did some kind of upgrade to the server which had a bad reaction with my database.  They were able to restore everything, so I think I only lost like an hour of work that I had done that day.  Much better than having to start over from scratch!!  Thanks for pointing me towards my host!!

-TK