Advertisement:

Author Topic: HELP: how to solve this error  (Read 1779 times)

Offline Angelotus

  • Sr. Member
  • ****
  • Posts: 881
  • Gender: Male
    • Weeklyfun.nl | The Dutch Society of Fun
HELP: how to solve this error
« on: August 15, 2008, 03:15:32 AM »
Code: [Select]
Unknown column 'b.id_boardNOT' in 'where clause'
File: /customers/weeklyfun.nl/weeklyfun.nl/httpd.www/forum/Sources/Recent.php
Line: 1323

I 'm getting this error on the recenttopics page. How to solve this?

Offline Nathaniel

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 3,117
  • Gender: Male
    • Verbtest.com
Re: HELP: how to solve this error
« Reply #1 on: August 15, 2008, 03:58:46 AM »
Hmm, I can't seem to duplicate this error with a clean version of SMF. If you post your Recent.php file then I may be able to isolate the issue.

Have you install any mods recently?
SMF Friend (Former Support Specialist) | SimplePortal Developer
My SMF Mods | SimplePortal

"Quis custodiet ipsos custodes?" - Who will Guard the Guards?

Please don't send me ANY support related PMs. I will just delete them.

Offline Angelotus

  • Sr. Member
  • ****
  • Posts: 881
  • Gender: Male
    • Weeklyfun.nl | The Dutch Society of Fun
Re: HELP: how to solve this error
« Reply #2 on: August 15, 2008, 04:42:01 AM »
Here  is my recent.php
Haven't installed any mods recently.

Offline Nathaniel

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 3,117
  • Gender: Male
    • Verbtest.com
Re: HELP: how to solve this error
« Reply #3 on: August 15, 2008, 05:06:50 AM »
Okay, I fixed the error. It was being caused by the Recent posts & topics extensions mod. I have attached an edited file.

I replaced this:
Code: [Select]
         AND b.id_boardNOT IN (" . implode(', ', $exclude_boards) . ")") . (!empty($include_boards) ? "
With this:
Code: [Select]
         AND b.id_board NOT IN (" . implode(', ', $exclude_boards) . ")") . (!empty($include_boards) ? "

I have reported this bug to the mod author:
http://www.simplemachines.org/community/index.php?topic=158917.msg1661631#msg1661631

That edit should stop that error from occuring, although I am not sure if the mod will actually work anyway, you will have to check it out, to see if there are any other errors. Also note that when you uninstall the mod, that particular edit will fail because the code of that file has been changed slightly. ;)
SMF Friend (Former Support Specialist) | SimplePortal Developer
My SMF Mods | SimplePortal

"Quis custodiet ipsos custodes?" - Who will Guard the Guards?

Please don't send me ANY support related PMs. I will just delete them.

Offline Angelotus

  • Sr. Member
  • ****
  • Posts: 881
  • Gender: Male
    • Weeklyfun.nl | The Dutch Society of Fun
Re: HELP: how to solve this error
« Reply #4 on: August 15, 2008, 05:20:06 AM »
Very nice, it works again. It did worked before and I never changed a thing, so why the error happens just now is a riddle to me. Thanks for solving this out!