Advertisement:

Author Topic: Menu Items not visible  (Read 4370 times)

Offline bchangia

  • Semi-Newbie
  • *
  • Posts: 28
  • Gender: Male
    • Technology Freak - Individaul's Knowledge database
Menu Items not visible
« on: August 21, 2008, 03:47:47 PM »
Hi I'm attaching a screenshot which shows the problem I'm facing.

My menu tems are no more visible. I had installed some packages, which I uninstalled but its not showing back.

Please help what should I do to solve this problem?

My language setting is changed to ENGLISH from ENGLISH-UTF8.
Bimlesh Changia

Offline ccbtimewiz

  • SMF Hero
  • ******
  • Posts: 5,300
  • Gender: Male
  • OXEN
Re: Menu Items not visible
« Reply #1 on: August 21, 2008, 03:56:09 PM »
Try clearing your forum cache.

Offline bchangia

  • Semi-Newbie
  • *
  • Posts: 28
  • Gender: Male
    • Technology Freak - Individaul's Knowledge database
Re: Menu Items not visible
« Reply #2 on: August 21, 2008, 04:00:53 PM »
Done, but didn't help  :(
Bimlesh Changia

Offline Deprecated

  • SMF Hero
  • ******
  • Posts: 3,499
Re: Menu Items not visible
« Reply #3 on: August 21, 2008, 04:11:26 PM »
You should ensure that your Admin.english.php is intact in your $language directory.

One way to test if this is the problem is to FTP to your site and change the name of the above file, add .BAK to it so you can restore it if needed, then copy over a fresh Admin.english.php from your local files. Doing this will lose any mods on that file, so you might want to inventory your mods and see which ones modified this file, if any. Any found may be the cause of the missing/corrupted file.

Or maybe not. :)

Offline bchangia

  • Semi-Newbie
  • *
  • Posts: 28
  • Gender: Male
    • Technology Freak - Individaul's Knowledge database
Re: Menu Items not visible
« Reply #4 on: August 21, 2008, 04:41:18 PM »
Thanks for the reply but it didn't help either :(
Bimlesh Changia

Offline ccbtimewiz

  • SMF Hero
  • ******
  • Posts: 5,300
  • Gender: Male
  • OXEN
Re: Menu Items not visible
« Reply #5 on: August 21, 2008, 04:42:44 PM »
The $txt[] strings are obviously missing.

Go into your FTP and replace all the language files with fresh copies then clear your forum cache and see what happens.

How do I use FTP? / What is FTP?

Offline Deprecated

  • SMF Hero
  • ******
  • Posts: 3,499
Re: Menu Items not visible
« Reply #6 on: August 21, 2008, 04:49:29 PM »
Just noting the OP says he is using UTF-8, wondering if this could be a related factor...

Offline ccbtimewiz

  • SMF Hero
  • ******
  • Posts: 5,300
  • Gender: Male
  • OXEN
Re: Menu Items not visible
« Reply #7 on: August 21, 2008, 04:55:09 PM »
Just noting the OP says he is using UTF-8, wondering if this could be a related factor...

Actually s/he stated s/he is now using English and changed from English UTF-8, according to the phrasing.

Offline Deprecated

  • SMF Hero
  • ******
  • Posts: 3,499
Re: Menu Items not visible
« Reply #8 on: August 21, 2008, 05:28:32 PM »
I was wondering if changing to/from UTF-8 could be part of the problem.

Offline bchangia

  • Semi-Newbie
  • *
  • Posts: 28
  • Gender: Male
    • Technology Freak - Individaul's Knowledge database
Re: Menu Items not visible
« Reply #9 on: August 22, 2008, 03:30:23 AM »
*ccbtimewiz

Where do I get the fresh copies from?
Bimlesh Changia

Offline Deprecated

  • SMF Hero
  • ******
  • Posts: 3,499
Re: Menu Items not visible
« Reply #10 on: August 22, 2008, 08:55:30 AM »
Not that you asked me :) but download the version of SMF that you are using to a local drive and unzip it there. Then find the files you want and FTP them to your hosting service account, overwriting the files you want to freshen.

Offline bchangia

  • Semi-Newbie
  • *
  • Posts: 28
  • Gender: Male
    • Technology Freak - Individaul's Knowledge database
Re: Menu Items not visible
« Reply #11 on: August 22, 2008, 09:24:16 AM »
Deprecated, thanks buddy, I actually took DB backup and reinstalled the forum, and ran the scripts, it works fine now, just lost the mods.
Bimlesh Changia

Offline lazanya

  • Jr. Member
  • **
  • Posts: 136
  • Gender: Male
    • Uzun kütüphane programı
Re: Menu Items not visible
« Reply #12 on: August 22, 2008, 08:39:18 PM »
I had exactly the same problem after I installed 2.0 beta on 1.1.5. No menu no action so I tried to get back to 1.1.5, but it wasn't so easy. I also got a message "a.attachmentType' in 'field list'" . Of course I backup my database, but I had to install forum 1.1.5 again. No I am afraid of installing 2.0 again.

Offline Deprecated

  • SMF Hero
  • ******
  • Posts: 3,499
Re: Menu Items not visible
« Reply #13 on: August 22, 2008, 09:57:26 PM »
Bchangia, I'm glad it worked out for you. Losing the mods is no big deal. What you learned is. :)

Lazanya at least you got good backups so you were able to restore your forum with nothing lost. Plan ahead next time and try again, and as long as you have good backups the most you will be out is a few hours of down time. Post your support questions here on the site and you will surely get some help from one or another of the many volunteers.

Offline lazanya

  • Jr. Member
  • **
  • Posts: 136
  • Gender: Male
    • Uzun kütüphane programı
Re: Menu Items not visible
« Reply #14 on: August 23, 2008, 04:23:08 AM »
be sure I will try again, but webupdate doesn't work. And when I try to upload the update package in the package install part of the forum, it says there is a problem check the FOLDER PERMISSIONS(options).  I will try.

Offline Deprecated

  • SMF Hero
  • ******
  • Posts: 3,499
Re: Menu Items not visible
« Reply #15 on: August 23, 2008, 08:27:54 AM »
Web update sounds like a clever idea (which I haven't tried) but I prefer the straight forward and simple, i.e. unzipping fresh files and uploading them to my hosting account folders.

I had a big problem when changing hosts, it turned out that SMF's FTP settings were wrong, so it couldn't set the file and folder permissions right. SMF install recommended the full host specified path for my FTP directory, but my host had it set up that my FTP login directory was / for me, although there is a longer path that I can use in the server's context.

Offline lazanya

  • Jr. Member
  • **
  • Posts: 136
  • Gender: Male
    • Uzun kütüphane programı
Re: Menu Items not visible
« Reply #16 on: August 23, 2008, 09:21:59 AM »
this time it is OK.
1. I had 1.1.5.  O downloaded "smf_2-0-beta3-1p_upgrade" files and uploaded only "deafult theme-index.php / sources / smileys-onyl deafult/ backup-index.php/ avatars-blank.gif,index.php/attachements-index.php,htaccess" Then I used upgrade.php. And then I uploaded Turkish languages file, but only deafult,index.php. Everything is okey now. I can see the all menus.  I realized that when I was installing by using upgrade.php, I press the CONTINUE button EARLY. That was the problem maybe.