• Welcome to Simple Machines Community Forum. Please login or sign up.
December 09, 2021, 12:25:48 AM

News:

SMF 2.1 RC4 has been released! Try it out and help us test! :) Read more.


RSS Feeder

Started by SlammedDime, January 11, 2009, 06:06:42 AM

Previous topic - Next topic

SlammedDime

Well you had said that there are no 'errors' in the RSS error log.... so really I assumed you meant SMF's error log, hence I asked about your hosts error log, normally available through cPanel, or there may be an error_log file in your SMF directory.

My suggestion would be to disable all feeds (easy with the one click disable/enable, just click the green check mark), then try and run the scheduled task... if it runs okay (although none will be posted), start enabling them one by one until you find the one that causes the white screen.

Let me know what happens :)
SlammedDime
Former Lead Customizer
BitBucket Projects
GeekStorage.com Hosting
                      My Mods
SimpleSEF
Ajax Quick Reply
Sitemap
more...
                     

Judgey

Hey, im getting "cURL error 7: couldn't connect to host" and then it keeps turning its self of (the rss feeder bit)



Killer-B

Quote from: SlammedDime on March 28, 2009, 01:18:01 PM
Well you had said that there are no 'errors' in the RSS error log.... so really I assumed you meant SMF's error log, hence I asked about your hosts error log, normally available through cPanel, or there may be an error_log file in your SMF directory.

My suggestion would be to disable all feeds (easy with the one click disable/enable, just click the green check mark), then try and run the scheduled task... if it runs okay (although none will be posted), start enabling them one by one until you find the one that causes the white screen.

Let me know what happens :)

Well, I meant the "scheduled tasks" error (task) log... showed no errors... but also showed no RSS activity since yesterday...

Approval Notifications  Today at 11:00:10 AM  0 seconds
Weekly Maintenance Today at 10:42:01 AM 0 seconds
Fetch Simple Machines Files Today at 10:42:01 AM 3 seconds
Weekly Notification Summary Today at 10:41:58 AM 0 seconds
Daily Notification Summary Today at 10:41:58 AM 0 seconds
Daily Maintenance Today at 10:41:58 AM 0 seconds
Approval Notifications Today at 10:41:58 AM 0 seconds
Approval Notifications Today at 09:00:10 AM 0 seconds
Approval Notifications Today at 07:00:59 AM 0 seconds
Approval Notifications Today at 05:00:58 AM 0 seconds
Approval Notifications Today at 03:00:59 AM 0 seconds
Approval Notifications Today at 01:02:58 AM 0 seconds
Approval Notifications Yesterday at 11:07:00 PM 0 seconds
Approval Notifications Yesterday at 09:01:53 PM 0 seconds
Fetch Simple Machines Files Yesterday at 08:22:02 PM 3 seconds
Approval Notifications Yesterday at 07:04:34 PM 0 seconds
Paid Subscription Checks Yesterday at 05:14:31 PM 0 seconds
Daily Maintenance Yesterday at 05:14:07 PM 0 seconds
Daily Notification Summary Yesterday at 05:11:23 PM 0 seconds
Approval Notifications Yesterday at 05:02:39 PM 0 seconds
Approval Notifications Yesterday at 03:03:13 PM 0 seconds
Approval Notifications Yesterday at 01:00:04 PM 0 seconds
Approval Notifications Yesterday at 11:02:34 AM 0 seconds
RSS Feeder Yesterday at 10:04:20 AM 1 seconds
RSS Feeder Yesterday at 09:07:03 AM 29 seconds
Approval Notifications Yesterday at 09:00:13 AM 0 seconds
RSS Feeder Yesterday at 08:00:49 AM 1 seconds
RSS Feeder Yesterday at 07:04:52 AM 15 seconds
Approval Notifications Yesterday at 07:02:07 AM 0 seconds
RSS Feeder Yesterday at 06:00:57 AM 2 seconds


I guess I'll disable them all, and see what that nets?... Is there a way to "back up" all my feeds in case I have to uninstall/reinstall the RSS mod?

And FWIW, I created an Admin account for you... but will try this first before crying on your shoulder more... It's just that today is THE first race of the season, and our busiest day... and losing all these feeds couldn't have come at a worse time :(

Thanks -

KB

SMF 2.0RC1

SlammedDime

If you have to uninstall the mod, it will not remove the feeds from the database, nor the feed log... they will all stay there. :)
SlammedDime
Former Lead Customizer
BitBucket Projects
GeekStorage.com Hosting
                      My Mods
SimpleSEF
Ajax Quick Reply
Sitemap
more...
                     

Judgey

Dont forget about me :)

SlammedDime

Just as the error stated, the mod could not connect to the host to retrieve the feed... what is the feed you're trying to use.
SlammedDime
Former Lead Customizer
BitBucket Projects
GeekStorage.com Hosting
                      My Mods
SimpleSEF
Ajax Quick Reply
Sitemap
more...
                     

Killer-B

Quote from: SlammedDime on March 28, 2009, 01:33:32 PM
If you have to uninstall the mod, it will not remove the feeds from the database, nor the feed log... they will all stay there. :)

Thanks for the tip...

I unchecked all 40+ feeds, and now it allows for Tasks to run... I put 2 or 3 feeds back in, ran it manually, and it works now...

Soooooooo - Now, I have to find the one "bad feed" that was causing it to hang -

Thanks for the prompt help

Cheers

KB
SMF 2.0RC1

mrtrc266

March 29, 2009, 12:34:51 PM #347 Last Edit: March 29, 2009, 12:45:26 PM by mrtrc266
Everything is working great except I can't seem to enter any keywords. When I put in a keyword it doesn't pull any feeds.

I went to the site that I pull the blogs from and there are blogs that contain the keywords that I use. Here is my list, does it look ok?

monster, monsters, rbcl, r.b.c.l., botc, b.o.t.c., bocl, b.o.c.l., mayhem, mash

EDIT: I even tried using just one keyword "monster" and get the same results...nothing :(

SlammedDime

What is the feed you are trying to use?

Killer - any updates?
SlammedDime
Former Lead Customizer
BitBucket Projects
GeekStorage.com Hosting
                      My Mods
SimpleSEF
Ajax Quick Reply
Sitemap
more...
                     

mrtrc266

The same as before here, It's working perfectly until I try to enter a keyword.
http://www.simplemachines.org/community/index.php?topic=285356.msg1988596#msg1988596

Killer-B

Yeah - sorry -

Like I said, I removed them all like you suggested, and that allowed me to do manual tasks... and then I loaded (enabled) them 1 by 1 till I found the culprit... Had some RSS feeds from SpeedTV - and for whatever reason, when I turn(ed) those on, it kills everything... so, I just removed them ... and is working double time.. :D  In fact, loaded some other pic feeds.. and can't keep up with all its pulling in! so - working like a champ - thanks for the help - For a moment there thought I was gonna have to fill out 40 forms from scratch again LOL-

Thanks -

KB
SMF 2.0RC1

dextrous

First off, awesome mod.

My one question--is it possible to have different update schedule for one of my feeds (it is a scorecard and should be updated regularly)? Perhaps I could install two instances of Feeder (1, 2)...is such a thing possible?

If not, how would I go about doing this manually and linking it from my forum, i.e. calling upon a RSS code full text using the "regular expression" tool?

Thanks.

SlammedDime

At this point, it's not possible to setup feeds for different schedules.  I will probably be doing that in the next version.  As for doing it manually... it wouldn't be easy... at all... there is a lot of code that is run through for just one feed, so you would have to copy it, and modify it to work with just one feed. 
SlammedDime
Former Lead Customizer
BitBucket Projects
GeekStorage.com Hosting
                      My Mods
SimpleSEF
Ajax Quick Reply
Sitemap
more...
                     

dextrous

Thanks, look forward to those changes.
Would setting it to 2 minutes for all the 5 feeds cause a lot of bandwith to be taken up by the program?

On an unrelated note, sometimes when I get the full text, there's a gap (http://cricketvoice.com/testforum/index.php?topic=68.0) -- white space on top, which is not a problem on the forum itself. But when I try do to an XML feed for that board, the same gap carries over. I'm wondering if it is possible to trim the space as a last command before it injects the text into the forum? Or maybe the XML could trim spaces; not sure which one might be easier.

Also, some feeds capture the image and others don't; any idea how I could get them all to be consistent?

Thanks, and look forward to using it on my live site (cricketvoice.com) very soon!

Vampy

Hi

I know this has been asked before but I still don't know how to get what I need. I want it to post the full article from this feed http://rss.news.yahoo.com/rss/world and not just the pic and small amount of text on the index page - what code do I have to put in to "Regular Expression - Required if retrieving full article. This must be PCRE format. The match is expected to be in second index of the array ([1])." to get it to do that?

Also I'm using a theme with a dark background, I can't see anything on the Add Feed page unless I switch to default theme - is there any way to fix this?

Thanks in advance for your kind help

SlammedDime

I don't use any special css for the add feed page, it should be using all SMF default colors based on the theme, I'll have to look into it.

As for the regular expression, have you looked at the small tutorial that is linked in the first topic of this post?
SlammedDime
Former Lead Customizer
BitBucket Projects
GeekStorage.com Hosting
                      My Mods
SimpleSEF
Ajax Quick Reply
Sitemap
more...
                     

Vampy

Yea I have - I saved and uploaded the file regex.php but all I get is 2 blank white boxes titled Regex: and Body: then a submit button

Could this all be to do with the add_settings.php file? Do I need to manually upload this file as I can't find it anywhere, and if so which folder do I need to upload it to?

SlammedDime

regex.php is only a small script to test regular expressions.  If you installed the mod already, you don't need to run add_settings.php, as that was done on install.

Did you attempt at creating any regular expressions based on my tutorial?  What was your result?
SlammedDime
Former Lead Customizer
BitBucket Projects
GeekStorage.com Hosting
                      My Mods
SimpleSEF
Ajax Quick Reply
Sitemap
more...
                     

Vampy

April 02, 2009, 03:32:04 PM #358 Last Edit: April 02, 2009, 03:57:26 PM by Vampy
I've only just found the link, they're not always easy to see LOL - I'll read it and try it out for myself and let you know how I get on - thanks

EDIT: I keep getting errors but then I don't know what to put into each box, I pretty much copied your example - this is what I wanted to try

~<div id="yn-story-secondary" class="ult-section">(.*)<\/div>~siU


mrtrc266

Try this, that worked for me.

Feed URL
http://rss.news.yahoo.com/rss/world

Regular Expression
~<div class="yn-story-content">(.*)<\/div>~siU

Advertisement: