Advertisement:

Author Topic: 2.0 rc1 problems  (Read 2973 times)

Offline Anub1s

  • Semi-Newbie
  • *
  • Posts: 68
  • Gender: Male
    • Free Web Gear
2.0 rc1 problems
« on: February 07, 2009, 02:04:38 AM »
i have encountered several problems in the last hour of using the 2.0 rc1 version

first was the fact i could not upgrade or install due to the fact that smf was saying my directory was not there. so i had to do a manual install :(

the other is now the package manager will not install anything as aparently the packages directory and files inside are not writable. i have checked this and they are.

this is confusing and the first problem i have ever had with smf :(

anyone have any ideas.


Also i would like to add that the breadcrums are doubled up :s for some strange reason.

other than these obvios problems i have seen nothing els :D will let you know though


« Last Edit: February 07, 2009, 02:49:36 AM by Anub1s »

Offline karlbenson

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 15,630
  • Gender: Male
    • Lifeproof
Re: 2.0 rc1 problems
« Reply #1 on: February 08, 2009, 01:01:20 PM »
I can't see to get the Latest packages or Package Server to work.
But it works for me if I download the package from the mod site, then click apply.

Does that work for you?

Offline 4Kstore

  • SMF Hero
  • ******
  • Posts: 4,323
  • Gender: Male
    • agustintari on Facebook
    • @agustintarifa on Twitter
    • SSIMPLE TEAM PAGE
Re: 2.0 rc1 problems
« Reply #2 on: February 08, 2009, 08:16:40 PM »
i have the same problem, my package manager not work... say Install succefull but nothing change.... all have permissions 777 in all directory... i create the folder temp but nothing change...
i work with smf 2 rc1  any help?¿
Thanks!
Sorry for my english... :(
¡¡NEW MOD: Sparkles User Names!!!

Offline sammyboy405

  • Semi-Newbie
  • *
  • Posts: 16
Re: 2.0 rc1 problems
« Reply #3 on: February 09, 2009, 04:07:16 AM »
update.php wont work. says im missing the cache directory and im not. so i tried manual update and 1/2 the sql wont update.  fourm shows its updated.  and seems to be working but some how im guessing next update I wont be able to upgrade again because this one didnt work 100%

bullbreedluverz

  • Guest
Re: 2.0 rc1 problems
« Reply #4 on: February 09, 2009, 07:13:44 AM »
i have the same problem, my package manager not work... say Install succefull but nothing change.... all have permissions 777 in all directory... i create the folder temp but nothing change...
i work with smf 2 rc1  any help?¿
Thanks!
Sorry for my english... :(

i have the same problem with packages not installing even tho they test fine and it says installed but it isnt actually installing some

when i do get 1 to install the next 1 i try to install actually installs the previous mod again so i end up with 2 of the same mod installed even tho i tried to install 2 different mods

i have all the permissions right
ive used the temp file
ive uploaded clean files/folders incase there was any corruptions from the upgrade

but all results in the same outcome

glad its a clone of my live site i upgraded and not my live site lol
« Last Edit: February 09, 2009, 07:31:49 AM by bullbreedluverz »

bullbreedluverz

  • Guest
Re: 2.0 rc1 problems
« Reply #5 on: February 09, 2009, 02:35:21 PM »
i think ive solved my problem of mods not installing, or saying they are installed and not actually installed - after the upgrade there was loads of files left over from 1.1.x and these were causing problems, for instance a mod looking for Modifications.english-utf8 was finding a 1.1.x version of the file still in the languages directory and was trying to install mods to it but as it wasnt the right file version it couldnt and caused a test failure

so on further looking thru all the files in the directory i found lots of 1.1.x files left over in them, which their was quite a few, their was back ups and files left over from old mods long since removed

since basically deleting all the old files to just leave new 1s mods seem to be installing fine now


EDIT

Ok i spoke to soon, its not working properly but i tried manually installing mods and they work fine so its the package parser not working, looks like it cant find the code to paste the edits into the files i.e.

Find

Code: [Select]
Blah blah Blaaah
Add After

Code: [Select]
La La Laaa
it dont seem to be able to find Blah Blah Blaaah to add La La Laaa after it
« Last Edit: February 09, 2009, 03:22:17 PM by bullbreedluverz »

Offline 4Kstore

  • SMF Hero
  • ******
  • Posts: 4,323
  • Gender: Male
    • agustintari on Facebook
    • @agustintarifa on Twitter
    • SSIMPLE TEAM PAGE
Re: 2.0 rc1 problems
« Reply #6 on: February 09, 2009, 11:27:03 PM »
i see lots 1.1.x files but i dont know why the upgrade dont clean this files..... and mi package manager ont work :( any solution ?
¡¡NEW MOD: Sparkles User Names!!!

bullbreedluverz

  • Guest
Re: 2.0 rc1 problems
« Reply #7 on: February 11, 2009, 02:56:09 PM »
OK ive come to find a fix for this issue but it is a long 1......

I exported a partial database from my live site;

`smf_boards`
`smf_board_permissions`
`smf_categories`
`smf_collapsed_categories`
`smf_membergroups`
`smf_members`
`smf_permissions`
`smf_pm_recipients`
`smf_topics`
`smf_personal_messages`
`smf_settings`

then created a clean install of 1.1.8
dumped the same tables as i exported above from its database
imported the above tables exported from my live site
upgraded from 1.1.8 to 2 RC1
all works fine now, packages install

bit of a pain in the arse especially as this was the 5th attempt to upgrade and ive had to go such a long way about it.......

Offline greyknight17

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 14,890
  • Gender: Male
    • Kevin's Resource Center
Re: 2.0 rc1 problems
« Reply #8 on: February 27, 2009, 10:46:59 PM »
Anub1s, is this issue resolved now?

How did you upgrade to SMF 2.0 RC1? You should get the large upgrade package and overwrite all your SMF files. Then run upgrade.php from your browser.