Advertisement:

Author Topic: Upgrading to 2.0 RC1  (Read 1120 times)

Offline clapter

  • Full Member
  • ***
  • Posts: 501
  • Gender: Male
Upgrading to 2.0 RC1
« on: February 27, 2009, 11:40:04 PM »
I wanted to upgrade, but i cannot seem to do it. Could anyone tell me how to do it manually?
Working on a Play-by-Post RPG

Offline Joey Smith™

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 6,356
  • Gender: Male
Re: Upgrading to 2.0 RC1
« Reply #1 on: February 28, 2009, 01:40:18 AM »
Uninstall all the mods you have in the 1.x then grab a large upgrade package and follow the instructions found here ;)

Upgrade SMF

Offline Gary

  • Sorceress's Knight
  • Lead Customizer
  • SMF Super Hero
  • *
  • Posts: 18,359
  • Gender: Male
  • So this is the luck of the draw...
    • Gazmanafc on Facebook
    • garygadsdon on LinkedIn
    • @Gazmanafc on Twitter
    • The Bongo Comics Fan Forum
Re: Upgrading to 2.0 RC1
« Reply #2 on: February 28, 2009, 01:46:32 AM »
You don't actually need to unistall the 1.1 mods really. The Large Upgrade package will still work even if they are still installed, and actually, I'd recommend that you leave them installed as that way you will keep the data as some mods remove it on uninstall.
Gary M. Gadsdon
Do NOT PM me unless I say so

War of the Simpsons
Bongo Comics Fan Forum
Youtube Let's Plays

^ YT is changing monetisation policy, help reach 1000 sub threshold.

Offline Joey Smith™

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 6,356
  • Gender: Male
Re: Upgrading to 2.0 RC1
« Reply #3 on: February 28, 2009, 01:49:47 AM »
True Gazmanafc in most cases but I have seen several mods cause issues in the upgrade from 2.0 Beta 4 to RC1. I imagine it could be the same from 1.x to 2.0 RC1

Offline Gary

  • Sorceress's Knight
  • Lead Customizer
  • SMF Super Hero
  • *
  • Posts: 18,359
  • Gender: Male
  • So this is the luck of the draw...
    • Gazmanafc on Facebook
    • garygadsdon on LinkedIn
    • @Gazmanafc on Twitter
    • The Bongo Comics Fan Forum
Re: Upgrading to 2.0 RC1
« Reply #4 on: February 28, 2009, 01:59:15 AM »
I've gone through the entire 2.0 line since Alpha and not once removed my mods. Granted that 1.1 mods wont work anyway, your best bet is to just skip the mod install step of the upgrader and then install the mods back in the package manager.
Gary M. Gadsdon
Do NOT PM me unless I say so

War of the Simpsons
Bongo Comics Fan Forum
Youtube Let's Plays

^ YT is changing monetisation policy, help reach 1000 sub threshold.

Offline Joey Smith™

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 6,356
  • Gender: Male
Re: Upgrading to 2.0 RC1
« Reply #5 on: February 28, 2009, 02:01:30 AM »
I agree 100% Gars (I have never uninstalled either), but none the less there are topics where several mods have caused problems during upgrades. Of course this could have been due to a dropped file in ftp, or many other reasons.... No way of knowing.. The problem was left over script from a mod in a file.. Not sure of the cause but a problem none the less.
« Last Edit: February 28, 2009, 02:03:14 AM by Tyrsson »