2.0RC1: Impossible to edit users profile

Started by Lamarck, February 08, 2009, 02:38:28 PM

Previous topic - Next topic


I updated from 2.0beta4 to 2.0RC1.Now,If I click "Forum profile" or whatever option in someone's profile (for example,to edit the signature of one of my users) I go to my "forum profile".

Also,the forum profile string was missed in the profile language file.However,the most important problem is the first: now I can't edit my forum member's profile.


PD:sorry for my bad english,I asked this is the spanish support forum but no one helped me.


Is the u=1234 in the url of the profile?
without that part, it will go to your profile
Are you using the SMF Default Core Theme?

What error are you getting in your error log?


Have you cleared the file cache in the Admin CP? (Admin CP > Maintenance > Forum Maintenance > Routine then Click "Run Task Now" under Empty the file cache)


I tried clearing the cache,but still the same problem.

No,I don't see u=1234.All URLs are like this:


I have the same problem in SMF Default Theme and in my custom themes.

Also,I have this error in the error log:

Quote8:Undefined index: forumprofile
File: /home/vol3/byethost9.com/b9_222711/silvanost.byethost31.com/htdocs/foro/Sources/Subs.php
                              Línea: 3996                            

PD:the problem is not only with the forum profile link,also with look and layout,account settings,etc all redirect to my profile.


I'm having the same problem. The options I see under in the "Modify Profile" heading are:

Account Settings
Look and Layout
Personal Messaging

The only difference is it only appears in the Energy Final theme which I'm using. The default theme is fine.



Same problem here, it works if I manually add in the user id of the profile, but when viewing another persons profile if I click on for example account settings I have to enter the member ID to get to their settings otherwise it of course take me to mine.

Any Ideas? 


Replace attached file with yours(Themes/energyfinal/GenericMenu.template.php). It's just a problem with your themes.



[email protected]

Deleting the language folder in my custom theme and using the default language from the default core theme fixed it for me, thanks for the help  :D
[nofollow] [nofollow]