Advertisement:

Author Topic: [Theme] Aqua Soft.org skin ported to SMF :)  (Read 389515 times)

Offline xenovanis

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 12,988
  • Gender: Female
Re: Aqua Soft.org skin ported to SMF :)
« Reply #100 on: April 21, 2005, 05:18:00 PM »
I think this theme looks really smooth and you did a great job on it. Wondering around your testforum I couldn't help noticing some small issues, I hope you don't mind me bringing them up here.

In the column 'lasts posts', when I hold my mouse over the arrow it says 'Show unread posts since last visit', but when I hit it it takes me to the last post in the board. Then again, if I click on the text in this column which should take me to the last post (Re: New forum style by BreathWork) it actually takes me to the first post of the thread.

Keep up the good work though, it's not that I can do a better job!  ;)
"Insanity: doing the same thing over and over again and expecting different results."

Offline Nightwish

  • Jr. Member
  • **
  • Posts: 101
  • Gender: Male
    • tabSRMM support
Re: Aqua Soft.org skin ported to SMF :)
« Reply #101 on: April 21, 2005, 07:07:11 PM »
I think this theme looks really smooth and you did a great job on it. Wondering around your testforum I couldn't help noticing some small issues, I hope you don't mind me bringing them up here.

In the column 'lasts posts', when I hold my mouse over the arrow it says 'Show unread posts since last visit', but when I hit it it takes me to the last post in the board. Then again, if I click on the text in this column which should take me to the last post (Re: New forum style by BreathWork) it actually takes me to the first post of the thread.

Keep up the good work though, it's not that I can do a better job!  ;)

That's actually a feature. The arrow does take you to the first unread post (just check the link) - like always in SMF, that only works if you're logged in so that the forum can tell which post is the "first unread" for you.

The text should take you to the beginning of the thread. That's correct.

It's similar to vBulletin which also has 2 links in the "last post" column - one takes you to the first unread and the other one (a little arrow) to the last post).
Every program has at least one bug and can be shortened by at least one instruction -- from which, by induction, one can deduce that every program can be reduced to a single instruction that doesn't work.
EoS - SMF-based forum under development.

Offline xenovanis

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 12,988
  • Gender: Female
Re: Aqua Soft.org skin ported to SMF :)
« Reply #102 on: April 21, 2005, 07:12:32 PM »
Well, sorry then  :D. Still seems a bit confusing to me but then again, I never used vBulletin so I guess it's a thing of getting used to.

Once again, great theme!
"Insanity: doing the same thing over and over again and expecting different results."

Offline Nightwish

  • Jr. Member
  • **
  • Posts: 101
  • Gender: Male
    • tabSRMM support
Re: Aqua Soft.org skin ported to SMF :)
« Reply #103 on: April 22, 2005, 01:57:05 AM »
Ok, new version is available:

Big changes, as most of you have probably already seen at my forum.

New features:

DHTML menus added. These are now all over the place, specifically, you can find them on the following pages:

1. Navigation bar (top). Search and Quicklinks are menus now (quicklinks not available for guests)
2. Message Index - "Search this Forum" and "Forum Tools" menus
3. Display - Thread Tools and Usermenu (click the username in the left column of a post)

You can disable DHTML menus by setting $settings['dhtml_menus'] to false in the index.template.php.

When using the DHTML menus, the top section of the message index is redesigned. The links are gone and the collapseable top section is gone aswell (imho, there is no need to duplicate this functionality). Also, when DHTML menus are active, a lot of buttons are absent in the MessageIndex and Display templates. All of their functionality (including moderator features) are then available in the menus.

Moderators can now be shown in their own column, both on the Board Index and for subforums within MessageIndex. Set $settings['mod_column'] to true if you want this.

Quick reply section is collapseable with the new system and remembers its state. If quick reply is collapsed, and you use it (e.g. by quoting a message), it will expand automatically.

Images changed. The Boardindex "new post indicators" are now using the default SMF images, only somewhat smaller. I think, they fit very well into an "aqua" style theme. Aqua bubbles were added to replace the star images for both global and normal moderators. Several other images where changed or slightly updated.

... and probably a lot more.

Note that you should reload after installing - the javascript file has changed significantly, also stylesheets and images are somewhat new.

I consider this theme now "final", feature-wise. I'll probably update it with some more (mostly minor) layout changes, and, of course, bug fixes (I assume, there are a few, since this theme has quite a lot new stuff). It has been in use on my forum, which isn't only a test forum and gets some few 1000 visits per day, by a few hundred registered users, so there shouldn't be major bugs.

The theme is tested with:

* Internet Explorer 6
* Opera 7.5 + 8.0 beta
* Mozilla Firefox 1.0.2/1.0.3

All the javascript works on these browsers and there are no major layout issues. The only thing is with IE6 - in the quicklinks menu, the clickable area to select the link is not extended over the entire cell. This works in other menus, but not in the quicklinks menu. I'am not sure why, but I think it's because the quicklinks menu has no images.

Also, the dynamic update of the user menu with Instant Messaging status icons does not always work in IE - seems it doesn't really like messing with innerHTML and img.src always.

As for installing - the previous version failed to install for some people when using automatic install. Not sure why - this version should be ok, it contains the theme_info.xml and is packaged properly without its own subdirectory.

Language related things

I have included a slightly modified index.english.php - for the DHTML menus mainly. I tried to re-use as much default language variables as possible, but had to add a few. So, you'll most likely have to translate them if you're using another language. The variables are at the very end of the file and it's really only a hand full :)

Download from here:

http://hell.at.eu.org/tabsrmm/SMFAQUA1_0.tgz

p.s. Thanks to the great buttongenerator - most of the images for the DHTML menus are taken from there - I hope that's ok, otherwise I'll find some other...
« Last Edit: April 26, 2005, 02:09:49 AM by Nightwish »
Every program has at least one bug and can be shortened by at least one instruction -- from which, by induction, one can deduce that every program can be reduced to a single instruction that doesn't work.
EoS - SMF-based forum under development.

Offline PopLife

  • Jr. Member
  • **
  • Posts: 336
    • Under Construction
Re: Aqua Soft.org skin ported to SMF :)
« Reply #104 on: April 22, 2005, 05:22:35 AM »
Very nice theme. When I first looked at this theme, I thought it was good, but wouldn't suit my tennis website. Now I have inspected it closely, and it looks fantastic. Just two things. 1- I too found that the theme must be manually uploaded. 2- The grey borders around the entire forums look slightly scrappy. I will just try the border with a few different colours. I think black would work.

Offline PopLife

  • Jr. Member
  • **
  • Posts: 336
    • Under Construction
Re: Aqua Soft.org skin ported to SMF :)
« Reply #105 on: April 22, 2005, 08:17:11 AM »
Sorry to double post, but why aren't any images appearing in the nav bar. Is this intentional? Or is my site just screwed?

Offline Nightwish

  • Jr. Member
  • **
  • Posts: 101
  • Gender: Male
    • tabSRMM support
Re: Aqua Soft.org skin ported to SMF :)
« Reply #106 on: April 22, 2005, 12:26:21 PM »
Sorry to double post, but why aren't any images appearing in the nav bar. Is this intentional? Or is my site just screwed?

It is intentional. The images are not included, because of possible copyright issues.
Every program has at least one bug and can be shortened by at least one instruction -- from which, by induction, one can deduce that every program can be reduced to a single instruction that doesn't work.
EoS - SMF-based forum under development.

Offline PopLife

  • Jr. Member
  • **
  • Posts: 336
    • Under Construction
Re: Aqua Soft.org skin ported to SMF :)
« Reply #107 on: April 22, 2005, 11:28:36 PM »
Is the index file pre-edited to make the images work if they were there??? Just wondering, because maybe you could put the images in the index file, but not include them. Then we can go to Aquasoft and get them ourselves.

Offline Nightwish

  • Jr. Member
  • **
  • Posts: 101
  • Gender: Male
    • tabSRMM support
Re: Aqua Soft.org skin ported to SMF :)
« Reply #108 on: April 22, 2005, 11:40:06 PM »
Is the index file pre-edited to make the images work if they were there??? Just wondering, because maybe you could put the images in the index file, but not include them. Then we can go to Aquasoft and get them ourselves.

The style sheet is responsible for this. You don't have to edit the index template, just the stylesheet :) Check out the .toolbar section..

It's really only a matter of getting the images and doing *a few* minor adjustments in the style sheet...
Every program has at least one bug and can be shortened by at least one instruction -- from which, by induction, one can deduce that every program can be reduced to a single instruction that doesn't work.
EoS - SMF-based forum under development.

Offline PopLife

  • Jr. Member
  • **
  • Posts: 336
    • Under Construction
Re: Aqua Soft.org skin ported to SMF :)
« Reply #109 on: April 23, 2005, 12:22:32 AM »
There is no style sheet  ???

Offline Nightwish

  • Jr. Member
  • **
  • Posts: 101
  • Gender: Male
    • tabSRMM support
Re: Aqua Soft.org skin ported to SMF :)
« Reply #110 on: April 23, 2005, 12:35:10 AM »
There is no style sheet  ???

There are 2 actually. aqua.css and graphite.css. Both are necessary and you should not rename or delete them.  They are basically identical with only different color schemes. The color scheme can be switched with the small images in the top right corner of the title bar.
Every program has at least one bug and can be shortened by at least one instruction -- from which, by induction, one can deduce that every program can be reduced to a single instruction that doesn't work.
EoS - SMF-based forum under development.

Offline PopLife

  • Jr. Member
  • **
  • Posts: 336
    • Under Construction
Re: Aqua Soft.org skin ported to SMF :)
« Reply #111 on: April 23, 2005, 12:39:43 AM »
OK thankyou. I thought these were just for changing catbg, titlebg etc. Thankyou. Maybe you could check out www.wtntennis.info/forums/index.php
It has a few problems

Offline Aravot

  • Sophist Member
  • *****
  • Posts: 1,057
  • Gender: Male
Re: Aqua Soft.org skin ported to SMF :)
« Reply #112 on: April 23, 2005, 12:53:05 AM »
Looks good matches with the portal colour

Offline Miraenda

  • Full Member
  • ***
  • Posts: 598
  • Gender: Female
  • nihil sunt omnia
    • RatingBar.com - Real Reviews by Regular People
Re: Aqua Soft.org skin ported to SMF :)
« Reply #113 on: April 23, 2005, 01:12:54 AM »
Is there a reason the theme doesn't work to use the typical way to install a theme which is the following (Please note that I've installed about 20 themes and this is the only one that required a different method than below to get it working):

1. Log into admin area, click on "Theme and Layout Settings" under Forum Configuration
2. Click the "Browse" button under Install a New Theme and upload the zip file, then click "Install!"
3. Theme says it is installed but then upon trying to change theme in Profile or admin section, get the error "main_above"

I found this forum post at http://www.simplemachines.org/community/index.php?topic=33993.msg252276#msg252276 and this did correct the issue, which was doing this instead:

1. Upload the zip into a folder I called "SMFAQUA1_0" at /home/user/public_html/smffolder/Themes/ and then extracted the zip there.
2. Went back to admin area, then clicked the "Theme and Layout Settings" link under Forum Configuration again.
3. Entered the path to the folder (/home/username/public_html/smffolder/Themes/SMFAQUA1_0) in the "From a directory on the server:" option under Install a New Theme and then clicked "Install!" button with it successfully working this time.

I don't think it could be because it is a zip rather than tar.gz as 1/2 of the other themes I've installed are zips too...
Thanks.

Offline Nightwish

  • Jr. Member
  • **
  • Posts: 101
  • Gender: Male
    • tabSRMM support
Re: Aqua Soft.org skin ported to SMF :)
« Reply #114 on: April 23, 2005, 01:47:36 AM »
Is there a reason the theme doesn't work to use the typical way to install a theme which is the following (Please note that I've installed about 20 themes and this is the only one that required a different method than below to get it working):

Hm, I really have NO idea why this error happens when installing the theme via the admin panel. As far as I can see, you didn't anything wrong.

I believe that it may be a packaging error, but I don't know where. The .xml is there and all the files are in the archive, also, the directory structure seems to be ok.

Maybe, someone with more experience regarding themes could take a look and find that bug :)
Every program has at least one bug and can be shortened by at least one instruction -- from which, by induction, one can deduce that every program can be reduced to a single instruction that doesn't work.
EoS - SMF-based forum under development.

Offline PopLife

  • Jr. Member
  • **
  • Posts: 336
    • Under Construction
Re: Aqua Soft.org skin ported to SMF :)
« Reply #115 on: April 23, 2005, 05:33:18 AM »
It doesn't fit into the portal correctly though. Logout is on a new line. I will try and fix it myself.

Maybe the auto installer doesn't work because there is no style.css  ???

Offline Nightwish

  • Jr. Member
  • **
  • Posts: 101
  • Gender: Male
    • tabSRMM support
Re: Aqua Soft.org skin ported to SMF :)
« Reply #116 on: April 23, 2005, 05:43:54 AM »
It doesn't fit into the portal correctly though. Logout is on a new line. I will try and fix it myself.

Maybe the auto installer doesn't work because there is no style.css  ???

The template was designed for standalone operation. Most of the pages can work with a rather low page width, but the top-toolbar needs about 600 pixels...

Missing style.css causing the troubles? Hm, maybe it confuses the installer. I could easily create a dummy style.css and check that.
Every program has at least one bug and can be shortened by at least one instruction -- from which, by induction, one can deduce that every program can be reduced to a single instruction that doesn't work.
EoS - SMF-based forum under development.

Offline PopLife

  • Jr. Member
  • **
  • Posts: 336
    • Under Construction
Re: Aqua Soft.org skin ported to SMF :)
« Reply #117 on: April 23, 2005, 06:22:56 AM »
By disabling the right hand portal, the forums fit in fine.  :D
Sorry for all the questions. The only reason I am so concerned with everything is that I love this theme so much. You did a great job, and it looks unique in it's own way.

Offline dtm.exe

  • SMF Hero
  • ******
  • Posts: 5,465
Re: Aqua Soft.org skin ported to SMF :)
« Reply #118 on: April 23, 2005, 10:07:41 AM »
OK, so NOW when is this theme scheduled to be released?  It's been like a week :(.

-Dan The Man

Offline [Unknown]

  • SMF Friend
  • SMF Master
  • *
  • Posts: 36,102
  • Gender: Male
Re: Aqua Soft.org skin ported to SMF :)
« Reply #119 on: April 23, 2005, 03:24:02 PM »
Hm, I really have NO idea why this error happens when installing the theme via the admin panel. As far as I can see, you didn't anything wrong.

I believe that it may be a packaging error, but I don't know where. The .xml is there and all the files are in the archive, also, the directory structure seems to be ok.

Maybe, someone with more experience regarding themes could take a look and find that bug :)

How high do you have your zipping settings?  SMF can only handle "regularly" compressed zip files - that means anything WinZip 6.0 can handle, really.  The new compression schemes some clients have added (particularly, WinZip 9.0, if I remember right...) are not supported.

Try lowering the compression method a notch.

-[Unknown]