• Welcome to Simple Machines Community Forum. Please login or sign up.
November 27, 2021, 02:08:24 AM

News:

Bored?  Looking to kill some time?  Want to chat with other SMF users?  Join us in IRC chat or Discord


Move Topic Notification [SMF 2.0 Supported]

Started by Nibogo, March 19, 2007, 06:58:51 PM

Previous topic - Next topic

sharks

Quote from: Nibogo on June 30, 2011, 12:44:37 PM
I've re-uploaded a package with that fix included, I didn't even tested due to lack of time, but I trust you so I just implemented
I have been using that fix ever since it was posted by HunterP, and encountered zero errors since then, so it must be right! Thanks for implementing it into the official mod package - that will make it easier for other users, especially newbies. :)

Martingonnella

Hello,

I installed your MOD on Version 2.0 Gold. Everything was successully when it installed. I click "Move Topic" and got the same OLD Move Post, etc.. see screenshot

Have I missed something in Settings, etc

I'm using the SMF Default Theme - Curve

any idea would be appreciated. Thanks

HunterP

Quote from: Martingonnella on August 02, 2011, 02:03:20 PM
I installed your MOD on Version 2.0 Gold. Everything was successully when it installed. I click "Move Topic" and got the same OLD Move Post, etc.. see screenshot

If you are testing on a topic which YOU have started, you can't notify yourself :)

BaghdadGhost

Hi,

I installed this mod without an error. It operates correctly except giving me this error in error log when me or a moderator try to move a topic


Quotehttp://xxx.com/index.php?action=movetopic;topic=1270.0
8: Undefined index: child_level
File: ../Themes/default/MoveTopic.template.php
Line: 42

this is the line

35 foreach ($context['categories'] as $category)
36 {
37 echo '
38 <optgroup label="', $category['name'], '">';
39
40 foreach ($category['boards'] as $board)
41 echo '
42 <option value="', $board['id'], '"', $board['selected'] ? ' selected="selected"' : '', $board['id'] == $context['current_board'] ? ' disabled="disabled"' : '', '>', $board['child_level'] > 0 ? str_repeat('==', $board['child_level']-1) . '=&gt; ' : '', $board['name'], '</option>';
43 echo '
44 </optgroup>';
45 }



any idea what needs to be changed to bypass the error?

thanks

BaghdadGhost

I checked all edit of this mod (only three) are all ok. the only one I did not find is this

Find: [Select]

</div>
<br />

Replace With: [Select]

</div>
<br />';
// PM Notification text.
if($context['allow_notify'])
echo '
<label for="postNotify"><input type="checkbox" name="postNotify" id="postNotify" checked="checked" onclick="document.getElementById(\'notifyArea\').style.display = this.checked ? \'block\' : \'none\';" class="check" /> ', $txt['moveTopic5'], '.</label><br />
<div id="notifyArea" style="margin-top: 1ex;">
', $txt['movetopic_notify_desc'], '<br />
<textarea name="notify" rows="5" cols="40">', $txt['movetopic_notify_default'], '</textarea><br />
</div>
<br />';
echo '

This operation isn't vital to the installation of this mod.

:-\

watchhorse

Quote from: BaghdadGhost on July 10, 2012, 01:40:24 AM
Hi,

I installed this mod without an error. It operates correctly except giving me this error in error log when me or a moderator try to move a topic


Quotehttp://xxx.com/index.php?action=movetopic;topic=1270.0
8: Undefined index: child_level
File: ../Themes/default/MoveTopic.template.php
Line: 42

this is the line

35 foreach ($context['categories'] as $category)
36 {
37 echo '
38 <optgroup label="', $category['name'], '">';
39
40 foreach ($category['boards'] as $board)
41 echo '
42 <option value="', $board['id'], '"', $board['selected'] ? ' selected="selected"' : '', $board['id'] == $context['current_board'] ? ' disabled="disabled"' : '', '>', $board['child_level'] > 0 ? str_repeat('==', $board['child_level']-1) . '=&gt; ' : '', $board['name'], '</option>';
43 echo '
44 </optgroup>';
45 }



any idea what needs to be changed to bypass the error?

thanks

I have the same problem.
Wij zoeken diergerelateerde fora ter overname.
Pb gerust als je geen tijd of zin meer hebt om uw forum te onderhouden.

demlak


DSystem

This mod is in need of a revision. I tried to use with SMF 2.07. More without success :(


klra

Quote from: DSystem on March 02, 2014, 04:23:19 PM
This mod is in need of a revision. I tried to use with SMF 2.07. More without success :(

I agree- would really like to see this updated for 2.0.7


gevv

ElkArte is a modern, powerful community building forum software. https://www.elkarte.net/

Advertisement: