• Welcome to Simple Machines Community Forum. Please login or sign up.

Tradução de MODs - Algumas linhas "guia"

Started by margarett, July 17, 2009, 10:34:14 AM

Previous topic - Next topic

margarett

July 17, 2009, 10:34:14 AM Last Edit: November 01, 2009, 12:09:59 AM by Costa
Algumas coisas úteis para "harmonizar" a tradução dos MODs que a malta for fazendo:

- Utilizar linguagem "formal". Tanto quanto possível, deve ser usado o "você" e evitado o "tu". A tradução do SMF, no geral, segue este princípio.
- Facultar sempre a tradução em ISO-8859-1 e UTF-8.
- Não utilizar caracteres acentuados directamente (ex.: à, á, ç, etc...). Nos nossos browsers isso deve funcionar na mesma por causa da codificação do SO, mas noutros vão haver problemas de visualização...

Há-de ser feito um índice com as traduções existentes...
Se forem conduzir, não bebam. Se forem beber... CHAMEM-ME!!!! :D

QuoteOver 90% of all computer problems can be traced back to the interface between the keyboard and the chair

Apllicmz




CesarManara

Quote from: margarett on July 17, 2009, 10:34:14 AM
- Não utilizar caracteres acentuados directamente (ex.: à, á, ç, etc...). Nos nossos browsers isso deve funcionar na mesma por causa da codificação do SO, mas noutros vão haver problemas de visualização...

Olá margarett, tive um problema no título das páginas. O índice ficava assim:
Sercomtel SAMP Fórum - ĺndice

Então fui no index.portuguese_brazilian.php e coloquei o acento diretamente. Como resolver sem colocar diretamente?

FragaCampos

CesarManara, tens de substituir pelos caracteres especiais em html.
Podes consultar esta página, mas existem milhares na Internet, é só procurares  ;)

CesarManara

Quote from: FragaCampos on July 26, 2009, 09:43:24 AM
CesarManara, tens de substituir pelos caracteres especiais em html.
Podes consultar esta página, mas existem milhares na Internet, é só procurares  ;)

O problema era que estava em HTML, dai ficava o Índice sendo exibido em html no browser, e não normalmente. Então fui lá e coloquei o acento diretamente, dai funcionou normal...

margarett

Se forem conduzir, não bebam. Se forem beber... CHAMEM-ME!!!! :D

QuoteOver 90% of all computer problems can be traced back to the interface between the keyboard and the chair

CesarManara


margarett

Então é estranho... Mas pode ser problema do pacote de linguagem ou um efeito cruzado de algumas definições trocadas. Isso, no geral, funciona sempre bem...

Eu tenho o meu fórum sem UTF-8, e nunca tive esse problema...

edit: experimenta o pacote de linguagem PT_PT só para ver se se mantém ;)
e entretanto tenho de dividir este tópico :P
Se forem conduzir, não bebam. Se forem beber... CHAMEM-ME!!!! :D

QuoteOver 90% of all computer problems can be traced back to the interface between the keyboard and the chair

Advertisement: